Bug 83082 - [BDW Bisected]Piglit spec_ARB_texture_multisample_sample-position_2 is core dumped
Summary: [BDW Bisected]Piglit spec_ARB_texture_multisample_sample-position_2 is core d...
Status: VERIFIED DUPLICATE of bug 83081
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: high normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-26 05:55 UTC by lu hua
Modified: 2014-09-01 01:54 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lu hua 2014-08-26 05:55:39 UTC
System Environment:
--------------------------
Platform: bdw
Libdrm:		(master)libdrm-2.4.56-10-g22b995d8cbf1059535c5de5ba1869c1623ae5b08
Mesa:		(master)306e421887720b149be77c749108bcffcebe34f6
Xserver:	(master)xorg-server-1.15.99.902-121-g2f5cf9ff9a0f713b7e038636484c77f113a5f10a
Xf86_video_intel:(master)2.99.914-68-gd209b03915e4d12ce445d72ac09bb4fe664ba664
Libva:		(master)acfcd5f0637a951d50c5112c7dfbd46f1d0dcdb3
Libva_intel_driver:(master)f3f49f2f0e6b3669d9b09341a11cf0b96e138674
Kernel:   (drm-intel-nightly)257d90d13794c2eb545ab0d6c708f21e2a0378b6

ug detailed description:
---------------------------
It fails on BDW with mesa master branch, works well on Mesa 10.3 branch.
Following cases also fail:
spec_ARB_texture_float_multisample-formats_2_GL_ARB_texture_float
spec_ARB_texture_rg_multisample-formats_2_GL_ARB_texture_rg
spec_ARB_texture_rg_multisample-formats_2_GL_ARB_texture_rg-float
spec_ARB_texture_rg_multisample-formats_2_GL_ARB_texture_rg-int

The latest known bad commit 306e421887720b149be77c749108bcffcebe34f6
The latest known good commit f80c6847e969016596b5ce3202236c15663cc61a
(It has bug 82929, bisect is slow)

output:
Floating point exception (core dumped)

(gdb) bt
#0  0x00007ffff3d53344 in get_fast_clear_rect (irb=<optimized out>, rect=0x7fffffffdc80, fb=0xd5c010, brw=0x7ffff39d7038) at brw_meta_fast_clear.c:310
#1  brw_meta_fast_clear (brw=brw@entry=0x7ffff39d7038, fb=fb@entry=0xd5c010, buffers=buffers@entry=256, partial_clear=partial_clear@entry=false) at brw_meta_fast_clear.c:512
#2  0x00007ffff3d0dc00 in brw_clear (ctx=0x7ffff39d7038, mask=256) at brw_clear.c:246
#3  0x0000000000401a31 in draw_ms_triangle (step=1, axis=0) at /GFX/Test/Piglit/piglit/tests/spec/arb_texture_multisample/sample-position.c:70
#4  0x0000000000401c59 in piglit_display () at /GFX/Test/Piglit/piglit/tests/spec/arb_texture_multisample/sample-position.c:125
#5  0x00007ffff7d8326b in run_test (gl_fw=0x604010, argc=2, argv=0x7fffffffe278) at /GFX/Test/Piglit/piglit/tests/util/piglit-framework-gl/piglit_fbo_framework.c:52
#6  0x00007ffff7d6a205 in piglit_gl_test_run (argc=2, argv=0x7fffffffe278, config=0x7fffffffe140) at /GFX/Test/Piglit/piglit/tests/util/piglit-framework-gl.c:151
#7  0x0000000000401958 in main (argc=2, argv=0x7fffffffe278) at /GFX/Test/Piglit/piglit/tests/spec/arb_texture_multisample/sample-position.c:46

Reproduce steps:
---------------------------- 
1. xinit
2. bin/arb_texture_multisample-sample-position 2 -fbo -auto
Comment 1 lu hua 2014-08-26 06:42:34 UTC
Bisect shows: 2f28a0dc23165123cf1e8b5942acad37878edd8a is the first bad commit
commit 2f28a0dc23165123cf1e8b5942acad37878edd8a
Author:     Kristian Høgsberg <krh@bitplanet.net>
AuthorDate: Mon Jul 7 16:44:58 2014 -0700
Commit:     Kristian Høgsberg <krh@bitplanet.net>
CommitDate: Fri Aug 15 11:25:47 2014 -0700

    i965: Implement fast color clears using meta operations

    This patch uses the infrastructure put in place by previous patches
    to implement fast color clears and replicated color clears in terms of
    meta operations.

    This works all the way back to gen7 where fast clear was introduced and
    adds support for fast clear on gen8.  It replaces the blorp path
    completely and improves on a few cases.  Layered clears are now done
    using instanced rendering and multiple render-target clears use a
    MRT shader with rep16 writes.

    Signed-off-by: Kristian Høgsberg <krh@bitplanet.net>
    Acked-by: Kenneth Graunke <kenneth@whitecape.org>

*** This bug has been marked as a duplicate of bug 83081 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.