Bug 83148 - Unity invisible under Ubuntu 14.04 and 14.10
Summary: Unity invisible under Ubuntu 14.04 and 14.10
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: All Linux (All)
: medium major
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords:
: 83167 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-27 13:31 UTC by Maciej
Modified: 2014-08-29 03:17 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
screenshot of the issue (1.16 MB, image/png)
2014-08-27 13:31 UTC, Maciej
Details
dmesg (59.03 KB, text/plain)
2014-08-27 13:58 UTC, Maciej
Details
Xorg.0.log (74.10 KB, text/plain)
2014-08-27 13:58 UTC, Maciej
Details
another screenshot showing corruption (79.72 KB, image/png)
2014-08-27 13:59 UTC, Maciej
Details
systemd-logind fail (1.41 MB, image/jpeg)
2014-08-27 14:06 UTC, Maciej
Details
Gabriel Mazetto's Xorg.log (68.67 KB, text/plain)
2014-08-27 18:21 UTC, Gabriel Mazetto
Details
u_vbuf: Make sure all caps are initialized (2.30 KB, patch)
2014-08-28 02:21 UTC, Michel Dänzer
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej 2014-08-27 13:31:51 UTC
Created attachment 105337 [details]
screenshot of the issue

Unity is invisible when using latest mesa git from Oibaf PPA. It started happening after update from yesterday or two days ago (updating almost daily).

Ubuntu 14.04 with kernel 3.16.1 and Ubuntu 14.10 with kernel 3.16.0.
Comment 1 Alex Deucher 2014-08-27 13:35:28 UTC
Please attach your xorg log and dmesg ouput.  Can you bisect mesa?
Comment 2 Maciej 2014-08-27 13:58:40 UTC
Created attachment 105338 [details]
dmesg
Comment 3 Maciej 2014-08-27 13:58:59 UTC
Created attachment 105339 [details]
Xorg.0.log
Comment 4 Maciej 2014-08-27 13:59:31 UTC
Created attachment 105340 [details]
another screenshot showing corruption
Comment 5 Maciej 2014-08-27 14:01:33 UTC
I have no idea how to bisect mesa tbh. I'll look into it later and see if I can manage.
Comment 6 Maciej 2014-08-27 14:06:18 UTC
Created attachment 105341 [details]
systemd-logind fail

Not sure if it's relevant, but this shows up along with latest mesa and those Unity glitches.
Comment 7 Maciej 2014-08-27 14:14:39 UTC
Comment on attachment 105340 [details]
another screenshot showing corruption

This happened after lightdm restart, suddenly Unity works, but everything else is corrupted.
Comment 8 smoki 2014-08-27 15:02:52 UTC
 Not usung Unity or Ubuntu, but i also have these ussues on Kabini, problem started with http://cgit.freedesktop.org/mesa/mesa/commit/?id=bbbe3b65adee44c164532d7afb4ff8fd8f88bbf4
Comment 9 Gabriel Mazetto 2014-08-27 18:21:04 UTC
I'm using oibaf's ppa with Ubuntu 14.04 and I can confirm that it's happening as the OP reported. (Attaching my Xorg.log to help with the ticket)
Comment 10 Gabriel Mazetto 2014-08-27 18:21:33 UTC
Created attachment 105350 [details]
Gabriel Mazetto's Xorg.log
Comment 11 Alex Deucher 2014-08-27 22:19:59 UTC
*** Bug 83167 has been marked as a duplicate of this bug. ***
Comment 12 Michel Dänzer 2014-08-28 01:20:13 UTC
(In reply to comment #8)
> [...] problem started with http://cgit.freedesktop.org/mesa/mesa/commit/
> ?id=bbbe3b65adee44c164532d7afb4ff8fd8f88bbf4

Eric, any ideas? I haven't seen this myself yet, but several people have bisected these problems to your commit above.

The only obvious semantic difference I can see before and after the patch is that before it, all formats out of a group with at least one unsupported format were converted, whereas after it, supported formats are always used directly, even if some other related formats are not supported.
Comment 13 Michel Dänzer 2014-08-28 02:21:57 UTC
Created attachment 105365 [details] [review]
u_vbuf: Make sure all caps are initialized

Does this patch help? I think caps.user_vertex_buffers being randomly 1 could explain the symptoms.
Comment 14 smoki 2014-08-28 03:31:54 UTC
(In reply to comment #13)
> Created attachment 105365 [details] [review] [review]
> u_vbuf: Make sure all caps are initialized
> 
> Does this patch help? I think caps.user_vertex_buffers being randomly 1
> could explain the symptoms.

 Yes, patch worked.
Comment 15 Maciej 2014-08-28 08:38:31 UTC
Did an updated from Oibaf PPA few minutes ago, problem fixed, thank you ;)
Comment 16 Andy Furniss 2014-08-28 09:32:02 UTC
(In reply to comment #13)
> Created attachment 105365 [details] [review] [review]
> u_vbuf: Make sure all caps are initialized
> 
> Does this patch help? I think caps.user_vertex_buffers being randomly 1
> could explain the symptoms.

Yes, fixes for me.
Comment 17 Michel Dänzer 2014-08-29 03:17:46 UTC
Module: Mesa
Branch: master
Commit: 6cd0dbc415dd092a72a8941c45ba812b9fe74b24
URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=6cd0dbc415dd092a72a8941c45ba812b9fe74b24

Author: Michel Dänzer <michel.daenzer@amd.com>
Date:   Thu Aug 28 11:12:20 2014 +0900

u_vbuf: Make sure all caps are initialized


bug/show.html.tmpl processed on Jan 16, 2017 at 21:49:23.
(provided by the Example extension).