Bug 83167 - Xorg rendering faliure since u_vbuf: Simplify the format fallback translation
Summary: Xorg rendering faliure since u_vbuf: Simplify the format fallback translation
Status: RESOLVED DUPLICATE of bug 83148
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-27 22:12 UTC by Andy Furniss
Modified: 2014-08-27 22:19 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Furniss 2014-08-27 22:12:31 UTC
R9270X kernel drm-fixes-3.17-wip xorg Jun, but ddx/glamor head.

Tentatively, since -

commit bbbe3b65adee44c164532d7afb4ff8fd8f88bbf4
Author: Eric Anholt <eric@anholt.net>
Date:   Fri Aug 22 10:34:55 2014 -0700

    u_vbuf: Simplify the format fallback translation.
    
    Individual caps made supporting new fallbacks more complicated than it
    needed to be.  Instead, just make a table of fallbacks at context init
    time.
    
    v2: Fix inverted "do we need to install vbuf?" flagging caught by Marek.

There is a chance when I startx that rendering will be broken.

Fluxbox menues empty, screen black, can blindly use menu to start an xterm.

xterm OK at first look - maximised OK dmesg worked and showed nothing strange, but trying to scroll up only updated the top 5 lines scrolling down only bottom 5.

tool bar and menu bar not being cleared, nothing rendered with glxgears.

mplayer video just first frame status line progressing as if normal.

This doesn't always happen, need quit/restart X several times to get bad during bisect. Goods were tested 20 ish times so there's a small chance I got a false good.

Xorg log normal.
Comment 1 Alex Deucher 2014-08-27 22:19:59 UTC

*** This bug has been marked as a duplicate of bug 83148 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.