Bug 83205 - GPU lockup when entering settings in Verdun game with HyperZ enabled
Summary: GPU lockup when entering settings in Verdun game with HyperZ enabled
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: Other Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
Depends on:
Blocks: 75112
  Show dependency treegraph
Reported: 2014-08-28 18:21 UTC by Clément Guérin
Modified: 2014-09-01 19:58 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Description Clément Guérin 2014-08-28 18:21:31 UTC
When playing Verdun (http://store.steampowered.com/app/242860/), every time I go to the settings I get a GPU lockup. Without R600_DEBUG=hyperz everything is fine.

I'm using mesa 4ca203f, llvm 216658, xorg-server 1.16, xf86-video-ati 7.4.0 on Arch Linux. I tried on Linux 3.14, 3.16 and 3.17rc2 with the same results. My graphics card is a HD 7950.

Here's my journalctl log: http://pastebin.com/s80VLPtr
Comment 1 Hohahiu 2014-08-29 00:28:46 UTC
Hi, Clément,
Marek recently posted patches [1] which are supposed to fix a hang with hyperz. Could you test them? Also there are some other patches which fix rendering with hyperz enabled [2]. As far as I understand these two series were reviewed by not yet mainlined. 
[1] http://lists.freedesktop.org/archives/mesa-dev/2014-August/066519.html
[2] http://lists.freedesktop.org/archives/mesa-dev/2014-August/066389.html
Comment 2 Marek Olšák 2014-08-29 11:06:15 UTC
Please apply both patches mentioned above and test again. If it still hangs, please record a trace file with apitrace (the recording can be done with hyperz disabled, but please make it as small as possible).

Comment 3 smoki 2014-08-29 11:20:09 UTC
 It is obvious but just as reminder, second patch Hohahiu linked is for evergreen you need this one for radeonsi instead:

Comment 4 Clément Guérin 2014-08-29 11:35:09 UTC
Thanks for the pointers. I will try as soon as I can.
Comment 5 Clément Guérin 2014-08-30 09:43:17 UTC
Alright, so I compiled lib32-mesa-git from here http://pkgbuild.com/~lcarlier/mesa-git/ with the two patches for radeonsi. It doesn't crash anymore with HyperZ enabled.

I can't be 100% sure though, because Steam managed to update the game just before I launched it. A very minor upgrade, so I assume the issue is fixed.

I guess it's time to reenable HyperZ by default, because it's the only issue I ever had with all the games I tried so far. I will try Brütal Legend now.
Comment 6 Clément Guérin 2014-08-30 10:38:53 UTC
I reverted to lib32-mesa-git 4ca203f and the issue reappeared. So the fix is definitely working! Great job guys. :)
Comment 7 Clément Guérin 2014-09-01 19:58:36 UTC
Marking as RESOLVED FIXED since the fix has just been merged. Keep up the good work!

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.