Bug 85626 - [BYT] Screen light down when CPU hangs during running Team Fortress 2
Summary: [BYT] Screen light down when CPU hangs during running Team Fortress 2
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-30 02:26 UTC by lili
Modified: 2015-02-03 07:54 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg.log (663 bytes, text/plain)
2014-10-30 02:26 UTC, lili
Details
dmesg.log (11.22 KB, text/plain)
2014-10-30 02:59 UTC, lili
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lili 2014-10-30 02:26:36 UTC
Created attachment 108667 [details]
dmesg.log

Environment:
-----------------------------------
Platform:BYT
Libdrm:(master)libdrm-2.4.58-4-g00847fa48b83a85b0cb882594a12ed1511f780db
Mesa:(master)1a170980a09d82201b88e3fe20684a0df2cfea80
Xserver:(master)xorg-server-1.16.0-429-gd181e52ceb9ae44e1faa8d5af8805f43328da6c2
Xf86_video_intel:(master)2.99.916-118-gd08a5f555a0c47ae23c0f9a890b512cb23e74feb
Cairo:(master)f9b65ae1fc91bc558a01c2ad7be5a121c6f10818
Libva:(master)ccd93de5a707e92a629cccd595757c8d436fa3cc
Libva_intel_driver:(master)f11176415ec26eb5960ba6841d2d9c22f2cabc60
Kernel:(drm-intel-nightly)88a443f454a4d8f779a9bff51f2ef334f5f69372

Bug detailed description:
---------------------------------------------
Screen light down when CPU hangs during running Team Fortress 2 on BYT,reproduce rate:60%.
Please refer to dmesg.log for detail.

Reproduce steps:
---------------------------------------------
1.xinit&
2.vblank_mode=0 ./hl2.sh -game tf +cl_showfps 1 -fullscreen -novid +timedemoquit pts2 -full -w 1920 -h 1080
Comment 1 lili 2014-10-30 02:59:49 UTC
Created attachment 108668 [details]
dmesg.log
Comment 2 lili 2014-10-30 03:01:32 UTC
(In reply to lili from comment #1)
> Created attachment 108668 [details]
dmesg.log

Attach the whole dmesg.log,thanks!
Comment 3 Jani Nikula 2015-01-29 14:18:16 UTC
Please retest on current drm-intel-nightly.

Please *never* use rar for compression. Attach plain text files if possible.

For GPU hangs, always attach the error state.
Comment 4 Ding Heng 2015-01-30 05:41:41 UTC
vblank_mode=0 ./hl2.sh -game tf +cl_showfps 1 -fullscreen -novid +timedemoquit pts2 -full -w 1920 -h 1080
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  153 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  85
  Current serial number in output stream:  86
Comment 5 Jani Nikula 2015-01-30 07:13:24 UTC
Is there a GPU hang?
Comment 6 ye.tian 2015-01-30 07:58:58 UTC
No GPU hang.
This bug is similar to bug 88862.
Comment 7 Jani Nikula 2015-01-30 08:32:35 UTC
(In reply to ye.tian from comment #6)
> No GPU hang.
> This bug is similar to bug 88862.

Okay, marking as duplicate. I don't really see anything kernel related in this one.

*** This bug has been marked as a duplicate of bug 88862 ***
Comment 8 ye.tian 2015-01-30 08:55:19 UTC
these 2 bugs (85626 and 88862) are very similar, but still not same.
Can't as duplicate.
Bug 88862 is good on commit (master)bc6e57e019b mesa,but bug 85626 is failed.
Comment 9 Jani Nikula 2015-01-30 10:17:40 UTC
(In reply to ye.tian from comment #8)
> these 2 bugs (85626 and 88862) are very similar, but still not same.
> Can't as duplicate.
> Bug 88862 is good on commit (master)bc6e57e019b mesa,but bug 85626 is failed.

*shrug* the failure mode is similar to bug 88842 too. Reassigning.
Comment 10 Tapani Pälli 2015-02-02 06:51:22 UTC
maybe same issue as with bug #88862 ?
Comment 11 ye.tian 2015-02-03 03:23:33 UTC
I've tested this game six times with the latest mesa, this issue does not appear.
maybe same issue as with bug 88862.
Anyway,I close this bug.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.