Bug 88862 - [ BYT regression]Doom3 fail to run with libGL error
Summary: [ BYT regression]Doom3 fail to run with libGL error
Status: CLOSED NOTOURBUG
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: high normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-29 09:05 UTC by ye.tian
Modified: 2015-02-02 06:43 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg info (17.21 KB, text/plain)
2015-01-29 09:05 UTC, ye.tian
Details
good glxinfo info (19.07 KB, text/plain)
2015-01-30 08:41 UTC, ye.tian
Details
failed glxinfo info (19.07 KB, text/plain)
2015-01-30 08:43 UTC, ye.tian
Details
doom3 run log info (12.83 KB, text/plain)
2015-01-30 08:45 UTC, ye.tian
Details
doom3-pts.cfg info (3.86 KB, text/plain)
2015-01-31 05:03 UTC, ye.tian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ye.tian 2015-01-29 09:05:11 UTC
Created attachment 112934 [details]
Xorg info

System Environment:       
--------------------------------------------------------------
Kernel:  (drm-intel-nightly)70438b51bdd44180b83f10591c3bdc1832d11dc2
Libdrm:  (master)libdrm-2.4.59-6-g28ee135a37e10b9a6cd62d67df0332e38ee0b85c
Mesa:    (master)6ee5effac1ac8858c96820ece352be57c5c53cf6
Xserver: (master)xorg-server-1.16.99.902-3-gdf1b401f57ad4b4925bad66684445b476562f26f
Xf86_video_intel: (master)2.99.917-60-g4bbd1023675f4724bd17de50dd750514626104bf
Cairo:   (master)cca8b1960b0091c53235d9dc4cde8a33010c5bbf
Libva:   (master)f9741725839ea144e9a6a1827f74503ee39946c3
Libva_intel_driver: (master)3d16cf07b6b65b9bd5c2dd855d97558264a12e79
 
Bug detailed description:
--------------------------------------------------
Doom3 fail to run with libGL error on BYT.
Error information: 
----- R_InitOpenGL -----
Setup X display connection
dlopen(libGL.so.1)
Initializing OpenGL display
Using XFree86-VidModeExtension Version 2.2
DGA DirectVideo Mouse (Version 2.0) initialized
Free86-VidModeExtension Activated at 1920x1080
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
Using 8/8/8 Color bits, 8 Alpha bits, 24 depth, 8 stencil display.
Fatal X Error:
  Major opcode of failed request: 153
  Minor opcode of failed request: 3
  Serial number of failed request: 50
BadValue (integer parameter out of range for operation)
Fatal X Error:
  Major opcode of failed request: 153
  Minor opcode of failed request: 5
  Serial number of failed request: 52
GLXBadContext
Fatal X Error:
  Major opcode of failed request: 153
  Minor opcode of failed request: 26
  Serial number of failed request: 52
0
GL_RENDERER: (null)
GL_EXTENSIONS: (null)
It’s mesa regression, I found the good commit and bad commit as below, note: first bad commit can not provide as several commits cannot make pass in the bisect progress.
Good commit: (master)bc6e57e019bd2399a70acabcad21217aadf2944c
Bad  commit: (master)461103ef64858e9d81073fad1bd8222b70b2754b

Please see Xrog.

Reproduce steps:
----------------------------
1, xinit& 
2, gnome-session&
3, vblank_mode=0 ./doom.x86 +exec doom3-pts.cfg +set sys_VideoRam 64 +set r_mode -1 +timedemoquit demo1 +set  r_customWidth 1920 +set r_customHeight 1080 +set com_machineSpec 1
Comment 1 Tapani Pälli 2015-01-30 07:12:43 UTC
> libGL error: unable to load driver: i965_dri.so

This seems strange, there nothing between the mentioned commits touching area that would affect dri driver loader, just some gbm changes. Could you try again and see if the driver was compiled and installed succesfully? Is there i965_dri.so available in the driver install location?
Comment 2 Tapani Pälli 2015-01-30 07:13:38 UTC
Also, are you able to run any other applications than doom3 with this setup?
Comment 3 Jani Nikula 2015-01-30 08:32:35 UTC
*** Bug 85626 has been marked as a duplicate of this bug. ***
Comment 4 ye.tian 2015-01-30 08:40:51 UTC
It can run on commit (master)bc6e57e019b.
but Team Fortress 2 was failed on this commit.
please see the glxinfo and etqw-demo run log.
Comment 5 ye.tian 2015-01-30 08:41:54 UTC
Created attachment 112965 [details]
good glxinfo info
Comment 6 ye.tian 2015-01-30 08:43:51 UTC
Created attachment 112966 [details]
failed glxinfo info
Comment 7 ye.tian 2015-01-30 08:45:19 UTC
Created attachment 112967 [details]
doom3 run log info
Comment 8 Tapani Pälli 2015-01-30 12:11:47 UTC
I don't have "doom3-pts.cfg" but I can run doom3 on Baytrail NUC with Mesa master (083fb21) with the resolutions it provides in the game gui.
Comment 9 Tapani Pälli 2015-01-30 12:19:45 UTC
Some more information, I'm running it with Ubuntu 14.10 which has kernel 3.16.0-29, Xorg 1.16.0 (with SNA).
Comment 10 ye.tian 2015-01-31 04:33:40 UTC
(In reply to Tapani Pälli from comment #2)
> Also, are you able to run any other applications than doom3 with this setup?

yes,I am able to run OpenArena/Padman/Warsow with this setup.
Comment 11 ye.tian 2015-01-31 05:03:52 UTC
Created attachment 112994 [details]
doom3-pts.cfg info
Comment 12 ye.tian 2015-01-31 05:07:05 UTC
(In reply to Tapani Pälli from comment #8)
> I don't have "doom3-pts.cfg" but I can run doom3 on Baytrail NUC with Mesa
> master (083fb21) with the resolutions it provides in the game gui.

BYT processor is N2820 [8086:0f31] (rev 0c).
Comment 13 ye.tian 2015-01-31 05:52:54 UTC
it also can't run on processor N3520 and J2900.
Comment 14 wendy.wang 2015-02-02 06:43:11 UTC
After 2015 Jan 16, 32bit game running need libcrypto.so.10, while without this lib, will encounter 32bit game cannot run problem.

Close this sightling as not our bug.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.