Bug 86398 - displays some application icons in huge size
Summary: displays some application icons in huge size
Status: RESOLVED FIXED
Alias: None
Product: PulseAudio
Classification: Unclassified
Component: pavucontrol (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: pulseaudio-bugs
QA Contact: pulseaudio-bugs
URL: https://bugs.debian.org/cgi-bin/bugre...
Whiteboard:
Keywords:
: 95228 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-11-17 14:48 UTC by Felipe Sateler
Modified: 2016-05-01 17:29 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
screenshot (201.70 KB, image/png)
2014-11-17 14:48 UTC, Felipe Sateler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Felipe Sateler 2014-11-17 14:48:41 UTC
Created attachment 109625 [details]
screenshot

Forwarding a bug from the debian bug tracker.

== Begin paste

there is a problem with GTK 3.14 in jessie which results in some [1] (svg?)
application icons in pavucontrol being displayed in huge size which also
affects pavucontrol, see:
  https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=765069#49
(tested with jessie from 2014-11-08)

[1] i.e. scummvm

debian-gtk-gnome@lists.debian.org told me to file a bug against each
application that shows this issue:

> Apparently this was an intentional change in GTK+ 3.14, see
>
> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=765069#49
>
> I haven't looked at the impact of it and whether it's reasonable and
> feasible to revert it for Jessie. For now, it's probably best to file bugs
> for the applications that broke.
>
> Emilio

== End paste

I can confirm that scummvm in debian creates a huge icon (see attached image. The bug is fixed if I apply the following diff:

diff --git a/src/mainwindow.cc b/src/mainwindow.cc
index ec07b96..c39588e 100644
--- a/src/mainwindow.cc
+++ b/src/mainwindow.cc
@@ -243,7 +243,7 @@ static void set_icon_name_fallback(Gtk::Image *i, const char *name, Gtk::IconSiz
     theme = Gtk::IconTheme::get_default();
 
     try {
-        pixbuf = theme->load_icon(name, width, Gtk::ICON_LOOKUP_GENERIC_FALLBACK);
+        pixbuf = theme->load_icon(name, width, Gtk::ICON_LOOKUP_GENERIC_FALLBACK | Gtk::ICON_LOOKUP_FORCE_SIZE);
 
         if (pixbuf)
             i->set(pixbuf);


However I do not know if there are wider consequences to forcing the size.
Comment 1 Felipe Sateler 2016-05-01 16:31:03 UTC
*** Bug 95228 has been marked as a duplicate of this bug. ***
Comment 2 Jerome Leclanche 2016-05-01 16:37:42 UTC
That patch looks good. Any reason it hasn't been picked up yet?
Comment 3 Tanu Kaskinen 2016-05-01 17:29:46 UTC
Sorry, the the patch was forgotten. I applied it now.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.