Bug 8732 (redirected-dri) - Composite breaks OpenGL
Summary: Composite breaks OpenGL
Status: RESOLVED FIXED
Alias: redirected-dri
Product: DRI
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
: 1208 6283 14034 19742 19974 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-10-23 08:35 UTC by Joseph Mulloy
Modified: 2010-05-03 13:10 UTC (History)
15 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Screenshot of problem (55.35 KB, image/png)
2006-10-23 08:37 UTC, Joseph Mulloy
no flags Details
Xorg Configuration File (4.84 KB, text/plain)
2006-10-23 08:38 UTC, Joseph Mulloy
no flags Details
Xorg log (65.54 KB, text/x-log)
2006-10-23 08:39 UTC, Joseph Mulloy
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Mulloy 2006-10-23 08:35:21 UTC
I have a toshbia M100 with a GMA 945/950 in it and I want to be able to use 
composite but when I use a compsiting manger such as the ones found in xfwm or 
kwin or if I use xcompmgr OpenGL windows draw themselves on top of everything 
else regardless to the actual window layering. I will attach configuration 
files, log files and a screenshot of the problem.
Comment 1 Joseph Mulloy 2006-10-23 08:37:16 UTC
Created attachment 7494 [details]
Screenshot of problem

This screenshot shows glxgears running behind Konsole with xcompmgr running,
but this happens with other composite managers as well and with other OpenGL
programs such as screensavers.
Comment 2 Joseph Mulloy 2006-10-23 08:38:19 UTC
Created attachment 7495 [details]
Xorg Configuration File
Comment 3 Joseph Mulloy 2006-10-23 08:39:21 UTC
Created attachment 7496 [details]
Xorg log
Comment 4 Michel Dänzer 2007-05-13 23:42:55 UTC
Fixing this is far from trivial, see http://dri.freedesktop.org/wiki/DirectRenderingToRedirectedWindows for a sketch of the road ahead.
Comment 5 Joseph Mulloy 2007-06-04 00:46:39 UTC
Why does EVERYONE ELSE with this EXACT chip not have this problem. Is it actually a driver problem? I've read reports of people being able to run Beryl with no problem on this chip. How do I prove this is a Hardware fault so Toshiba will fix it?
Comment 6 Michel Dänzer 2007-06-04 05:31:17 UTC
(In reply to comment #5)
> Why does EVERYONE ELSE with this EXACT chip not have this problem. 

How did you get that impression? Everybody should have the same problem under the same circumstances.

> Is it actually a driver problem? 

It's more complicated than that, see comment #4.

> I've read reports of people being able to run Beryl with no problem on this
> chip. 

I can only guess based on this little information, but maybe they're using Xgl.

> How do I prove this is a Hardware fault

It probably isn't.
Comment 7 Tim Boundy 2007-06-21 08:05:55 UTC
I have the same problem on my laptop (incidentally also a Toshiba M100). I never noticed it until I stumbled across this bug report and checked for myself.
Comment 8 Russell Harmon 2007-07-01 17:01:39 UTC
Is there any work currently to have it fixed? Or is the fix still being merely discussed...
Comment 9 Kristian Høgsberg 2007-07-02 11:12:04 UTC
(In reply to comment #8)
> Is there any work currently to have it fixed? Or is the fix still being merely
> discussed...

There is work going on here, but the scope of this is a lot bigger than your average bug fix.  We need to rework the interaction and interface between the kernel drm, the X server and the 3D DRI drivers.  We're probably talking man-years of work here, so you'll have to wait a little longer :)  Michels roadmap mentioned in comment 4 gives an idea of the changes we're looking at.
Comment 10 Michel Dänzer 2007-09-04 04:24:12 UTC
*** Bug 6283 has been marked as a duplicate of this bug. ***
Comment 11 Michel Dänzer 2007-09-04 04:24:25 UTC
*** Bug 1208 has been marked as a duplicate of this bug. ***
Comment 12 Joseph Mulloy 2007-12-10 23:54:06 UTC
Any progress? This bug is over a year old. I bought a laptop with an intel graphics chip because I wanted to use a free software driver but obviously that was a mistake. Next time I'll go with an NVIDIA chip. The drivers may be proprietary but at least their stuff WORKS! It's nearly 2008, I should be able to have nice effects on my computer. KDE 4 is coming out soon and I won't be able to use it to it's full potential because this is BROKEN!
Comment 13 Daniel Stone 2007-12-11 01:37:29 UTC
It's your decision to make: don't let us stop you.
Comment 14 Jesse Barnes 2007-12-11 09:01:42 UTC
Joseph, there's been lots of progress on this front, but the final bits haven't been released yet afaik, though Kristian may have more details on what's available for testing etc.
Comment 15 olig9 2007-12-17 05:35:18 UTC
Isn't there any kind of workaround for this? I don't care much for performance on the particular machine where this problem occurs, but it would be nice if toys like Google Earth or Celestia would have usable menus. Any idea?
Comment 16 Michel Dänzer 2007-12-17 06:25:27 UTC
(In reply to comment #15)
> Isn't there any kind of workaround for this?

Unfortunately not - the only way to get correct compositing is to properly redirect the rendering.
Comment 17 Michel Dänzer 2008-01-12 03:18:56 UTC
*** Bug 14034 has been marked as a duplicate of this bug. ***
Comment 18 e 2008-01-21 04:08:11 UTC
I would be interested in amd64 testing, when something's available.

I'm having the same problem on my desktop.
Q965 Integrated Graphics Controller (rev 02) --> Intel® GMA 3000

It will likely affect my eeepc also.

thx

e
Comment 19 Neil J. Patel 2008-05-27 08:15:40 UTC
Sorry for the spam, but is there any update on this? 

Although I understand that this is not, by any stretch of the imagination, a trivial fix, there seem to be more and more Linux-based devices that are coming out in the next few months that all exhibit this issue, and it sucks to have to choose between composite or GL. This suckage increases as we are now starting to get more application<=>GL integration on the desktop.

Anyway, thanks for all the hard work!

PS. I can provide testing on the 945GSE chipset.
Comment 20 Joseph Mulloy 2008-05-27 08:36:05 UTC
There should be a fix for this in the next release.

It's called DRI2.

See
http://hoegsberg.blogspot.com/2008/03/i-just-committed-last-bit-of-dri2-work.html
http://www.x.org/wiki/DRI2
http://lists.freedesktop.org/archives/xorg/2008-February/032646.html

Anyone know how I can get a version of Xorg with DRI2 on Gentoo?
Comment 21 Daniel Stone 2008-06-09 14:32:44 UTC
Hooray for DRI2!
Comment 22 Michel Dänzer 2009-01-26 05:54:24 UTC
*** Bug 19742 has been marked as a duplicate of this bug. ***
Comment 23 Eric Anholt 2009-02-10 17:15:35 UTC
*** Bug 19974 has been marked as a duplicate of this bug. ***
Comment 24 Martin Schaaf 2009-03-02 11:11:15 UTC
I can confirm that this is fixed int ubuntu jaunty alpha5 by enabling dri2 and uxa. Thank you very much.
Comment 25 Dotan Cohen 2010-05-03 11:51:49 UTC
*** Bug 27947 has been marked as a duplicate of this bug. ***
Comment 26 Dotan Cohen 2010-05-03 11:55:08 UTC
Why is this marked as FIXED? I see that one poster found a workaround by manually enabling dri2 and uxa on Ubuntu, but the fix was never ported to the released version of the driver. That is, even on Ubuntu, users are bitten by this bug unless the know how to enable dri2 and uxa, and assuming that they know that they even have to.

I am reopening until the issue is fixed, a workaround (or manually enabling dri2/uxa) is not a fix.
Comment 27 Alex Deucher 2010-05-03 12:02:44 UTC
One of the main points of DRI2 was to fix GL + composite.  It will only work as expected with a DRI2 capable driver.  DRI2 is not a workaround, it is the fix.
Comment 28 Dotan Cohen 2010-05-03 12:19:42 UTC
> One of the main points of DRI2 was to fix GL + composite. It
> will only work as expected with a DRI2 capable driver. DRI2 is
> not a workaround, it is the fix.

I have misunderstood, then. I understood this issue to be for improving OpenGL (and DRI) support for a specific driver. I was too quick to mark my own bug as a dupe (see comment 25). I will reopen that bug as a request to enable DRI in radeonhd.

Thanks.
Comment 29 Julien Cristau 2010-05-03 13:10:39 UTC
> --- Comment #28 from Dotan Cohen <freedesktop-org@dotancohen.com> 2010-05-03 12:19:42 PDT ---
> I will reopen that bug as a request to enable DRI in radeonhd.
> 
don't.  just use radeon instead.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.