Bug 87391 - [i965]Piglit shaders_glsl-deriv-varyings fails on Mesa 10.4
Summary: [i965]Piglit shaders_glsl-deriv-varyings fails on Mesa 10.4
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 10.4
Hardware: All Linux (All)
: high normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-17 03:23 UTC by lu hua
Modified: 2016-10-28 00:24 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lu hua 2014-12-17 03:23:05 UTC
System Environment:
--------------------------
Platform:   i965
Libdrm:		(master)libdrm-2.4.58-19-gf99522e678dbbaffeca9462a8edcbe900574dc12
Mesa:		(10.4)bccfe7ae0f4e11a0219eb92f7070b1fc70bc6fd6
Xserver:	(server-1.16-branch)xorg-server-1.16.2.901
Xf86_video_intel:(master)2.99.916-177-g99537089346ed7a1bc6b02349fad93845e865bb9
Libva:		(master)8986ec692b19d8dd6bd2aa118b5dffbd05a8f909
Libva_intel_driver:(master)b5d6d9d425a6d539b27d22992bda05f79d1a0622
Kernel:   (drm-intel-fixes)b0616c5306b342ceca07044dbc4f917d95c4f825
Piglit: f18b947d7c03b81b989ed47551dc24bcc29cc0fc

Bug detailed description:
---------------------------
This case fails on Mesa 10.4 branch and works well on Mesa master branch.Bisect shows it's a Piglit regression.

Bisect shows: b1ee0f3214028cd724028f697ac5ee7b6240de10 is the first bad commit.
commit b1ee0f3214028cd724028f697ac5ee7b6240de10
Author:     Andres Gomez <agomez@igalia.com>
AuthorDate: Fri Dec 12 17:13:55 2014 +0100
Commit:     Matt Turner <mattst88@gmail.com>
CommitDate: Mon Dec 15 11:41:54 2014 -0800

    glsl-deriv-varyings: Added checks for derivatives on parameters with negative or abs modifiers

    Exposes a bug in the i965 driver.

    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=82991
    Reviewed-by: Matt Turner <mattst88@gmail.com>


output:
libGL: screen 0 does not appear to be DRI3 capable
libGL: pci id for fd 4: 8086:0152, driver i965
libGL: OpenDriver: trying /opt/X11R7/lib/dri/tls/i965_dri.so
libGL: OpenDriver: trying /opt/X11R7/lib/dri/i965_dri.so
libGL: Error in /etc/drirc line 1, column 0: no element found.
libGL: Error in /root/.drirc line 1, column 0: no element found.
libGL: Error in /etc/drirc line 1, column 0: no element found.
libGL: Error in /root/.drirc line 1, column 0: no element found.
Probe color at (280,125)
  Expected: 0.800000 0.400000 0.000000
  Observed: 0.000000 0.000000 0.000000
PIGLIT: {"result": "fail" }


Reproduce steps:
-------------------------
1. xinit
2. bin/glsl-deriv-varyings -auto -fbo
Comment 1 lu hua 2014-12-17 03:38:17 UTC
As the patch's description, it only exposes Mesa issue. Reset to Mesa.
Comment 2 Ian Romanick 2014-12-17 05:16:52 UTC
There's already a bug for this... it's mentioned in the commit message that you quoted.

*** This bug has been marked as a duplicate of bug 82991 ***
Comment 3 lu hua 2015-06-24 06:06:03 UTC
bug 82991 fixed. but this case still fails on the latest mesa 10.6 branch.
libGL: OpenDriver: trying /opt/X11R7/lib/dri/tls/i965_dri.so
libGL: OpenDriver: trying /opt/X11R7/lib/dri/i965_dri.so
libGL: Using DRI2 for screen 0
Probe color at (355,125)
  Expected: 0.800000 0.400000 0.000000
  Observed: 0.800000 0.000000 0.000000
PIGLIT: {"result": "fail" }
Comment 4 Andrés Gómez García 2015-06-24 12:47:27 UTC
(In reply to lu hua from comment #3)
> bug 82991 fixed. but this case still fails on the latest mesa 10.6 branch.
> libGL: OpenDriver: trying /opt/X11R7/lib/dri/tls/i965_dri.so
> libGL: OpenDriver: trying /opt/X11R7/lib/dri/i965_dri.so
> libGL: Using DRI2 for screen 0
> Probe color at (355,125)
>   Expected: 0.800000 0.400000 0.000000
>   Observed: 0.800000 0.000000 0.000000
> PIGLIT: {"result": "fail" }

Is this failure happening with latest piglit? Notice that the test was modified as a result of fixing bug 87407.
Comment 5 Iago Toral 2015-07-13 12:13:00 UTC
(In reply to Andrés Gómez García from comment #4)
> (In reply to lu hua from comment #3)
> > bug 82991 fixed. but this case still fails on the latest mesa 10.6 branch.
> > libGL: OpenDriver: trying /opt/X11R7/lib/dri/tls/i965_dri.so
> > libGL: OpenDriver: trying /opt/X11R7/lib/dri/i965_dri.so
> > libGL: Using DRI2 for screen 0
> > Probe color at (355,125)
> >   Expected: 0.800000 0.400000 0.000000
> >   Observed: 0.800000 0.000000 0.000000
> > PIGLIT: {"result": "fail" }
> 
> Is this failure happening with latest piglit? Notice that the test was
> modified as a result of fixing bug 87407.

That is correct, that test does not exist any more in piglit, it has been replaced by these other tests:

bin/shader_runner ./tests/shaders/glsl-derivs-sign.shader_test -auto
bin/shader_runner ./tests/shaders/glsl-derivs-varyings.shader_test -auto
bin/shader_runner ./tests/shaders/glsl-derivs-abs-sign.shader_test -auto
bin/shader_runner ./tests/shaders/glsl-derivs-abs.shader_test -auto
bin/shader_runner ./tests/shaders/glsl-derivs-swizzle.shader_test -auto

All of which pass fine for me.

Lu, you probably still have the binary for the old program and that is why you did not notice. I think this can be closed again.
Comment 6 lu hua 2015-07-15 05:49:12 UTC
Christophe, 
Does this issue still happen on your machines?
Comment 7 Andrés Gómez García 2015-07-16 14:06:41 UTC
(In reply to Andrés Gómez García from comment #4)
> (In reply to lu hua from comment #3)
> > bug 82991 fixed. but this case still fails on the latest mesa 10.6 branch.
> > libGL: OpenDriver: trying /opt/X11R7/lib/dri/tls/i965_dri.so
> > libGL: OpenDriver: trying /opt/X11R7/lib/dri/i965_dri.so
> > libGL: Using DRI2 for screen 0
> > Probe color at (355,125)
> >   Expected: 0.800000 0.400000 0.000000
> >   Observed: 0.800000 0.000000 0.000000
> > PIGLIT: {"result": "fail" }
> 
> Is this failure happening with latest piglit? Notice that the test was
> modified as a result of fixing bug 87407.

Just now, compiled mesa 10.6 branch and passed the tests with piglit's master:

$ for i in ./tests/shaders/glsl-derivs-*; do echo $i; ./bin/shader_runner $i -auto -fbo; done
./tests/shaders/glsl-derivs-abs.shader_test
PIGLIT: {"result": "pass" }
./tests/shaders/glsl-derivs-abs-sign.shader_test
PIGLIT: {"result": "pass" }
./tests/shaders/glsl-derivs-sign.shader_test
PIGLIT: {"result": "pass" }
./tests/shaders/glsl-derivs-swizzle.shader_test
PIGLIT: {"result": "pass" }
./tests/shaders/glsl-derivs-varyings.shader_test
PIGLIT: {"result": "pass" }


bug/show.html.tmpl processed on Mar 27, 2017 at 02:48:03.
(provided by the Example extension).