Bug 88263 - Civilization Beyond Earth crashes on r600
Summary: Civilization Beyond Earth crashes on r600
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2015-01-10 10:35 UTC by oleid
Modified: 2019-09-18 19:18 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Description oleid 2015-01-10 10:35:44 UTC
Dear Mesa developers,

as suggested in #87489 a new report.

The game crashes when staring a new game or loading an existing. I can reach the menu, set up a new game and so on. As far as I can tell, llvm-svn is used for building the mesa-git package. I also tried running R600_DEBUG=llvm to make sure llvm is really used --- I'm not sure what's the default, nowadays (is it somewhere in the logs? I didn't find anything).

I created an trace file of the game and enabled R600_DEBUG=vs,gs,ps

As the trace file is rather huge, I put everything to the following google drive storage. You can find there also the debugging output generated by the above debug settings.


As the game crashes, I'm not certain, if the files are complete. 

If it is of any help, I can provide an apitrace of fglrx. It runs the game, albeit with graphic errors. Please let me know if I can provide more information.

**** System:
ATI Juniper PRO [Radeon HD 5750]
ArchLinux AMD64 using mesa-git repository.
Comment 1 Joti Papadopoulos 2015-01-12 19:54:55 UTC
Same issue here and i'm also using git(67208.e28f9d0 to be precise, but this issue has been present since the games release). This is also an issue with 10.3.2 and 10.3.5, but i havent tested any other official releases. Also of note is when the game crashes i initially get a black screen for about 10secs and then the screen turns white. After a crash the kernel seems unresponsive as magic keys don't work. 

Arch Linux 64bit
CPU: AMD Phenom2 X3 720
GPU: AMD HD5850( Mesa git 67208.e28f9d0)
Kernel 3.17.6-1-ARCH
Xorg 1.16
DPM is enabled

Let me know if any more info is needed
Comment 2 Marek Olšák 2015-01-23 21:57:51 UTC
Is the bug present without LLVM?

BTW, I don't recommend using LLVM with r600g for graphics, because it's not tested by developers and likely incomplete.
Comment 3 oleid 2015-01-23 22:36:56 UTC
Hey Marek!

Thanks for having a look into this!

As far as I can tell, the bug occurs without the LLVM backend. I just realized, that you have to set the environment variable "R600_LLVM", which I didn't. Instead, I tried to activate the LLVM backend by adding the string "llvm" to R600_DEBUG (yet, not in the run which created the traces). Furthermore, R600_LLVM is not set by default on ArchLinux. So actually, I never tried the LLVM backend.

If you'd like to have a trace using the LLVM backend, please let me know.
Comment 4 Marek Olšák 2015-01-23 22:45:22 UTC
I can't download the trace. The google download returns error 400.
Comment 5 oleid 2015-01-23 23:14:30 UTC
That's strange. It works for me, even without being loged in to google.

Please try this link:

Comment 6 Ernst Sjöstrand 2015-02-07 07:14:21 UTC
Have you tried with R600_DEBUG=nosb ?
Comment 7 Ernst Sjöstrand 2015-12-22 07:32:23 UTC
There's been a lot of updates since this bug was reported, is this still an issue?
Comment 8 oleid 2016-01-08 14:36:01 UTC
I just tried it again with current git (Mesa 11.2.0-devel (git-040e314)). It works for me with with low settings. I played a few turns - it seems to be fine, albeit a bit slow. When using medium settings, the game hits the assert:

CivBE: ../nptl/pthread_mutex_lock.c:353: __pthread_mutex_lock_full: Assertion `(-(e)) != 3 || !robust' failed.

and doesn't start. But there is no system crash.
Comment 9 GitLab Migration User 2019-09-18 19:18:54 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/539.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.