Bug 88777 - GPU hang (ring hung) with chromium and OpenGL composite manager on Intel 965GM
Summary: GPU hang (ring hung) with chromium and OpenGL composite manager on Intel 965GM
Status: CLOSED DUPLICATE of bug 88809
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-24 15:04 UTC by Gustavo Sverzut Barbieri
Modified: 2017-07-24 22:49 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg.txt of kernel with drm.debug=0xe (400.36 KB, text/plain)
2015-01-24 15:04 UTC, Gustavo Sverzut Barbieri
no flags Details
/sys/class/drm/card0/error (847.44 KB, text/plain)
2015-01-24 15:05 UTC, Gustavo Sverzut Barbieri
no flags Details
Xorg.log of a working system (before crash) (27.92 KB, text/plain)
2015-01-24 15:05 UTC, Gustavo Sverzut Barbieri
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gustavo Sverzut Barbieri 2015-01-24 15:04:25 UTC
Created attachment 112778 [details]
dmesg.txt of kernel with drm.debug=0xe

I've noticed this bug to be reproducible on my system even after recent updates to xorg and mesa.

My system:
 - MacBook 4,1 (Intel(R) Core(TM)2 Duo T8300, video card is 965GM)
 - ArchLinux (kernel 3.18.2-2-ARCH x86_64 SMP PREEMPT)
 - Package versions:
    * xorg-server: 1.16.3-2
    * xf86-video-intel: 2.99.917-1
    * libva-intel-driver: 1.5.0-1
    * libva-mesa-driver: 10.4.2-1 
    * mesa: 10.4.2-1
    * libdrm: 2.4.59-1
    * enlightenment: 0.19.2-1 
    * slim: 1.3.6-5
 - Window Manager: Enlightenment 0.19.2 running OpenGL compositor (also happens with GNOME3, but that often crashes earlier)
 - Login Manager: slim (shouldn't matter but...)

Steps to reproduce:
 1. Login to enlightenment using its OpenGL composite manager;
 2. Visit Chrome Themes page https://chrome.google.com/webstore/category/themes?hl=en
 3. GPU hungs

See attached logs:
 * dmesg.txt: kernel booted with drm.debug=0xe
 * drm_card0_error.txt: /sys/class/drm/card0/error, same as /sys/kernel/debug/dri/0/i915_error_state
Comment 1 Gustavo Sverzut Barbieri 2015-01-24 15:05:20 UTC
Created attachment 112779 [details]
/sys/class/drm/card0/error
Comment 2 Gustavo Sverzut Barbieri 2015-01-24 15:05:54 UTC
Created attachment 112780 [details]
Xorg.log of a working system (before crash)
Comment 3 Chris Wilson 2015-02-03 12:45:59 UTC
Presuming this is a dupe of 88809:

This is likely fixed in Mesa 10.4.3 or master.  Can you try one of those?

 You may also be able to work around the problem by running with
 "always_flush_cache=true".

*** This bug has been marked as a duplicate of bug 88809 ***
Comment 4 Gustavo Sverzut Barbieri 2015-02-03 17:54:28 UTC
I'm traveling, will test next week.

Thanks!
Comment 5 Gustavo Sverzut Barbieri 2015-02-07 20:35:03 UTC
confirmed as solved (mesa 10.4.4)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.