Bug 88809 - [gen4] GPU hang on render of specific pages in Chrome
Summary: [gen4] GPU hang on render of specific pages in Chrome
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 10.1
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 88777 88894 88931 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-01-26 20:25 UTC by cybermerchantlucky7
Modified: 2015-02-22 17:17 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments
syslog dump of time of crash (68.15 KB, text/plain)
2015-01-26 20:25 UTC, cybermerchantlucky7
Details
/sys/class/drm/card0/error (851.58 KB, text/plain)
2015-01-30 19:41 UTC, cybermerchantlucky7
Details
syslog time of last crash that goes with card0 error file (140.91 KB, text/plain)
2015-01-30 19:42 UTC, cybermerchantlucky7
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cybermerchantlucky7 2015-01-26 20:25:59 UTC
Created attachment 112841 [details]
syslog dump of time of crash

When rendering certain pages, like youtube.com, in Chrome, a GPU hang occurs, making the system unusable. The hang will occur every time such a particular page is loaded, but not with most pages and not in FireFox. SysLog details are attached.
Comment 1 cybermerchantlucky7 2015-01-26 20:27:39 UTC
The crash occurs even when GPU acceleration turned off in Chrome.
Comment 2 Chris Wilson 2015-01-26 20:44:49 UTC
Please attach /sys/class/drm/card0/error
Comment 3 cybermerchantlucky7 2015-01-26 20:51:10 UTC
(In reply to Chris Wilson from comment #2)
> Please attach /sys/class/drm/card0/error

I opened the file and all it contains is: "no error state collected". 

Perhaps it is necessary to collect it via SSH during the crashed state? To do so, I would need to enable SSH and crash the computer again.
Comment 4 Rodrigo Vivi 2015-01-26 23:58:18 UTC
Yes you need to collect right after the hang...
Comment 5 cybermerchantlucky7 2015-01-30 19:41:13 UTC
Created attachment 112984 [details]
/sys/class/drm/card0/error

Here is the /sys/class/drm/card0/error file right after such a crash.
Comment 6 cybermerchantlucky7 2015-01-30 19:42:50 UTC
Created attachment 112985 [details]
syslog time of last crash that goes with card0 error file

Here is the syslog data that occurred when I reproduced the error for the sake of capturing the /sys/class/drm/card0/error.
Comment 7 cybermerchantlucky7 2015-01-30 21:26:49 UTC
How do I go about getting you the version info? Which software should that be the version for?
Comment 8 Kenneth Graunke 2015-01-31 12:49:34 UTC
$ glxinfo | grep 'GL version'

This is likely fixed in Mesa 10.4 or master.  Can you try one of those?

You may also be able to work around the issue by setting the "always_flush_cache=true" environment variable.
Comment 9 Kenneth Graunke 2015-01-31 12:50:43 UTC
Mesa 10.4.3, specifically (10.4.2 doesn't contain the fix).
Comment 10 cybermerchantlucky7 2015-01-31 19:29:18 UTC
OpenGL version string: 2.1 Mesa 10.1.3
Comment 11 cybermerchantlucky7 2015-01-31 20:44:07 UTC
Thanks everyone. An upgrade to mesa 10.5 using ppa:oibaf/graphics-drivers fixed the issue.
Comment 12 Chris Wilson 2015-02-03 09:14:16 UTC
*** Bug 88894 has been marked as a duplicate of this bug. ***
Comment 13 Chris Wilson 2015-02-03 09:20:15 UTC
*** Bug 88931 has been marked as a duplicate of this bug. ***
Comment 14 Chris Wilson 2015-02-03 12:45:59 UTC
*** Bug 88777 has been marked as a duplicate of this bug. ***
Comment 15 cybermerchantlucky7 2015-02-22 17:17:27 UTC
(Additional to cybermerchantlucky7 from comment #11)
> Thanks everyone. An upgrade to mesa 10.5 using ppa:oibaf/graphics-drivers
> fixed the issue.

However, using the oibaf PPA has made the system unstable in other ways by upgrading to unstable builds. I have been able to configure, make, and make install Mesa 10.4.4 (which is the latest stable release) BUT it isn't being used by the system. This is probably the wrong place to ask, but how can I make the system (probably X Windows?) use the Mesa 10.4.4 I compiled?


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.