Bug 88780 - Several Unity3D-based games render with "foggy blueish overlay"
Summary: Several Unity3D-based games render with "foggy blueish overlay"
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 77449
  Show dependency treegraph
 
Reported: 2015-01-25 09:25 UTC by Kai
Modified: 2015-08-02 14:10 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Blue overlay with Dreamfall Chapters in the lab scene (421.66 KB, image/jpeg)
2015-01-25 09:25 UTC, Kai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kai 2015-01-25 09:25:08 UTC
Created attachment 112787 [details]
Blue overlay with Dreamfall Chapters in the lab scene

With the stack detailed below (AFAICT this is *NOT* a regression, because I seem to remember having these hazy blue scenes with older versions of Mesa as well) several Unity3D-based games (e.g. Jagged Alliance: Flashback or Dreamfall Chapters) render either entirely or only some scenes as if there was some fog overlay with a blue hue.

For Dreamfall Chapters (from which the attached screenshot originates), it's only for some scenes, sometimes even dependant on the camera angle. For example, in the Queenie scene only some camera angles exhibit this problem, while in the lab scene, you have it constantly. With Dreamfall Chapters this bug can be seen mostly indoors.

Games like Jagged Alliance render all 3D scenes with this blue hue overlay. This is, every sector you go into shows this problem.

My current stack (Debian testing as a base):
GPU: Hawaii PRO [Radeon R9 290] (ChipID = 0x67b1)
Mesa: Git:master/d2811c29da
libdrm: Git:master/libdrm-2.4.59
LLVM: SVN:trunk/r226934 (3.7 devel)
X.Org: Git:master/6672606420
Linux: Git:<git://people.freedesktop.org/~airlied/linux>:drm-fixes/67cf2d3912
Firmware: <http://people.freedesktop.org/~agd5f/radeon_ucode/>
> 9e05820da42549ce9c89d147cf1f8e19  hawaii_ce.bin
> c8bab593090fc54f239c8d7596c8d846  hawaii_mc.bin
> 3618dbb955d8a84970e262bb2e6d2a16  hawaii_me.bin
> c000b0fc9ff6582145f66504b0ec9597  hawaii_mec.bin
> 0643ad24b3beff2214cce533e094c1b7  hawaii_pfp.bin
> ba6054b7d78184a74602fd81607e1386  hawaii_rlc.bin
> 11288f635737331b69de9ee82fe04898  hawaii_sdma.bin
> 284429675a5560e0fad42aa982965fc2  hawaii_smc.bin
libclc: Git:master/d73f33b736
DDX: Git:master/c9f8f642fd
Comment 1 Kai 2015-06-16 09:12:16 UTC
This is still an issue in e.g. Dreamfall Chapters. In book two you can see it for example when you arrive in Marcuria by boat for the first time (shortly after the beginning of book 2).

My current stack (Debian testing as a base):
GPU: Hawaii PRO [Radeon R9 290] (ChipID = 0x67b1)
Mesa: Git:master/4d35eef326
libdrm: 2.4.60-3
LLVM: SVN:trunk/r239668 (3.7 devel)
X.Org: 2:1.17.1-2
Linux: 4.0.5
Firmware: <https://secure.freedesktop.org/~agd5f/radeon_ucode/hawaii/>
> 286640da3d90d7b51bdb038b65addc47  hawaii_ce.bin
> 161105a73f7dfb2fca513327491c32d6  hawaii_mc.bin
> d6195059ea724981c9acd3abd6ee5166  hawaii_me.bin
> ad511d31a4fe3147c8d80b8f6770b8d5  hawaii_mec.bin
> 63eae3f33c77aadbc6ed1a09a2aed81e  hawaii_pfp.bin
> 5b72c73acf0cbd0cbb639302f65bc7dc  hawaii_rlc.bin
> f00de91c24b3520197e1ddb85d99c34a  hawaii_sdma1.bin
> 8e16f749d62b150d0d1f580d71bc4348  hawaii_sdma.bin
> 7b6ca5302b56bd35bf52804919d57e63  hawaii_smc.bin
> 9f2ba7e720e2af4d7605a9a4fd903513  hawaii_uvd.bin
> b0f2a043e72fbf265b2f858b8ddbdb09  hawaii_vce.bin
libclc: Git:master/5cd2688a9f
DDX: Git:master/d7c82731a8
Comment 2 Marek Olšák 2015-08-02 13:00:24 UTC
Would you please create an apitrace?
Comment 3 Kai 2015-08-02 14:10:15 UTC
Seems to be fixed now. At least I wasn't able to get the blue fog in any Unity3D-based game anymore.

I'll produce an apitrace if the bug resurfaces.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.