Bug 88785 - KWin context menues show visual corruption with GLAMOR
Summary: KWin context menues show visual corruption with GLAMOR
Status: RESOLVED DUPLICATE of bug 80827
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/Acceleration/glamor (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-25 14:01 UTC by Kai
Modified: 2015-01-28 07:37 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
visual corruption with GLAMOR and KWin of context menus (132.33 KB, image/png)
2015-01-25 14:01 UTC, Kai
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kai 2015-01-25 14:01:52 UTC
Created attachment 112798 [details]
visual corruption with GLAMOR and KWin of context menus

When right-clicking on the window decoration of a window which is rendered by KWin, the context menu always shows corruption of some sort. I've attached an screenshot of one such example.

My KDE is running with desktop effects on the the OpenGL 3.1 native renderer.

I'm not seeing this corruption with an Intel GPU and one of their custom acceleration schemes. But for as long as I've been using Glamor, I've seen this. I just forgot to report it. This might be a duplicate of bug 29873, but I can't tell for sure, because the referenced screenshot isn't available anymore. In any case, I'm only seeing the corruption in the context menus of the window.

My current stack (Debian testing as a base):
GPU: Hawaii PRO [Radeon R9 290] (ChipID = 0x67b1)
Mesa: Git:master/d2811c29da
libdrm: Git:master/libdrm-2.4.59
LLVM: SVN:trunk/r226934 (3.7 devel)
X.Org: Git:master/xorg-server-1.16.99.902
Linux: Git:<git://people.freedesktop.org/~airlied/linux>:drm-fixes/67cf2d3912
Firmware: <http://people.freedesktop.org/~agd5f/radeon_ucode/>
> 9e05820da42549ce9c89d147cf1f8e19  hawaii_ce.bin
> c8bab593090fc54f239c8d7596c8d846  hawaii_mc.bin
> 3618dbb955d8a84970e262bb2e6d2a16  hawaii_me.bin
> c000b0fc9ff6582145f66504b0ec9597  hawaii_mec.bin
> 0643ad24b3beff2214cce533e094c1b7  hawaii_pfp.bin
> ba6054b7d78184a74602fd81607e1386  hawaii_rlc.bin
> 11288f635737331b69de9ee82fe04898  hawaii_sdma.bin
> 284429675a5560e0fad42aa982965fc2  hawaii_smc.bin
libclc: Git:master/d73f33b736
DDX: Git:master/c9f8f642fd

Let me know, if you need something else.
Comment 1 Michel Dänzer 2015-01-28 07:37:53 UTC
See https://bugs.freedesktop.org/show_bug.cgi?id=80827#c4 .

*** This bug has been marked as a duplicate of bug 80827 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.