Bug 88894 - System suddenly crashed to blank screen
Summary: System suddenly crashed to blank screen
Status: CLOSED DUPLICATE of bug 88809
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-01 05:39 UTC by John Eure
Modified: 2017-07-24 22:48 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
GPU crash dump (25 bytes, text/plain)
2015-02-01 05:39 UTC, John Eure
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Eure 2015-02-01 05:39:11 UTC
Created attachment 113010 [details]
GPU crash dump

My laptop's screen suddenly went blank, and the laptop became unresponsive.  I could not switch to a virtual console, or if I could, it was not able to display the login prompt on the screen.  Eventually, I stopped waiting and held down the power button to reboot my laptop.  This worked normally.  After the reboot, I looked in my syslog, and it told me to: 
"Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel", and include the GPU crash dump at "/sys/class/drm/card0/error".  
Unfortunately, when I read the GPU crash dump file, it just says "no error state collected".

In case it's useful, the output of "uname -a" is:

Linux artemis 3.13.0-44-generic #73-Ubuntu SMP Tue Dec 16 00:22:43 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

And the first bit of the syslog output after the crash, trimmed of headers, is:

Watchdog[16595]: segfault at 0 ip 00007f38da33f428 sp 00007f38ca9c8520 error 6 in libcontent.so[7f38d9a88000+1244000]
Watchdog[16909]: segfault at 0 ip 00007f6a47856428 sp 00007f6a37edf520 error 6 in libcontent.so[7f6a46f9f000+1244000]
[drm] stuck on render ring
[drm] GPU crash dump saved to /sys/class/drm/card0/error
[drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[drm:i915_set_reset_status] *ERROR* render ring hung inside bo (0x3175000 ctx 0) at 0x3176594
[drm] GMBUS [i915 gmbus vga] timed out, falling back to bit banging on pin 2
[drm:i915_reset] *ERROR* Failed to reset chip.
Comment 1 Chris Wilson 2015-02-01 09:11:55 UTC
We need the crash dump before rebooting. Given the symptoms I think you have a gen4 GPU, e.g. gm45, and you were running Chrome.

Quoting: https://bugs.freedesktop.org/show_bug.cgi?id=88809#c8

 This is likely fixed in Mesa 10.4 or master.  Can you try one of those?

 You may also be able to work around the issue by setting the
 "always_flush_cache=true" environment variable.
Comment 2 John Eure 2015-02-03 03:03:01 UTC
Thanks a lot!  I'm afraid that I don't have the GPU dump, but if something like this happens again, I now have a better idea of how to get the dump.

You were right about the versions I have - "glxinfo" gives "OpenGL version string: 2.1 Mesa 10.1.3" and my graphics chipset is an even older 4th gen - "GM965/GL960".  And I was running Chromium ("chromium-browser --version" gives "Chromium 39.0.2171.65 Ubuntu 14.04").

I've updated to the Mesa 10.5 drivers, and so hopefully this won't occur again.  Unless there's anything more I can do for you, I think this bug can probably be closed?
Comment 3 Chris Wilson 2015-02-03 09:14:16 UTC
Let's assume it is a duplicate, thanks for the report.

*** This bug has been marked as a duplicate of bug 88809 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.