Bug 89913 - GPU HANG: ecode 8:0:0xfffffffe, in Xorg [960], reason: Ring hung, action: reset
Summary: GPU HANG: ecode 8:0:0xfffffffe, in Xorg [960], reason: Ring hung, action: reset
Status: RESOLVED DUPLICATE of bug 83908
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: matthias.a.lee
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-05 22:54 UTC by matthias.a.lee
Modified: 2015-04-11 08:33 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
error file from previously mentioned error (2.67 MB, text/plain)
2015-04-07 00:42 UTC, matthias.a.lee
no flags Details
another dump file (2.73 MB, text/plain)
2015-04-10 16:55 UTC, matthias.a.lee
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description matthias.a.lee 2015-04-05 22:54:22 UTC
GPU Hang/crash on Thinkpad X1 Carbon with an Intel i7-5600U

I got the following message:
[11136.674235] [drm] stuck on render ring
[11136.674985] [drm] GPU HANG: ecode 8:0:0xfffffffe, in Xorg [960], reason: Ring hung, action: reset
[11136.674987] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[11136.674987] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[11136.674988] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[11136.674988] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[11136.674989] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[11136.682245] drm/i915: Resetting chip after gpu hang


Here is the error file: https://www.dropbox.com/s/17axcjqhwtyu1xe/error?dl=0

Could this be related to https://bugs.freedesktop.org/show_bug.cgi?id=85583?


Is any other information needed from me?
Comment 1 Chris Wilson 2015-04-06 08:39:51 UTC
Can you please compress the error state and attach it? At a rough guess this is on one of the TLB hangs and you should update your kernel.
Comment 2 matthias.a.lee 2015-04-07 00:42:48 UTC
Created attachment 114892 [details]
error file from previously mentioned error

I'll upgrade to RC6 and see if it happens again.
Comment 3 matthias.a.lee 2015-04-10 16:55:22 UTC
Created attachment 115009 [details]
another dump file

It looks like the issue has happened again:
[ 2768.504078] [drm] stuck on render ring
[ 2768.506913] [drm] GPU HANG: ecode 8:0:0xfffffffe, in Xorg [931], reason: Ring hung, action: reset
[ 2768.506914] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[ 2768.506915] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[ 2768.506915] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[ 2768.506916] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[ 2768.506917] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[ 2768.512055] drm/i915: Resetting chip after gpu hang


This is on Kernel 4.0 RC7

Error file has been attached
Comment 4 Chris Wilson 2015-04-10 20:40:59 UTC
Oh, execlist vs suspend?

Can you please try i915.enable_execlists=0?
Comment 5 matthias.a.lee 2015-04-10 22:14:45 UTC
setting i915.enable_execlists=0 changed the output, now i get this: 

[  308.629021] [drm:stop_ring [i915]] *ERROR* render ring : timed out trying to stop ring

I should note, that besides these error messages I don't see any other effects of this bug.
Comment 6 Chris Wilson 2015-04-11 08:33:30 UTC

*** This bug has been marked as a duplicate of bug 83908 ***


bug/show.html.tmpl processed on Jan 19, 2017 at 21:25:33.
(provided by the Example extension).