Bug 90440 - 250KB PDF converted to 50MB PDF
Summary: 250KB PDF converted to 50MB PDF
Status: RESOLVED MOVED
Alias: None
Product: poppler
Classification: Unclassified
Component: cairo backend (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-13 22:20 UTC by Ofir
Modified: 2018-08-21 10:39 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
PDF to convert (250.24 KB, application/pdf)
2015-05-13 22:20 UTC, Ofir
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ofir 2015-05-13 22:20:23 UTC
Created attachment 115751 [details]
PDF to convert

Tested with poppler-utils 0.30.0 Ubuntu 15.04 64bit.

Converting the attached PDF to SVG with pdftocairo give me a 50MB SVG which crashes viewers.

It takes about a minute for Evince to display the PDF compared to 1 second with Foxit Reader.
Comment 1 Ofir 2015-05-13 22:29:42 UTC
Might be a duplicate of:
https://bugs.freedesktop.org/show_bug.cgi?id=90009
Pattern image is repeated thousands of times, producing huge output
Comment 2 kurt.pfeifle 2016-03-02 02:19:29 UTC
You can run the following commands to gain some insight into what the problem with this file is:

$>  pdfimages -listFlow-background.pdf | head
page num  type width height color comp bpc  enc interp object ID x-ppi y-ppi size ratio
---------------------------------------------------------------------------------------
   1   0 image     5     5  rgb     3   8  image  no        4  0   150   150   25B  33%
   1   1 smask     5     5  gray    1   8  image  no        4  0   150   150   11B  44%
   1   2 image     5     5  rgb     3   8  image  no        4  0   150   150   25B  33%
   1   3 smask     5     5  gray    1   8  image  no        4  0   150   150   11B  44%
   1   4 image     5     5  rgb     3   8  image  no        4  0   150   150   25B  33%
   1   5 smask     5     5  gray    1   8  image  no        4  0   150   150   11B  44%
   1   6 image     5     5  rgb     3   8  image  no        4  0   150   150   25B  33%
   1   7 smask     5     5  gray    1   8  image  no        4  0   150   150   11B  44%

$> pdfimages -list ~/Downloads/Flow-background.pdf | wc -l
  163934

This page contains almost 164.000 mini-images (sized 5x5 pixels each, half of them real images, the other half being "softmasks")!

Ok, the last sentence was not very precise... In reality it contains 164.000 references to a mini-image sized 5x5 pixels and located in object "4 0". (This seems to also indicate a problem with pdfimages itself, since I think it should point to a different object for the softmask...)
Comment 3 GitLab Migration User 2018-08-21 10:39:39 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/poppler/poppler/issues/311.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.