Bug 9060 - The backslash/bar definition is missing in the us dvorak variant
Summary: The backslash/bar definition is missing in the us dvorak variant
Status: RESOLVED DUPLICATE of bug 9061
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: 6.9.0
Hardware: All All
: high minor
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords: i18n, l10n, movetoxkc, patch
Depends on:
Blocks:
 
Reported: 2006-11-17 05:26 UTC by Johann "Myrkraverk" Oskarsson
Modified: 2007-01-25 13:07 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Patch to fix backslash/bar in us(dvorak) (381 bytes, patch)
2006-11-17 05:28 UTC, Johann "Myrkraverk" Oskarsson
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Johann "Myrkraverk" Oskarsson 2006-11-17 05:26:23 UTC
The backslash/bar definition is missing from the dvorak variant of the us
layout,  in the (on my system) /usr/X11R6/lib/X11/xkb/symbols/pc/us file.

This means, that switching to a layout that uses this key for something else,
such as the Icelandic one - is - and swithing to us(dvorak), the key is still
using the Icelandic definition.

I found this bug on Solaris Express Community Release build 50 (snv_50), which I
believe has Xorg 6.9.  This probably applies to all other Xorg versions as well.
 I'll also bug xkeyboard-config about this.

I also have a patch to fix this, but this form does not give an option to upload
it.  Please tell me what to do with the patch, it's just a one-liner.
Comment 1 Johann "Myrkraverk" Oskarsson 2006-11-17 05:28:21 UTC
Created attachment 7816 [details] [review]
Patch to fix backslash/bar in us(dvorak)
Comment 2 Johann "Myrkraverk" Oskarsson 2006-11-17 05:34:53 UTC
I've also bugged xkeyboard-config in
https://bugs.freedesktop.org/show_bug.cgi?id=9061
for this,

Johann
Comment 3 Piter PUNK 2007-01-25 13:07:23 UTC

*** This bug has been marked as a duplicate of bug 9061 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.