Bug 9061 - The backslash/bar definition is missing in the us dvorak variant
Summary: The backslash/bar definition is missing in the us dvorak variant
Status: RESOLVED FIXED
Alias: None
Product: xkeyboard-config
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: All All
: high normal
Assignee: xkb
QA Contact:
URL:
Whiteboard:
Keywords: i18n, l10n, patch
: 9060 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-11-17 05:32 UTC by Johann "Myrkraverk" Oskarsson
Modified: 2007-01-25 13:27 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Patch to fix backslash/bar in us(dvorak) (381 bytes, patch)
2006-11-17 05:33 UTC, Johann "Myrkraverk" Oskarsson
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Johann "Myrkraverk" Oskarsson 2006-11-17 05:32:56 UTC
This is a duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=9060

The backslash/bar definition is missing from the dvorak variant of the us
layout,  in the (on my system) /usr/X11R6/lib/X11/xkb/symbols/pc/us file.

This means, that switching to a layout that uses this key for something else,
such as the Icelandic one - is - and swithing to us(dvorak), the key is still
using the Icelandic definition.

I found this bug on Solaris Express Community Release build 50 (snv_50), which I
believe has Xorg 6.9.  This probably applies to all other Xorg versions as well.
Comment 1 Johann "Myrkraverk" Oskarsson 2006-11-17 05:33:45 UTC
Created attachment 7817 [details] [review]
Patch to fix backslash/bar in us(dvorak)
Comment 2 Sergey V. Udaltsov 2006-11-17 13:29:09 UTC
Thanks, committed.
Comment 3 Piter PUNK 2007-01-25 13:07:23 UTC
*** Bug 9060 has been marked as a duplicate of this bug. ***
Comment 4 Piter PUNK 2007-01-25 13:10:47 UTC
(In reply to comment #2)
> Thanks, committed.
> 

Sergey, I download the CVS today and don't find the backslash/bar in us(dvorak). Maybe the patch is reversed by other one?
Comment 5 Sergey V. Udaltsov 2007-01-25 13:14:35 UTC
It is in dvorak-classic now. Should it be put in dvorak as well?
Comment 6 Piter PUNK 2007-01-25 13:21:47 UTC
(In reply to comment #5)
> It is in dvorak-classic now. Should it be put in dvorak as well?
> 

I think yes. The bug is filled against xorg 6.9, before the dvorak-classic
inclusion in xkeyboard-config. I think the bug affect both layouts and
dvorak-{r,l} but these two includes us(dvorak).
Comment 7 Sergey V. Udaltsov 2007-01-25 13:27:02 UTC
Actually IIRC in xkeyboard-config dvorak was moved to dvorak-classic, that is why the patch got lost. Anyway, fixed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.