Bug 91041 - Purple line is visible on left side of screen and the screen is blurry using HTMI output with AMD radeon
Summary: Purple line is visible on left side of screen and the screen is blurry using ...
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Default DRI bug account
QA Contact:
URL: Bug on arch linux bug tracker: https:...
Whiteboard:
Keywords:
: 91253 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-06-20 22:28 UTC by robotbuilderfiletransfer
Modified: 2015-08-06 13:16 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg output (59.21 KB, text/plain)
2015-06-25 15:40 UTC, robotbuilderfiletransfer
no flags Details
xorg log (231.52 KB, text/plain)
2015-06-25 15:41 UTC, robotbuilderfiletransfer
no flags Details
possible fix (3.08 KB, patch)
2015-07-23 14:31 UTC, Alex Deucher
no flags Details | Splinter Review
possible fix (12.21 KB, patch)
2015-07-23 19:04 UTC, Alex Deucher
no flags Details | Splinter Review
possible fix (17.85 KB, patch)
2015-07-23 22:20 UTC, Alex Deucher
no flags Details | Splinter Review
proper fix (17.93 KB, patch)
2015-07-27 13:17 UTC, Alex Deucher
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description robotbuilderfiletransfer 2015-06-20 22:28:11 UTC
The problem can be sloved by executing this command: "xrandr --output HDMI-0 --auto --set audio off".
I found a simillar, but very old (6 years old), bug here: https://bugs.freedesktop.org/show_bug.cgi?id=23384.
Comment 1 robotbuilderfiletransfer 2015-06-20 22:48:14 UTC
(In reply to robotbuilderfiletransfer from comment #0)
> The problem can be sloved by executing this command: "xrandr --output HDMI-0
> --auto --set audio off".
> I found a simillar, but very old (6 years old), bug here:
> https://bugs.freedesktop.org/show_bug.cgi?id=23384.

I am using the xf86-video-ati driver.  My kernel version is 4.0.5-1.
Comment 2 Alex Deucher 2015-06-24 17:40:52 UTC
Is this still an issue with a newer kernel?  Please attach your xorg log and dmesg output.
Comment 3 robotbuilderfiletransfer 2015-06-25 15:40:34 UTC
Created attachment 116716 [details]
dmesg output
Comment 4 robotbuilderfiletransfer 2015-06-25 15:41:08 UTC
Created attachment 116717 [details]
xorg log
Comment 5 robotbuilderfiletransfer 2015-06-25 15:42:28 UTC
(In reply to Alex Deucher from comment #2)
> Is this still an issue with a newer kernel?  Please attach your xorg log and
> dmesg output.

I have upgraded to the latest linux kernel version: 4.0.6-1, and the bug still occurres.
Comment 6 robotbuilderfiletransfer 2015-06-25 16:07:55 UTC
occures*
Comment 7 Alex Deucher 2015-07-23 14:31:55 UTC
Created attachment 117316 [details] [review]
possible fix

Does this patch fix the issue?
Comment 8 robotbuilderfiletransfer 2015-07-23 14:46:47 UTC
(In reply to Alex Deucher from comment #7)
> Created attachment 117316 [details] [review] [review]
> possible fix
> 
> Does this patch fix the issue?

So I will have to rebuild the diver from source?
Comment 9 Alex Deucher 2015-07-23 14:58:19 UTC
Yes.  you'll need apply the patch to your kernel and recompile.
Comment 10 Alex Deucher 2015-07-23 19:04:11 UTC
Created attachment 117322 [details] [review]
possible fix

Updated patch.
Comment 11 Alex Deucher 2015-07-23 22:20:08 UTC
Created attachment 117326 [details] [review]
possible fix

Updated patch.
Comment 12 robotbuilderfiletransfer 2015-07-24 17:28:28 UTC
(In reply to Alex Deucher from comment #11)
> Created attachment 117326 [details] [review] [review]
> possible fix
> 
> Updated patch.

I have never applied a patch before, nor have I recompiled the linux kernel.  Is there documentation on how to recompile the linux kernel?
Comment 13 Alex Deucher 2015-07-27 13:17:08 UTC
*** Bug 91302 has been marked as a duplicate of this bug. ***
Comment 14 Alex Deucher 2015-07-27 13:17:35 UTC
Created attachment 117395 [details] [review]
proper fix
Comment 15 Maxqia 2015-07-27 20:16:06 UTC
Tested Patch, Seems to be working
Comment 16 Andreas Tunek 2015-07-28 19:16:58 UTC
Patch works for me.
Comment 17 Alex Deucher 2015-07-30 13:52:16 UTC
*** Bug 91253 has been marked as a duplicate of this bug. ***
Comment 18 Maxqia 2015-08-06 08:59:54 UTC
I'm having issues with Linux 4.2 RC5 with the Displayport audio being warped. Doesn't happen with 4.1.3 with the patch from https://bugzilla.kernel.org/attachment.cgi?id=183611.
Comment 19 Alex Deucher 2015-08-06 13:16:30 UTC
(In reply to Maxqia from comment #18)
> I'm having issues with Linux 4.2 RC5 with the Displayport audio being
> warped. Doesn't happen with 4.1.3 with the patch from
> https://bugzilla.kernel.org/attachment.cgi?id=183611.

Please open a different bug for that issue.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.