Bug 91342 - Very dark textures on some objects in indoors environments in Postal 2
Summary: Very dark textures on some objects in indoors environments in Postal 2
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
: 91998 (view as bug list)
Depends on:
Blocks: 77449
  Show dependency treegraph
 
Reported: 2015-07-14 22:59 UTC by Bryant
Modified: 2016-08-20 22:21 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Output of glxinfo (60.13 KB, text/plain)
2015-07-15 03:38 UTC, Bryant
Details
Output of dmesg after game has been run and closed (76.02 KB, text/plain)
2015-07-15 03:49 UTC, Bryant
Details
Photo of the game showing a properly-rendered door (1.89 MB, image/jpeg)
2015-07-15 03:56 UTC, Bryant
Details
Photo of the game showing a badly-rendered door (closed) (1.52 MB, image/jpeg)
2015-07-15 03:57 UTC, Bryant
Details
Photo of the game showing a badly-rendered door (open) (1.41 MB, image/jpeg)
2015-07-15 03:57 UTC, Bryant
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bryant 2015-07-14 22:59:41 UTC
I'd like to take a screenshot, but Postal 2 likes to take over my desktop and I'm not certain how to rectify this. I can't alt-tab out of Postal 2 to take a screenshot and using Steam's screenshot utility, I only get garbled output.

 but on radeonsi on Cape Verde hardware (git-8787141) some models (mostly NPCs and doors) have VERY dark lighting, almost black. For the doors it is always the entire door that is dark, but it then sometimes is properly lit when I walk close enough to the door. For NPCs, they are sometimes properly lit below the waist and very dark above.

I have an extra game in my Steam inventory and will be happy to send it to someone to help debug this.
Comment 1 Michel Dänzer 2015-07-15 03:19:32 UTC
(In reply to acutiator from comment #0)
> I'd like to take a screenshot, but Postal 2 likes to take over my desktop
> and I'm not certain how to rectify this. I can't alt-tab out of Postal 2 to
> take a screenshot and using Steam's screenshot utility, I only get garbled
> output.

You could log in via ssh and get a screenshot using a command line utility, or you could take a picture of the screen.

Please attach the /var/log/Xorg.0.log file and the output of dmesg and glxinfo.
Comment 2 Bryant 2015-07-15 03:38:01 UTC
Created attachment 117126 [details]
Output of glxinfo
Comment 3 Bryant 2015-07-15 03:49:35 UTC
Created attachment 117127 [details]
Output of dmesg after game has been run and closed
Comment 4 Bryant 2015-07-15 03:56:46 UTC
Created attachment 117128 [details]
Photo of the game showing a properly-rendered door
Comment 5 Bryant 2015-07-15 03:57:35 UTC
Created attachment 117129 [details]
Photo of the game showing a badly-rendered door (closed)
Comment 6 Bryant 2015-07-15 03:57:52 UTC
Created attachment 117130 [details]
Photo of the game showing a badly-rendered door (open)
Comment 7 Bryant 2015-07-15 03:58:28 UTC
I tried taking a screenshot of the game running in windowed mode using the command `DISPLAY=:0 xwd -root | convert - /tmp/FILENAME`, but it only showed the game windows as all black. Any idea why this would be?

Anyways, I just took pictures with my phone of the same door in the foyer to the police building. The one to the outside is very dark/black and the one to the inside (presumably the same texture and physical model) is properly textured/lit.
Comment 8 Marek Olšák 2015-08-06 12:58:25 UTC
Would you please record a trace using apitrace and send it to us? Thanks.

https://github.com/apitrace/apitrace
Comment 9 Daniel Scharrer 2015-08-06 14:16:35 UTC
I can reproduce the issue on my Radeon HD 7950 (TAHITI) - here is an apitrace:

 http://constexpr.org/tmp/POSTAL2-radeonsi.trace.xz (75 MiB)
Comment 10 Marek Olšák 2015-08-06 14:48:52 UTC
In addition to your Tahiti, Tonga is affected too.
Comment 11 Daniel Scharrer 2015-10-01 12:13:10 UTC
*** Bug 91998 has been marked as a duplicate of this bug. ***
Comment 12 Daniel Scharrer 2015-10-01 21:38:06 UTC
The apitrace is fixed for me with this commit:
http://cgit.freedesktop.org/mesa/mesa/commit/?id=b3f9c5cc0fab6d770d220efd87ba3746c6673875

acutiator, can you check if the bug is fixed for you as well?
Comment 13 Bryant 2015-10-03 03:31:29 UTC
I can't compile this right now as Mesa won't build for me on Fedora 22 using llvm from Rawhide. But I do have an extra Postal 2 game in my Steam inventory, so if anyone wants it so they can test this, I'm happy to provide it.
Comment 14 Daniel Scharrer 2015-10-03 10:20:59 UTC
I do have POSTAL 2 myself and the it's fixed for me - just wanted to make sure we were seeing the same issue.
Comment 15 Declan Hoare 2016-08-13 11:00:58 UTC
I have the exact same symptoms on Arch, RadeonSI, Mesa 12.0.1-7, on an R7 370, with the latest Steam version of POSTAL 2. I think there has been a regression.
Comment 16 Dmytro Zverev 2016-08-13 14:22:40 UTC
I confirm same issue with Portal. Some textures have very dark lighting. With latest stable 12.0.1 all fine. Git version have this regression. Wine games have broken textures too (test on No One Lives Forever, Mesa 12.0.1 == ok, git == fail).
Comment 17 Kai 2016-08-13 14:51:34 UTC
Can you check whether the resurfacing of this issue might be a duplicate of bug 97285? Just compile Mesa with attachment 125699 [details] [review] applied and verify that the issue persist if you use that version of Mesa. If it is fixed you should close this bug again and subscribe to the other because the original cause of this and the current problem would be different (even though the symptoms might be similar).
Comment 18 Dmytro Zverev 2016-08-13 19:37:10 UTC
As Kai say, this bug duplicate of bug 97285. I check patch and apply it to fresh git and this fix it. So it can be mark as RESOVLED.

Original bug: https://bugs.freedesktop.org/show_bug.cgi?id=97285
Patch to fix: https://bugs.freedesktop.org/attachment.cgi?id=125699
Comment 19 Daniel Scharrer 2016-08-13 23:30:24 UTC
Dmytro Zverev, you are talking about a completely different bug in a different game.

This has indeed regressed as the fix was effectively removed in commit fe2d2c7ad8793fbcc4761cf5b51270c296eb811c
Author: Matt Turner <mattst88@gmail.com>
Date:   Sat Feb 27 14:04:30 2016 -0800

    program: Remove NV_fragment_program Abs support.
    
    Reviewed-by: Kenneth Graunke <kenneth@whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick@intel.com>
    Acked-by: Brian Paul <brianp@vmware.com>

I'll send a patch soon.
Comment 20 Daniel Scharrer 2016-08-14 00:24:25 UTC
Fixed by https://patchwork.freedesktop.org/patch/105070/
Comment 21 Daniel Scharrer 2016-08-20 22:21:23 UTC
This has been fixed in Mesa git master:

https://cgit.freedesktop.org/mesa/mesa/commit/?id=16ef7ab5c13d2c5638f5a4e1fe7f0303d26b4e96


bug/show.html.tmpl processed on Feb 24, 2017 at 03:38:06.
(provided by the Example extension).