Bug 92270 - Radeon R7 M260/M265 - *ERROR* amdgpu: ring 0 test failed (scratch(0xC040)=0xCAFEDEAD)
Summary: Radeon R7 M260/M265 - *ERROR* amdgpu: ring 0 test failed (scratch(0xC040)=0x...
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
: 91330 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-10-03 20:06 UTC by Ederson
Modified: 2016-05-31 02:39 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg (64.39 KB, text/plain)
2015-10-03 20:06 UTC, Ederson
no flags Details
lspci -k (2.74 KB, text/plain)
2015-10-03 20:07 UTC, Ederson
no flags Details
Mark iceland as experimental (1.80 KB, patch)
2015-10-06 14:59 UTC, Alex Deucher
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Ederson 2015-10-03 20:06:30 UTC
Created attachment 118649 [details]
dmesg

Hello,

I have a Dell Inspiron with a Radeon R7 M260/M265 [Topaz XT] - as reported by lspci, and I'm facing problems with GPU initialisation, rendenring it unusable, it is not listed on `xrandr --listproviders`, for instance, althoug the driver is properly loaded. Attached are `dmesg` and `lspci -k`. Please let me know if there's something else I can do to help.

Thanks for any help,
Comment 1 Ederson 2015-10-03 20:07:14 UTC
Created attachment 118650 [details]
lspci -k
Comment 2 Christian König 2015-10-05 13:17:24 UTC
I wouldn't call this "properly loaded", the kernel driver completely fails to initialize the hardware and unloads itself after realizing that this won't work.

Good to know that unloading the driver works, but I don't have any idea what's going wrong here.

@Alex: How well did we already tested Topaz? If not we might want to disable the PCI-ID for now.
Comment 3 Ederson 2015-10-05 22:52:17 UTC
Well, I've said "properly loaded" because `amdgpu` is listed on `lsmod`.
Comment 4 Alex Deucher 2015-10-06 14:57:02 UTC
*** Bug 91330 has been marked as a duplicate of this bug. ***
Comment 5 Alex Deucher 2015-10-06 14:59:43 UTC
Created attachment 118719 [details] [review]
Mark iceland as experimental

(In reply to Christian König from comment #2)
> 
> @Alex: How well did we already tested Topaz? If not we might want to disable
> the PCI-ID for now.

We haven't really tested them much.  How about the attached patch?
Comment 6 Christian König 2015-10-06 15:27:16 UTC
(In reply to Alex Deucher from comment #5)
> Created attachment 118719 [details] [review] [review]
> Mark iceland as experimental
> 
> (In reply to Christian König from comment #2)
> > 
> > @Alex: How well did we already tested Topaz? If not we might want to disable
> > the PCI-ID for now.
> 
> We haven't really tested them much.  How about the attached patch?

Yeah, probably a good idea until we have time to fix those.

Patch is Reviewed-by: Christian König <christian.koenig@amd.com>
Comment 7 René Linder 2015-12-11 15:14:45 UTC
Is there any Progress with this Bug? I've a Notebook here from a project, where the Official Driver could not be used currently (Xorg 1.18)
Comment 8 Chris 2016-01-16 20:47:14 UTC
I'm also experiencing this bug with a Radeon 6850 and GNOME 3 desktop, on following systems:

Ubuntu 14.04 with 3.19 kernel and fglrx drivers.
openSUSE Leap 42.1 with open source drivers.

It happens when I resume from suspend. System hangs and switching to tty1 displays all the errors such as "ring 0 test failed", etc. From there, I have to shutdown the system if I want to use it.
Comment 9 Michel Dänzer 2016-01-18 06:19:46 UTC
(In reply to Chris from comment #8)
> I'm also experiencing this bug with a Radeon 6850 [...]

Different GPU => file your own report please.
Comment 10 Ederson 2016-05-31 01:34:35 UTC
I can confirm that issue is now gone, using Linux 4.5 (which contains dba280b20bfd1c2bed8a07ce3f75a6da8ba7d247). Who does take care of closing this issue?
Comment 11 Michel Dänzer 2016-05-31 02:39:03 UTC
Resolving per comment 10, thanks for the followup.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.