Bug 92915 - GeoClue is a mystery to integrate: Include rules for polkit please
Summary: GeoClue is a mystery to integrate: Include rules for polkit please
Status: RESOLVED NOTOURBUG
Alias: None
Product: GeoClue
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Geoclue Bugs
QA Contact: Geoclue Bugs
URL:
Whiteboard:
Keywords:
: 93026 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-11-12 11:25 UTC by Tristan Van Berkom
Modified: 2015-11-21 14:16 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tristan Van Berkom 2015-11-12 11:25:34 UTC
It seems that debian is rolling it's own geoclue-2.0.rules and installing it into /usr/share/polkit-d/rules.d

When building a system from scratch, geoclue just has no chance of working without this essential file being installed.

Why is this hidden away in some obscure location ? It would be much less of a mystery to integrate geoclue if the polkit rules were installed with a simple make install.
Comment 1 Bastien Nocera 2015-11-12 11:28:00 UTC
(In reply to Tristan Van Berkom from comment #0)
> It seems that debian is rolling it's own geoclue-2.0.rules and installing it
> into /usr/share/polkit-d/rules.d
> 
> When building a system from scratch, geoclue just has no chance of working
> without this essential file being installed.

It's not needed. There are no polkit checks in geoclue itself. It's a debian problem (and it would be good if there was an upstream bug with discussions about this).
Comment 2 Laurent Bigonville 2015-11-12 11:37:47 UTC
The polkit rule has been added in debian because modemmanager is compiled in "strict" mode and block locations request by default.

As stated in the debian/changelog file:

  * [8d8c2fe3] Add polkit rules and pkla files to allow geoclue to query
               a modem location (Closes: #765184)

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=765184
Comment 3 Zeeshan Ali 2015-11-12 17:01:15 UTC
Well, until MM devs implement this:

https://bugs.freedesktop.org/show_bug.cgi?id=85036

I'm afraid you're going to have to be doing what you are currently doing in debian.
Comment 4 Zeeshan Ali 2015-11-21 14:16:15 UTC
*** Bug 93026 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.