Bug 93026 - Polkit configuration to allow geoclue to contact modem-manager
Summary: Polkit configuration to allow geoclue to contact modem-manager
Status: RESOLVED DUPLICATE of bug 92915
Alias: None
Product: GeoClue
Classification: Unclassified
Component: Modem source (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Geoclue Bugs
QA Contact: Geoclue Bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-19 21:05 UTC by Laurent Bigonville
Modified: 2015-11-21 15:18 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
geoclue-2.0.pkla (217 bytes, text/plain)
2015-11-19 21:05 UTC, Laurent Bigonville
Details
geoclue-2.0.rules (263 bytes, text/plain)
2015-11-19 21:05 UTC, Laurent Bigonville
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Bigonville 2015-11-19 21:05:20 UTC
Created attachment 119951 [details]
geoclue-2.0.pkla

Hi,

When modem-manager is compiled in "strict" mode, it seems that geoclue cannot query the modem.

In debian we have added these 2 polkit files
Comment 1 Laurent Bigonville 2015-11-19 21:05:38 UTC
Created attachment 119952 [details]
geoclue-2.0.rules
Comment 2 Zeeshan Ali 2015-11-20 15:06:04 UTC
Isn't this a dup of bug#92915 ?
Comment 3 Laurent Bigonville 2015-11-21 12:17:31 UTC
Yes it is, I completely forgot about the other bug.

Note that hadess asked me to propose these files on the bugzilla
Comment 4 Zeeshan Ali 2015-11-21 14:16:15 UTC
(In reply to Laurent Bigonville from comment #3)
> Yes it is, I completely forgot about the other bug.
> 
> Note that hadess asked me to propose these files on the bugzilla

OK, please re-open that bug with paste of your conversation with him. I'm guessing he'll turn these files into patches with proper commit log then. :)

*** This bug has been marked as a duplicate of bug 92915 ***
Comment 5 Bastien Nocera 2015-11-21 15:18:35 UTC
(In reply to Laurent Bigonville from comment #3)
> Yes it is, I completely forgot about the other bug.
> 
> Note that hadess asked me to propose these files on the bugzilla

I asked that and linked to the original bug from Tristan ;)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.