Bug 93664 - GPU Hung with intel HD 3000 (i915).
Summary: GPU Hung with intel HD 3000 (i915).
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-11 08:35 UTC by Alexander
Modified: 2017-07-24 22:43 UTC (History)
1 user (show)

See Also:
i915 platform: SNB
i915 features: GPU hang


Attachments
System info. (308.93 KB, text/plain)
2016-01-11 08:35 UTC, Alexander
no flags Details
/sys/class/drm/card0/error (317.78 KB, text/plain)
2016-01-11 12:29 UTC, Alexander
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander 2016-01-11 08:35:50 UTC
Created attachment 120950 [details]
System info.

I face some problems with my Intel HD 3000 (i915) GPU.

Mainly

[drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=1059075 end=1059076)
[Jan 4 17:25] [drm] stuck on render ring
[  +0.000605] [drm] GPU HANG: ecode 6:0:0x87e8effd, in kwin [20369], reason: Ring hung, action: reset
[  +0.001867] drm/i915: Resetting chip after gpu hang
[Jan 4 17:35] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=1159454 end=1159455)
[Jan 4 17:39] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=1174633 end=1174634)

This will result in a 5~10 second screen freeze (I can hear sound playing). The mouse pointer is moving in most cases. This will occur with 3D programs (e.g. KiCAD 3D viewer).

And a more severe problem that lead to an extensive screen freeze for about 5 minutes. The following problem manifest it self when for example I watch a movie with vlc and fast forward it.

----------[ cut here ]------------
[14435.117621] WARNING: CPU: 1 PID: 3953 at drivers/gpu/drm/i915/intel_display.c:3921 intel_crtc_wait_for_pending_flips+0x1f3/0x200 [i915]()
[14435.117622] Removing stuck page flip
[14435.117623] Modules linked in: sha256_generic hmac drbg ansi_cprng ctr ccm ax25 fuse btusb uvcvideo btrtl btbcm videobuf2_vmalloc btintel bluetooth videobuf2_memops videobuf2_core v4l2_common videodev uas media joydev mousedev arc4 iwldvm iTCO_wdt iTCO_vendor_support dell_wmi intel_rapl sparse_keymap iosf_mbi x86_pkg_temp_thermal snd_hda_codec_hdmi mac80211 intel_powerclamp snd_hda_codec_conexant snd_hda_codec_generic dell_laptop coretemp snd_hda_intel kvm_intel iwlwifi dcdbas kvm snd_hda_codec psmouse crc32_pclmul cfg80211 pcspkr snd_hda_core snd_hwdep snd_pcm input_leds snd_timer snd led_class thermal atl1c soundcore serio_raw i2c_i801 rfkill evdev mac_hid mei_me mei lpc_ich shpchp ac wmi battery dell_smo8800 sch_fq_codel cpufreq_conservative cpufreq_powersave processor dell_smm_hwmon sg ip_tables
[14435.117656]  x_tables ext4 crc16 mbcache jbd2 dm_mod usb_storage sr_mod cdrom sd_mod atkbd libps2 crc32c_intel ahci libahci libata xhci_pci xhci_hcd scsi_mod ehci_pci ehci_hcd usbcore usb_common i8042 serio i915 video button intel_gtt i2c_algo_bit drm_kms_helper drm agpgart
[14435.117670] CPU: 1 PID: 3953 Comm: Xorg Tainted: G     U  W       4.2.5-1-ARCH #1
[14435.117672] Hardware name: Dell Inc.          Dell System Inspiron N411Z/0H8G5G, BIOS A06 09/10/2012
[14435.117673]  c1631967 f34d4ccd 00000000 f0403c8c c14c8e8d f0403ccc f0403cbc c1058457
[14435.117677]  f8312740 f0403cec 00000f71 f831db28 00000f51 f82b9ba3 f82b9ba3 f456c500
[14435.117680]  f710cbc8 f7110000 f0403cd8 c10584ce 00000009 f0403ccc f8312740 f0403cec
[14435.117684] Call Trace:
[14435.117686]  [<c14c8e8d>] dump_stack+0x48/0x69
[14435.117689]  [<c1058457>] warn_slowpath_common+0x87/0xc0
[14435.117697]  [<f82b9ba3>] ? intel_crtc_wait_for_pending_flips+0x1f3/0x200 [i915]
[14435.117706]  [<f82b9ba3>] ? intel_crtc_wait_for_pending_flips+0x1f3/0x200 [i915]
[14435.117708]  [<c10584ce>] warn_slowpath_fmt+0x3e/0x60
[14435.117716]  [<f82b9ba3>] intel_crtc_wait_for_pending_flips+0x1f3/0x200 [i915]
[14435.117719]  [<c1093e80>] ? wake_atomic_t_function+0x70/0x70
[14435.117728]  [<f82bb417>] intel_begin_crtc_commit+0x1b7/0x1c0 [i915]
[14435.117731]  [<f80808c4>] drm_atomic_helper_commit_planes_on_crtc+0x44/0x1f0 [drm_kms_helper]
[14435.117742]  [<f82d4c9f>] intel_atomic_commit+0x5f/0xf0 [i915]
[14435.117746]  [<f80d3c52>] drm_atomic_commit+0x32/0x60 [drm]
[14435.117749]  [<f8080c3c>] drm_atomic_helper_disable_plane+0xcc/0x110 [drm_kms_helper]
[14435.117756]  [<f80c41be>] __setplane_internal+0x20e/0x2e0 [drm]
[14435.117761]  [<f80d2ba4>] ? drm_modeset_lock_all_crtcs+0x84/0x90 [drm]
[14435.117765]  [<f80d2dd9>] ? __drm_modeset_lock_all+0x109/0x130 [drm]
[14435.117770]  [<f80c7a75>] drm_mode_setplane+0x135/0x1d0 [drm]
[14435.117775]  [<f80c7940>] ? drm_plane_check_pixel_format+0x40/0x40 [drm]
[14435.117780]  [<f80b8fb3>] drm_ioctl+0x143/0x560 [drm]
[14435.117782]  [<c14cd8ad>] ? _raw_spin_unlock_bh+0xd/0x10
[14435.117786]  [<f80c7940>] ? drm_plane_check_pixel_format+0x40/0x40 [drm]
[14435.117789]  [<c117d9f3>] ? kmem_cache_free+0x1c3/0x1e0
[14435.117791]  [<c11a8ba4>] ? dentry_free+0x44/0x90
[14435.117793]  [<c11ac068>] ? evict+0xe8/0x160
[14435.117795]  [<c11a8ba4>] ? dentry_free+0x44/0x90
[14435.117799]  [<f80b8e70>] ? drm_copy_field+0x60/0x60 [drm]
[14435.117802]  [<c11a4b92>] do_vfs_ioctl+0x2e2/0x500
[14435.117804]  [<c1062337>] ? recalc_sigpending+0x17/0x50
[14435.117806]  [<c1062f6c>] ? __set_task_blocked+0x3c/0xa0
[14435.117808]  [<c11adffb>] ? __fget+0x6b/0xc0
[14435.117811]  [<c11a4e30>] SyS_ioctl+0x80/0x90
[14435.117813]  [<c14cded7>] sysenter_do_call+0x12/0x12
[14435.117814] ---[ end trace 9e1b1f8d85bd8633 ]---


I have tested numerous setting, with no effect (SNA, UXA, DRI to false and many others).

The problem started with version kernel 4.2 (If I remember correctly).
Comment 1 Chris Wilson 2016-01-11 09:41:35 UTC
The /sys/class/drm/card0/error is essential for diagnosing this following a hang.
Comment 2 Alexander 2016-01-11 12:29:42 UTC
Created attachment 120954 [details]
/sys/class/drm/card0/error
Comment 3 Alexander 2016-01-11 12:30:09 UTC
Ok, just upload it.
Comment 4 Alexander 2016-04-15 14:17:14 UTC
Any progress on this issue?
Comment 5 yann 2016-12-02 13:46:06 UTC
(In reply to Alexander from comment #4)
> Any progress on this issue?

We seem to have neglected the bug a bit, apologies.

Alexander, I am not sure this is linked to ddx and the hung is not happening in render batch buffer. Since There were improvements pushed in kernel that will benefit to your system, so please re-test with latest kernel and mark as REOPENED if you can reproduce (and attach fresh gpu error dump & kernel log) and RESOLVED/* if you cannot reproduce.
Comment 6 Alexander Kaltsas 2016-12-03 16:10:51 UTC
There still is a plethora of errors but the screen doesn't freeze anymore.

[drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=323255 end=323256) time 3728 us, min 763, max 767, scanline start 662, end 39
Comment 7 Jari Tahvanainen 2016-12-19 11:06:13 UTC
Marking this (=gpu hung) as resolved per previous comment. Bug 91883 and/or Bug 94634 can be used to follow up the "Atomic update failure on pipe" dmesg fixing.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.