Bug 93669 - Indirect GLX/X_GLXCreateContext broken in 2.7.9_rc
Summary: Indirect GLX/X_GLXCreateContext broken in 2.7.9_rc
Status: RESOLVED DUPLICATE of bug 96260
Alias: None
Product: XQuartz
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: development (betas, rcs, git)
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium major
Assignee: Jeremy Huddleston Sequoia
QA Contact: Jeremy Huddleston Sequoia
Depends on:
Reported: 2016-01-11 19:52 UTC by Eric Berggren
Modified: 2016-05-28 21:46 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Note You need to log in before you can comment on or make changes to this bug.
Description Eric Berggren 2016-01-11 19:52:59 UTC
OpenGL over X (indirect rendering via ssh tunnel) get X_GLXCreateContext error for any GL [Linux] application under 2.7.9_rc2

Linux% glxinfo  (or glxgears, etc)
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  152 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  26
  Current serial number in output stream:  28

Reverting to 2.7.8 is okay --

  OSX version is 10.10.5 and 10.11.[23]
  Linux platform is RHEL5.9 and RHEL6.6

Local (OSX) GL applications work.

Comment 1 Jeremy Huddleston Sequoia 2016-05-28 21:46:10 UTC

*** This bug has been marked as a duplicate of bug 96260 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.