Bug 96260 - patch for startx that enables IGLX
Summary: patch for startx that enables IGLX
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: App/xinit (show other bugs)
Version: unspecified
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Jeremy Huddleston Sequoia
QA Contact: Jeremy Huddleston Sequoia
URL:
Whiteboard:
Keywords:
: 93669 93953 96261 96433 96506 96559 96849 98407 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-05-28 15:51 UTC by Rich Cook
Modified: 2016-10-24 16:32 UTC (History)
8 users (show)

See Also:
i915 platform:
i915 features:


Attachments
patch file for startx (772 bytes, patch)
2016-05-28 15:51 UTC, Rich Cook
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Rich Cook 2016-05-28 15:51:44 UTC
Created attachment 124148 [details] [review]
patch file for startx

XQuartz 2.7.9 stock install:
rcook@surface86 (~ ): glxgears
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  150 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  23
  Current serial number in output stream:  24
rcook@surface86 (~ ): glxinfo
name of display: surface86:18.0
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  150 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  17
  Current serial number in output stream:  18
rcook@surface86 (~ ):

XQuartz 2.7.9 with +iglx added to serverargs on line 112 of /usr/X11R6/bin/startx
defaultserverargs="$defaultserverargs +iglx"

Works perfectly.
name of display: surface86:18.0
display: surface86:18  screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
server glx vendor string: SGI
server glx version string: 1.4
etc etc etc.

Attached is a patch file.  After patching startx, users can then do this: 
defaults write org.macosforge.xquartz.X11 enable_iglx -bool true
Comment 1 Jeremy Huddleston Sequoia 2016-05-28 17:53:08 UTC
*** Bug 96261 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Huddleston Sequoia 2016-05-28 21:11:46 UTC
https://cgit.freedesktop.org/xorg/app/xinit/commit/?id=4525e14fcfeaaf526227e3addec67d0ce4632270

This should be addressed in XQuartz 2.7.10 beta2 or later (not released yet).
Comment 3 Jeremy Huddleston Sequoia 2016-05-28 21:46:10 UTC
*** Bug 93669 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Huddleston Sequoia 2016-05-29 08:49:02 UTC
*** Bug 93953 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Huddleston Sequoia 2016-06-08 05:41:36 UTC
*** Bug 96433 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Huddleston Sequoia 2016-06-13 08:52:50 UTC
*** Bug 96506 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Huddleston Sequoia 2016-06-17 03:30:36 UTC
*** Bug 96559 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy Huddleston Sequoia 2016-07-07 19:52:58 UTC
*** Bug 96849 has been marked as a duplicate of this bug. ***
Comment 9 Jeremy Huddleston Sequoia 2016-10-24 16:32:39 UTC
*** Bug 98407 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.