Bug 93953 - glxgears and glxifno does not work with ssh to a linux machine from a macbook
Summary: glxgears and glxifno does not work with ssh to a linux machine from a macbook
Status: RESOLVED DUPLICATE of bug 96260
Alias: None
Product: XQuartz
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: unspecified
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Jeremy Huddleston Sequoia
QA Contact: Jeremy Huddleston Sequoia
URL:
Whiteboard:
Keywords:
: 95318 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-02-01 10:41 UTC by walter.bonivento
Modified: 2016-05-29 08:49 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description walter.bonivento 2016-02-01 10:41:14 UTC
Dear All
I need to use OpenGL graphics with ssh forwarding on macbook pro using xquarz.

I have a bug whose behaviour  is hardware dependent
when doing ssh from  my mac to another linux machine
running glxinfo and glxgears after logging on the linux machine


1) from a 2011 mac glxgears opens the window but rotation of gears is not visible or very slow



3) from my 2009 mac the glxgear window opens for a fraction of a second and then disappears


glxinfo:
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  150 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  26
  Current serial number in output stream:  28





Locally on the 2 macs I get:

on the 2011 mac:

glxinfo:
...
OpenGL vendor string: Intel Inc.
OpenGL renderer string: Intel HD Graphics 4000 OpenGL Engine
….

and  on my 2009 mac 
 glxinfo:
...
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: NVIDIA GeForce 9400M OpenGL Engine
--

This explains why the behaviour is different.

I suspect a software bug though....
Comment 1 Jeremy Huddleston Sequoia 2016-02-02 01:11:07 UTC
What version of XQuartz do you have?

What version of mesa is on the remote systems?
Comment 2 walter.bonivento 2016-02-02 08:36:39 UTC
Hi

an even simpler framework, which really goes to the heart of the problem 

I installed on my macbook a linux virtual machine using virtual box

if I open the VM (using ssh to it and then using VNC viewer) all is fine inside the VM window glxinfo gives 

direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
 
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions:
 
GLX version: 1.4
GLX extensions:
  
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.6, 128 bits)
OpenGL version string: 2.1 Mesa 10.6.5
OpenGL shading language version string: 1.30


HOWEVER when I do ssh to this machine 

at present I use on my macbook xquarz 2.7.9_rc2 
(I also tried with the 2.7.8)

I get

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request:  GLXBadContext
  Major opcode of failed request:  150 (GLX)
  Minor opcode of failed request:  6 (X_GLXIsDirect)
  Serial number of failed request:  23
  Current serial number in output stream:  22
Comment 3 walter.bonivento 2016-02-02 08:37:37 UTC
I mean glxinfo:


libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request:  GLXBadContext
  Major opcode of failed request:  150 (GLX)
  Minor opcode of failed request:  6 (X_GLXIsDirect)
  Serial number of failed request:  23
  Current serial number in output stream:  22
Comment 4 Jeremy Huddleston Sequoia 2016-05-12 06:43:12 UTC
*** Bug 95318 has been marked as a duplicate of this bug. ***
Comment 5 Magda 2016-05-12 16:11:08 UTC
Hi indeed it seems like I am facing a very similar issue as described in my previously marked duplicate comment. So is there a way to fix that? I really need that for my work so I have no idea what I need to do. Thanks.
Comment 6 Jeremy Huddleston Sequoia 2016-05-12 18:18:08 UTC
If you are a coder, you could work on a fix, but there's not much chance of someone looking at this unless somebody steps up to do the work.
Comment 7 Magda 2016-05-12 18:25:55 UTC
Oh I see that bad. No I am not unfortunately I am an MD so I just have some understanding of coding but I am not a developer myself. Just to get a better understanding of this is that an issue that apple should be looking at xquartz developers? I am not sure if I am clear on whom the issue best relates to so that I see if I can get a better understanding of whom I should ask about that and perhaps yes, I could get some developers' help if needed. I just need to know on what end the problem lies. Thanks.
Comment 8 Jeremy Huddleston Sequoia 2016-05-12 18:35:34 UTC
(In reply to Magda from comment #7)
> Oh I see that bad. No I am not unfortunately I am an MD so I just have some
> understanding of coding but I am not a developer myself. Just to get a
> better understanding of this is that an issue that apple should be looking
> at xquartz developers? I am not sure if I am clear on whom the issue best
> relates to so that I see if I can get a better understanding of whom I
> should ask about that and perhaps yes, I could get some developers' help if
> needed. I just need to know on what end the problem lies. Thanks.

No, the issue isn't that Apple should be looking for XQuartz developers.  XQuartz is an open source project, and Apple contributed development to it in the past but does not much any more.  I worked on it as an intern project many years ago, but there has not been anyone at Apple working on it as their primary (or even secondary) role for the past 5 years or so.  I've continued to do what I can to keep the project on life support (pulling in security updates, adapting to OS X changes, etc), but I don't have the time to dedicate to the project that it needs.  Also, the current architecture is not the correct solution.  We should be moving to XtoQ.app which is part of libxcwm.  Unfortunately, there aren't any developers working on the project right now.
Comment 9 Magda 2016-05-12 18:38:20 UTC
Oh I see thank you so much for the detailed response. I really appreciate the clarification. I feel like in my Department there may be people who could help and look into that help. I am really glad that you managed to work on that and managed to sustain that for that period of time. I do know what kind of dedication something like that needs and I appreciate it. It was a bit silly but I had not realized it was open source. I will see if I could get someone to help with that then since it is xquartz related from my understanding. Thanks a lot!
Comment 10 Magda 2016-05-13 01:36:24 UTC
Just felt the need to confirm that after some tests based on Jeremy's kind suggestions the commands work flawlessly with xquartz version 2.7.8 on my system. Any other version above brings up errors. Unfortunately I do not have the skills to help fixing that issue but I did want to raise awareness and I will do my best to attract attention on that so that you get all the help you need to keep providing support for that project. Thanks again for the help.
Comment 11 Jeremy Huddleston Sequoia 2016-05-29 08:49:02 UTC

*** This bug has been marked as a duplicate of bug 96260 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.