Bug 93988 - Amdgpu, Tonga R9 380: ring 0 test failed (scratch(0xC040)=0xCAFEDEAD)
Summary: Amdgpu, Tonga R9 380: ring 0 test failed (scratch(0xC040)=0xCAFEDEAD)
Status: RESOLVED NOTABUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-03 15:34 UTC by jk
Modified: 2016-02-05 19:26 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Journalctl (93.48 KB, text/plain)
2016-02-03 15:34 UTC, jk
no flags Details
dmesg (68.04 KB, text/plain)
2016-02-03 15:35 UTC, jk
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description jk 2016-02-03 15:34:39 UTC
Created attachment 121493 [details]
Journalctl

It looks al little bit as this bug here:
https://bugs.freedesktop.org/show_bug.cgi?id=92270

But this time with a R9 380, Gigabyte, 4Gb

Tested kernels:4.2,3,4,5-rc-2
Comment 1 jk 2016-02-03 15:35:21 UTC
Created attachment 121494 [details]
dmesg
Comment 2 Michel Dänzer 2016-02-05 01:57:35 UTC
Why NOTOURBUG? Where was the bug?
Comment 3 jk 2016-02-05 13:38:51 UTC
Ok notabug would be better.. the problem was in mkinitcpio.conf, the radeon module was loaded there and conflicted with the amdgpu module... After i removed this entry everything worked.
Comment 4 Christian König 2016-02-05 19:26:20 UTC
Wait a second. Why the heck should radeon conflict with amdgpu?

As long as nobody messed with the PCI-IDs the kernel should know very well what driver to load for a Tonga.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.