Bug 94127 - [HSW] textureGather + samplerCube sometimes fail
Summary: [HSW] textureGather + samplerCube sometimes fail
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Kenneth Graunke
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 94621 (view as bug list)
Depends on:
Blocks: i965-deqp
  Show dependency treegraph
 
Reported: 2016-02-12 20:34 UTC by Ilia Mirkin
Modified: 2019-03-14 08:40 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
deqp test failure pattern (10.17 KB, text/plain)
2016-02-12 20:34 UTC, Ilia Mirkin
Details
failure mask for one test (259 bytes, image/png)
2016-02-12 22:56 UTC, Ilia Mirkin
Details
another set of errors, with actual/original (3.44 KB, text/plain)
2016-02-12 23:14 UTC, Ilia Mirkin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ilia Mirkin 2016-02-12 20:34:25 UTC
Created attachment 121724 [details]
deqp test failure pattern

I'm seeing the following failure pattern on *texture* dEQP tests. Only cube fails, and not 100% of them. All of these tests pass on nouveau/GK208, so it's not some really dumb texture completeness issue.

It does seem like the only tests that pass are in the filter_mode subgroup (and all of those do seem to pass). So probably something with texture setup?

Amusingly that test case group is

TestCaseGroup(m_context, "filter_mode", "Test that filter modes have no effect");

oops :) I guess it has the effect of causing the tests to pass. By default, nearest/nearest is used for min/mag filters.
Comment 1 Kenneth Graunke 2016-02-12 22:29:50 UTC
Related to #92579?
Comment 2 Ilia Mirkin 2016-02-12 22:36:21 UTC
(In reply to Kenneth Graunke from comment #1)
> Related to #92579?

Don't know. But applying Neil's last patch just makes everything fail :)
Comment 3 Ilia Mirkin 2016-02-12 22:56:30 UTC
Created attachment 121727 [details]
failure mask for one test

I checked a few and they all look like this. The hole at the top moves around a bit, but always this general square of fail inset into the image. Weird.
Comment 4 Ilia Mirkin 2016-02-12 23:14:01 UTC
Created attachment 121728 [details]
another set of errors, with actual/original

If you use chrome, just start typing

data:image/png;base64,

and then paste the base64'd data after the ',' from the attachment -- no need to remove newlines/etc.
Comment 5 Kenneth Graunke 2016-03-22 16:23:01 UTC
*** Bug 94621 has been marked as a duplicate of this bug. ***
Comment 6 Kenneth Graunke 2016-03-24 03:43:20 UTC
Patch on the list:
https://lists.freedesktop.org/archives/mesa-dev/2016-March/110739.html
Comment 7 Mark Janes 2016-04-25 18:16:44 UTC
Ken's patch has been merged.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.