Bug 94621 - dEQP-GLES31.functional.texture.gather.basic.cube.* fails
Summary: dEQP-GLES31.functional.texture.gather.basic.cube.* fails
Status: RESOLVED DUPLICATE of bug 94127
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: i965-deqp
  Show dependency treegraph
 
Reported: 2016-03-19 08:17 UTC by Kenneth Graunke
Modified: 2019-03-14 08:40 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kenneth Graunke 2016-03-19 08:17:20 UTC
The dEQP-GLES31.functional.texture.gather.basic.cube.* test cases are broken.

Setting the wrap modes to BRW_TEXCOORDMODE_CUBE appears to fix all of them.

The test use GL_NEAREST, so we override the wrap modes to CLAMP.  However, textureGather forces GL_LINEAR filtering (regardless of what's specified), so CUBE may actually be appropriate.
Comment 1 Kenneth Graunke 2016-03-19 08:18:24 UTC
If we do need to re-specify wrap modes based on the message type, this means having to double-emit surface states again...one for normal messages, and one for gather4.  We have code for this, we'd just have to apply it in more cases.
Comment 2 Kenneth Graunke 2016-03-21 19:11:40 UTC
I was wrong - we'd need to emit multiple SAMPLER_STATEs, not SURFACE_STATEs.
Comment 3 Ilia Mirkin 2016-03-22 15:43:53 UTC
Is this the same as bug 94127 which I filed a while back?
Comment 4 Kenneth Graunke 2016-03-22 16:23:01 UTC
Yep, thanks - I knew you filed one, but I didn't manage to dig it up.  We'll add yours to the tracker and close this one as a duplicate.

*** This bug has been marked as a duplicate of bug 94127 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.