Bug 95524 - Ditching xf86-video-openchrome in favor of xf86-video-modesetting?
Summary: Ditching xf86-video-openchrome in favor of xf86-video-modesetting?
Status: RESOLVED NOTABUG
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/openchrome (show other bugs)
Version: unspecified
Hardware: All All
: medium normal
Assignee: Openchrome development list
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-22 16:38 UTC by N. W.
Modified: 2016-06-12 04:37 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description N. W. 2016-05-22 16:38:40 UTC
Hello,

according to the discussion in the following Phoronix forum thread:

https://www.phoronix.com/forums/forum/phoronix/latest-phoronix-articles/863332-intel-s-unreleased-3-0-x-org-driver-gets-more-fixes-for-dri3-present

the generic xf86-video-modesetting DDX driver included in xorg-server seems to be better than most vendor specific xf86-video- drivers.

I am wondering:

Then why not ditch xf86-video-openchrome in favor of xf86-video-modesetting?

This has also been requested for:

xf86-video-amdgpu:
https://bugs.freedesktop.org/show_bug.cgi?id=94841

xf86-video-ati:
https://bugs.freedesktop.org/show_bug.cgi?id=94842

xf86-video-intel:
https://bugs.freedesktop.org/show_bug.cgi?id=94843

xf86-video-nouveau:
https://bugs.freedesktop.org/show_bug.cgi?id=94844

And since then there has also been a lot of discussion and benchmarking around this topic, see for example:

http://www.phoronix.com/scan.php?page=search&q=xf86-video-modesetting

Regards
Comment 1 Kevin Brace 2016-05-23 00:42:17 UTC
(In reply to nw9165-3201 from comment #0)

Hi there,

> Hello,
> 
> according to the discussion in the following Phoronix forum thread:
> 
> https://www.phoronix.com/forums/forum/phoronix/latest-phoronix-articles/
> 863332-intel-s-unreleased-3-0-x-org-driver-gets-more-fixes-for-dri3-present
> 
> the generic xf86-video-modesetting DDX driver included in xorg-server seems
> to be better than most vendor specific xf86-video- drivers.
> 
> I am wondering:
> 
> Then why not ditch xf86-video-openchrome in favor of xf86-video-modesetting?
> 
> This has also been requested for:
> 
> xf86-video-amdgpu:
> https://bugs.freedesktop.org/show_bug.cgi?id=94841
> 
> xf86-video-ati:
> https://bugs.freedesktop.org/show_bug.cgi?id=94842
> 
> xf86-video-intel:
> https://bugs.freedesktop.org/show_bug.cgi?id=94843
> 
> xf86-video-nouveau:
> https://bugs.freedesktop.org/show_bug.cgi?id=94844
> 
> And since then there has also been a lot of discussion and benchmarking
> around this topic, see for example:
> 
> http://www.phoronix.com/scan.php?page=search&q=xf86-video-modesetting
> 
> Regards

The developer (James Simmons) who did most of the OpenChrome DRM with KMS disappeared completely, and due to that, the new DRM development has been delayed considerably.
Since then, I have made one commit to fix a minor problem, and Frank Huang (the other active OpenChrome developer) also made one commit to fix an HDMI related problem.

https://cgit.freedesktop.org/openchrome/drm-openchrome/

If I understand the issue correctly, 2D acceleration is currently turned off for the new DRM.
Although it does sound like an excuse, I do not really like working on the newer DRM since it does not compile with the newer Linux kernel (i.e., Linux 4.2 kernel).
I mainly work on OpenChrome UMS code since that is what is sort of working (I phrase it like this since the UMS code is also broken in some ways.), and mode setting code I am currently working on for VIA IGP should eventually make its way into the new DRM. 
That is what my current plan is.
If there is anyone who wants to further develop the newer DRM or turn on 2D acceleration when the newer DRM is used, I will welcome the help.
Comment 2 Kevin Brace 2016-05-23 00:49:48 UTC
Did Michael Larabel set this question up?
Is nw9165-3201@yahoo.com an alternative e-mail for Michael?
Comment 3 N. W. 2016-05-23 13:48:36 UTC
(In reply to Kevin Brace from comment #2)
> Did Michael Larabel set this question up?

No, he did not.

(In reply to Kevin Brace from comment #2)
> Is nw9165-3201@yahoo.com an alternative e-mail for Michael?

No, it is not.

But since Phoronix.com has always reported about this topic in the past, I have Cc'ed Michael Larabel here.

Regards
Comment 4 Kevin Brace 2016-05-26 23:50:08 UTC
(In reply to nw9165-3201 from comment #3)
> 
> 
> No, it is not.

Okay, I can accept you explanation for now.

> 
> But since Phoronix.com has always reported about this topic in the past, I
> have Cc'ed Michael Larabel here.
> 
> Regards

At this point, there is nothing newsworthy to write about OpenChrome.
Whether you or other people like it or not, OpenChrome development lags other more developed graphics device driver stacks by a huge margin.
Effectively, I am the only person working on OpenChrome at this point (Frank is taking a break from the development.), and since the code itself has many problems, it takes tremendous amount of time to figure out why stuff goes wrong.
In terms of the development roadmap, it is something like this.

1. Stablize OpenChrome UMS code

  - Fix screen resolution change bug (a regression that happened between Version 0.3.2 and 0.3.3)
  - Add external TMDS transmitter (VT1632A) support for DVI
  - Add dynamic IGA1 / IGA2 allocation within OpenChrome
  - Fix TV out support
  - Fix ACPI S3 State resume bug with several devices

2. Port OpenChrome UMS code to the newer DRM that supports KMS

3. Add DisplayPort and HDMI support to OpenChrome UMS code

4. Add 2D and video acceleration support when the newer DRM is used

5. Work on developing the 3D device driver stack


Some of these items in the roadmap can be done in parallel with other items (i.e., 3D stack), but since I am the only one actively working on developing OpenChrome, inevitably, they will be done sequentially.
Comment 5 N. W. 2016-05-30 22:35:55 UTC
(In reply to Kevin Brace from comment #4)
> At this point, there is nothing newsworthy to write about OpenChrome.

Yet your post has made it to the news, see:

http://www.phoronix.com/scan.php?page=news_item&px=OpenChrome-One-Dev-Roadmap

;)

And no, I did not write that article.
Comment 6 Kevin Brace 2016-06-12 04:37:31 UTC
I will just close the case since I answered the question.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.