Bug 96433 - XQuartz version 2.7.9 causes glxinfo to break on remote sessions
Summary: XQuartz version 2.7.9 causes glxinfo to break on remote sessions
Status: RESOLVED DUPLICATE of bug 96260
Alias: None
Product: XQuartz
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 2.7.9 (xserver-1.17.4)
Hardware: All Mac OS X (All)
: medium major
Assignee: Jeremy Huddleston Sequoia
QA Contact: Jeremy Huddleston Sequoia
Depends on:
Reported: 2016-06-08 03:26 UTC by Raffaella
Modified: 2016-06-08 05:41 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Note You need to log in before you can comment on or make changes to this bug.
Description Raffaella 2016-06-08 03:26:50 UTC
After updating Xquartz to version 2.7.9 whenever connecting to a linux cluster (with ssh -X -Y) from a mac programs that use GLX stop working, for example:

name of display: localhost:10.0
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  150 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  20
  Current serial number in output stream:  23

Downgrading to Xquartz version 2.7.8 fixes the problem.
Comment 1 Jeremy Huddleston Sequoia 2016-06-08 05:41:36 UTC

*** This bug has been marked as a duplicate of bug 96260 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.