Bug 96849 - 2.7.9 breaks usage of Freesurfer while 2.7.8 does not
Summary: 2.7.9 breaks usage of Freesurfer while 2.7.8 does not
Status: RESOLVED DUPLICATE of bug 96260
Alias: None
Product: XQuartz
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Jeremy Huddleston Sequoia
QA Contact: Jeremy Huddleston Sequoia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-07 19:03 UTC by Robert Welsh
Modified: 2016-07-07 19:52 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Welsh 2016-07-07 19:03:56 UTC
Hi,

A community of XQuartz users also use the Harvard/MGH package Freesurfer (https://surfer.nmr.mgh.harvard.edu/fswiki). The upgrade of xquartz from 2.7.8 to 2.7.9 (on a MacBookPro10,1 running 10.11.4) has resulted in breakage. Not sure if the issue lies with XQuartz, Freesurfer, or both.

Connecting to a debian (wheezy) machine running Freesurfer 5.3.0 and trying the three graphical commands of freeview, qdec, and tkmedit result in the following errors:

rcwelsh@mnemosyne:/home/Software/fs_install/bin$ qdec
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  150 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  1184
  Current serial number in output stream:  1185


rcwelsh@mnemosyne:/home/Software/fs_install/bin$ tkmedit
X Error of failed request:  GLXBadContext
  Major opcode of failed request:  150 (GLX)
  Minor opcode of failed request:  6 (X_GLXIsDirect)
  Serial number of failed request:  26
  Current serial number in output stream:  25


rcwelsh@mnemosyne:/home/Software/fs_install/bin$ freeview
X Error: BadValue (integer parameter out of range for operation) 2
  Extension:    150 (Uknown extension)
  Minor opcode: 3 (Unknown request)
  Resource id:  0x0
X Error: GLXBadContext 160
  Extension:    150 (Uknown extension)
  Minor opcode: 5 (Unknown request)
  Resource id:  0x18001d8
[0]PETSC ERROR: ------------------------------------------------------------------------
[0]PETSC ERROR: Caught signal number 11 SEGV: Segmentation Violation, probably memory access out of range
[0]PETSC ERROR: Try option -start_in_debugger or -on_error_attach_debugger
[0]PETSC ERROR: or see http://www.mcs.anl.gov/petsc/petsc-as/documentation/troubleshooting.html#Signal[0]PETSC ERROR: or try http://valgrind.org on linux or man libgmalloc on Apple to find memory corruption errors
[0]PETSC ERROR: configure using --with-debugging=yes, recompile, link, and run 
[0]PETSC ERROR: to get more information on the crash.
[0]PETSC ERROR: --------------------- Error Message ------------------------------------
[0]PETSC ERROR: Signal received!
[0]PETSC ERROR: ------------------------------------------------------------------------
[0]PETSC ERROR: Petsc Release Version 2.3.3, Patch 13, Thu May 15 17:29:26 CDT 2008 HG revision: 4466c6289a0922df26e20626fd4a0b4dd03c8124
[0]PETSC ERROR: See docs/changes/index.html for recent updates.
[0]PETSC ERROR: See docs/faq.html for hints about trouble shooting.
[0]PETSC ERROR: See docs/index.html for manual pages.
[0]PETSC ERROR: ------------------------------------------------------------------------
[0]PETSC ERROR: Unknown Name on a linux-gnu named mnemosyne by rcwelsh Thu Jul  7 14:56:12 2016
[0]PETSC ERROR: Libraries linked from /autofs/space/lyon_006/pubsw/Linux2-2.3-x86_64/packages/petsc/2.3.3-p13/src/petsc-2.3.3-p13/lib/linux-gnu-c-opt
[0]PETSC ERROR: Configure run at Tue Aug 10 15:01:59 2010
[0]PETSC ERROR: Configure options --with-debugging=no --with-cc=gcc --with-fc=g77 --download-f-blas-lapack=0 --download-mpich=1 --with-mpi=1 --with-x=0 --with-gnu-copyright-code=0 --with-shared=0 COPTFLAGS=-O3 CXXOPTFLAGS=-O3 FOPTFLAGS=-O3
[0]PETSC ERROR: ------------------------------------------------------------------------
[0]PETSC ERROR: User provided function() line 0 in unknown directory unknown file
[unset]: aborting job:
application called MPI_Abort(MPI_COMM_WORLD, 59) - process 0
X Error: GLXBadContextTag 164
  Extension:    150 (Uknown extension)
  Minor opcode: 1 (Unknown request)
  Resource id:  0x960005
Comment 1 Jeremy Huddleston Sequoia 2016-07-07 19:52:58 UTC

*** This bug has been marked as a duplicate of bug 96260 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.