Bug 96985 - test-tpl-log-walker.c: function name 'rewind' conflicts with stdio.h
Summary: test-tpl-log-walker.c: function name 'rewind' conflicts with stdio.h
Status: RESOLVED DUPLICATE of bug 97034
Alias: None
Product: Telepathy
Classification: Unclassified
Component: logger (show other bugs)
Version: git master
Hardware: Other All
: high major
Assignee: Telepathy bugs list
QA Contact: Telepathy bugs list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-19 04:22 UTC by Ting-Wei Lan
Modified: 2016-07-22 14:04 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Description Ting-Wei Lan 2016-07-19 04:22:39 UTC

    
Comment 1 Ting-Wei Lan 2016-07-19 04:25:12 UTC
GCC error messages:

test-tpl-log-walker.c:172:1: error: conflicting types for ‘rewind’
 rewind (WalkerTestCaseFixture *fixture,
 ^~~~~~
In file included from glib-2.0/glib/gmessages.h:33:0,
                 from glib-2.0/glib.h:62,
                 from glib-2.0/gobject/gbinding.h:28,
                 from glib-2.0/glib-object.h:23,
                 from ../../tests/lib/simple-account.h:14,
                 from test-tpl-log-walker.c:5:
/usr/include/stdio.h:759:13: note: previous declaration of ‘rewind’ was here
 extern void rewind (FILE *__stream);
             ^~~~~~
Makefile:809: recipe for target 'test-tpl-log-walker.o' failed


Clang error messages:

test-tpl-log-walker.c:172:1: error: static declaration of 'rewind' follows non-static declaration
rewind (WalkerTestCaseFixture *fixture,
^
/usr/include/stdio.h:266:7: note: previous declaration is here
void     rewind(FILE *);
         ^
test-tpl-log-walker.c:353:20: error: too many arguments to function call, expected 1, have 3
  rewind (fixture, walker, 8);
  ~~~~~~           ^~~~~~~~~
/usr/include/stdio.h:266:1: note: 'rewind' declared here
void     rewind(FILE *);
^
test-tpl-log-walker.c:355:20: error: too many arguments to function call, expected 1, have 3
  rewind (fixture, walker, 8);
  ~~~~~~           ^~~~~~~~~
/usr/include/stdio.h:266:1: note: 'rewind' declared here
void     rewind(FILE *);
fatal error: too many errors emitted, stopping now [-ferror-limit=]
20 errors generated.
Comment 2 George Kiagiadakis 2016-07-20 06:22:50 UTC
Incredible...
Comment 3 George Kiagiadakis 2016-07-22 04:37:21 UTC
*** Bug 97034 has been marked as a duplicate of this bug. ***
Comment 4 Debarshi Ray 2016-07-22 14:04:26 UTC

*** This bug has been marked as a duplicate of bug 97034 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.