Bug 98407 - GLXCreateNewContext error in XQuartz2.7.10 for Mac OS Sierra
Summary: GLXCreateNewContext error in XQuartz2.7.10 for Mac OS Sierra
Status: RESOLVED DUPLICATE of bug 96260
Alias: None
Product: XQuartz
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: unspecified
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Jeremy Huddleston Sequoia
QA Contact: Jeremy Huddleston Sequoia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-24 10:31 UTC by Lluís Blancafort
Modified: 2016-10-24 16:32 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lluís Blancafort 2016-10-24 10:31:07 UTC
I am running latest XQuartz2.7.10 (downloaded Oct 24th 2016) on new OS Sierra, and I have a problem launching a quantum-chemistry gui call grid viewer. I run the program remotely and export it to my mac. I get the error log shown below in my remote server.

The program was working fine with previous OS ElCapitan and XQuartz2.7.9. Simpler things like xclock do work with my new setup.

Thanks!

X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  149 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  28
  Current serial number in output stream:  29
Comment 1 Jeremy Huddleston Sequoia 2016-10-24 16:32:39 UTC
2.7.9 certainly did not work (unless you modified it).

I suspect you were using 2.7.8 before the upgrade.

You need to run this for your use case:

    defaults write org.macosforge.xquartz.X11 enable_iglx -bool true

*** This bug has been marked as a duplicate of bug 96260 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.