Bug 99423 - [skl] Using Libreoffice Writer causes GPU Hang
Summary: [skl] Using Libreoffice Writer causes GPU Hang
Status: NEW
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 12.0
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL: https://bugs.launchpad.net/ubuntu/+so...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-15 18:43 UTC by W. the Pooh
Modified: 2018-03-21 22:00 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
DMESG out regarding GPU Hang (732 bytes, text/plain)
2017-01-15 18:43 UTC, W. the Pooh
Details
GPU crash dump (272.37 KB, text/plain)
2017-01-15 18:43 UTC, W. the Pooh
Details
Xorg log (39.43 KB, text/x-log)
2017-01-17 20:31 UTC, W. the Pooh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description W. the Pooh 2017-01-15 18:43:10 UTC
Created attachment 128972 [details]
DMESG out regarding GPU Hang

For the last couple of months I've been experiencing issues when using LibreOffice Writer on my Dell Precision 7510 running Ubuntu 16.10, while using the Intel HD Graphics 530 IGP for the graphics.

When using LibreOffice Writer, e.g. while typing text the whole desktop-interface (including LibreOffice) will hang / freeze for about 5 seconds, after that everything will return to normal, those hangs will occur about every 5 minutes or so and only occur when using LibreOffice Writer.

The DMESG output indicates a GPU hang:
[drm] GPU HANG: ecode 9:0:0x86dffffd, in Xorg [1472], reason: Hang on render ring, action: reset

Now I've already submitted a bug to bugs.launchpad.org:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1635996
but was referred to here since this apparently is an upstream issue. 

I'm attaching the DMESG-ouput regarding the GPU-hang and the GPU crash dump

This is my first time reporting an issue here @ bugs.freedesktop.org, so if there's info missing or if I'm doing stuff wrong, please do let me know. 

P.S.:
I've read about Bug 99325 but I am unsure if this is the exact same issue, so I've decided to open a separate Bug.
Comment 1 W. the Pooh 2017-01-15 18:43:54 UTC
Created attachment 128973 [details]
GPU crash dump
Comment 2 Mark Janes 2017-01-17 19:58:01 UTC
Please attach xorg log.
Comment 3 W. the Pooh 2017-01-17 20:31:54 UTC
Created attachment 129009 [details]
Xorg log
Comment 4 Christopher M. Penalver 2017-02-13 02:11:35 UTC
Mesa version 12.0.3 as per:
https://launchpad.net/ubuntu/+source/mesa

Assigned back to intel-3d-bugs@lists.freedesktop.org as original reporter provided requested xorg log and has not indicated they will be releasing a patch towards this.
Comment 5 Elizabeth 2018-03-21 22:00:45 UTC
Hello, libreoffice issue should be fixed in 17.3.6: https://bugs.freedesktop.org/show_bug.cgi?id=99720#c33.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.