Bug 99656 - strange planets on star conflict and game crashes if textures set to high
Summary: strange planets on star conflict and game crashes if textures set to high
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: high normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 77449
  Show dependency treegraph
 
Reported: 2017-02-02 19:38 UTC by david becerra
Modified: 2019-09-25 19:00 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
the strange planet (924.02 KB, image/png)
2017-02-02 19:38 UTC, david becerra
Details
another place where it happens (953.53 KB, image/png)
2017-02-02 19:41 UTC, david becerra
Details

Note You need to log in before you can comment on or make changes to this bug.
Description david becerra 2017-02-02 19:38:45 UTC
Created attachment 129302 [details]
the strange planet

those are actually two bugs 
1 some planets are like half empty
2 if you set textures to high the game crashes in the next map load(sometimes instantly)
Comment 1 david becerra 2017-02-02 19:39:53 UTC
the texture on high crash doesnt happen on radeonsi on a r7 260
Comment 2 david becerra 2017-02-02 19:41:44 UTC
Created attachment 129303 [details]
another place where it happens
Comment 3 david becerra 2017-02-03 08:05:44 UTC
forgot to say im on hd 5500
Comment 4 Kenneth Graunke 2017-02-07 04:25:30 UTC
Can you create an apitrace of the game showing the issue?
Comment 5 david becerra 2017-02-07 08:35:24 UTC
(In reply to Kenneth Graunke from comment #4)
> Can you create an apitrace of the game showing the issue?

sorry but i dont know what is an apitrace
can you explain how to do it or a link to a page where it explains it?
Comment 6 Kenneth Graunke 2017-02-08 17:01:14 UTC
Apitrace - http://apitrace.github.io/ - should be available in your distro's package manager (apt install, dnf install, pacman -S, etc).  If you run the game from the command line, just run "apitrace ./game"  and it should start recording "game.trace" (which can be pretty huge).

If you run the game via Steam, right click on it in your library, hit properties, then [Set Launch Options], and change it to:

apitrace trace -o ~/game.trace %command%
Comment 7 Kenneth Graunke 2017-02-08 17:02:01 UTC
Once you have that, xz -T 0 game.trace to compress it, and attach it here, or upload it somewhere and link it.  Thanks!
Comment 8 david becerra 2017-02-08 18:00:38 UTC
thanks for the explanation 
but i cant run apitrace because, if i start the game with it steam gives this error:
/home/david/.local/share/Steam/ubuntu12_32/steam: symbol lookup error: /usr/lib32/libxcb-dri3.so.0: undefined symbol: xcb_send_request_with_fds
and worse, steam resets and i have to put my account again :(

note that the game has issues with native libs and i have to run it with STEAM_RUNTIME_PREFER_HOST_LIBRARIES=0 otherwise it wont boot
Comment 9 david becerra 2017-02-08 18:06:02 UTC
also the textures on high sometimes work but with very long loading times and like it was going to crash.
it feels like it was trying to use all the resources because sounds are played like they would do if the map loaded altough only for a little time.
also switching to tty and back to desktop again closes the game (no need to killing it)
Comment 10 Kenneth Graunke 2017-02-10 05:30:41 UTC
I was able to run it via the command line:

cd ~/.local/share/Steam/*team*pps/common/star\ conflict
LD_PRELOAD=/usr/lib32/libcurl.so.4.3.0 ./StarConflict

You can probably do:

LD_PRELOAD=/usr/lib32/libcurl.so.4.3.0 apitrace trace ./StarConflict

I played through the tutorial and the planet looked okay.  Just to double check, are you running the latest Mesa?
Comment 11 david becerra 2017-02-10 08:42:13 UTC
yes, daily updated mesa-git
thanks for trying it :)
Comment 12 david becerra 2017-02-10 20:17:52 UTC
wow thanks Kenneth now i can run star conflict with a steam parameter which means i dont have to unload steam if i did have it opened before.
i got the trace of star conflict and you werent joking about it being large,
it is 1,6 GIGABYTES!!
FYI the trace is about the textures on high crash.
do you still want me to upload it?
Comment 13 Kenneth Graunke 2017-02-12 03:19:29 UTC
Does it crash if you replay the trace with "glretrace StarConflict.trace"?  If so, sure.  Also, do try to compress it with "xz -T 0 StarConflict.trace"...
Comment 14 david becerra 2017-02-12 09:25:28 UTC
yes it crashes with glretrace which is a cool tool
the link: https://mega.nz/#F!E1hSWIhK!1fafzhslvNsTGNFg7CR4Pw
Comment 15 david becerra 2017-02-24 14:58:58 UTC
found something?
Comment 16 david becerra 2017-03-05 16:39:19 UTC
i tested the game on windows
and the textures on high is an OOM problem
the planet looks good on windows
Comment 17 oleksandr.nikitin 2018-04-06 10:08:44 UTC
Bugs are still reproducible with 18.1.0 MESA. 
Information on the configuration of a computer: 
- Ubuntu Linux Version 16.04 64-bit
- 4.13.0-38-generic
- Intel® HD Graphics 620 (Kaby Lake GT2)
- Intel® Core™ i7-7500U CPU @ 2.70GHz × 4 
With gdb and built with --enable-debug mesa, crash with high textures happens without mesa's libraries.
Bug with half empty planets also exists with NVIDIA GK107 [GeForce GT 640] https://forum.star-conflict.com/index.php?/topic/36157-graphic-bugs-with-nvidia-384-binary-driver/
So a crash - is a bug of the game. Bad textures of planets is common problem with NVIDIA proprietary driver.
Comment 18 GitLab Migration User 2019-09-25 19:00:22 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1570.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.