Bug 99762 - "Black Mesa" not launching
Summary: "Black Mesa" not launching
Status: RESOLVED NOTOURBUG
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: 13.0
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 77449
  Show dependency treegraph
 
Reported: 2017-02-10 13:18 UTC by Bronson
Modified: 2017-07-02 10:31 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bronson 2017-02-10 13:18:47 UTC
I see not command line output, so can only assume a recent driver update has caused this game to stop running.

Using mesa 13.0.3 on a radeon 6970 under kde neon.

Running the game from steam gives no error in the console, and does nothing. I had it working fine previously with an older version.
Comment 1 Samuel Pitoiset 2017-02-10 13:47:27 UTC
At first look, I thought "Black Mesa" was a joke but it's not. Funny name! :-)

According to https://steamcommunity.com/app/362890/discussions/0/312265327168384714/, the Linux version seems to have various issues. I will let you know when I can test myself.

Thanks for reporting.
Comment 2 Samuel Pitoiset 2017-02-13 10:22:06 UTC
"Black Mesa" is working here, both with mesa 13.0.4 and mesa-git. Tested on RX480.
Comment 3 Bronson 2017-02-13 23:04:50 UTC
ok i found a linux script to launch the game under linux in the folder.
This is the error log i get from the command line:

libGL error: unable to load driver: r600_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: r600
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  94
  Current serial number in output stream:  95
Comment 4 Gregor Münch 2017-07-02 10:31:50 UTC
This is a game bug caused by old / incompatible lib files.
I had exact the same issue and solved it by adding this to the game launch options:
LD_PRELOAD='./libcxxrt.so:/usr/$LIB/libstdc++.so.6' %command%


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.