Bug 99916 - Rotating display gives garbage with Radeon RX 480
Summary: Rotating display gives garbage with Radeon RX 480
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/AMDgpu (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 99978 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-02-22 22:15 UTC by Hadrien Nilsson
Modified: 2017-03-03 19:22 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
actual result (155.70 KB, image/jpeg)
2017-02-22 22:15 UTC, Hadrien Nilsson
no flags Details
xorg log from ~/.local/share/xorg/Xorg.0.log (51.71 KB, text/plain)
2017-02-23 20:52 UTC, Hadrien Nilsson
no flags Details
dmesg output (188.15 KB, text/plain)
2017-02-23 20:52 UTC, Hadrien Nilsson
no flags Details
xrandr output (967 bytes, text/plain)
2017-02-23 20:52 UTC, Hadrien Nilsson
no flags Details
Preliminary fix (1.59 KB, patch)
2017-02-24 10:15 UTC, Michel Dänzer
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Hadrien Nilsson 2017-02-22 22:15:36 UTC
Created attachment 129850 [details]
actual result

I am on Ubuntu 16.10 x64 (kernel 4.8.0-38-generic). I have a Radeon RX 480 and I use the Padoka PPA to get latest Mesa drivers.

Currently I have this for the xserver video driver:
xserver-xorg-video-radeon/yakkety,now 1:7.8.99+git1702101817.1351e48~y~padoka0 amd64

The exact commit hash is: 1351e48efe7a2c28eab447e16f36a00fbd02ae48

Steps to reproduce:
  * go the the display settings in the Ubuntu settings dialog
  * select a rotation flavor (left, right, 180)
  * apply the selection

Expected result: the display is rotated as specified
Actual result: the display looks corrupted (see attached picture)
Comment 1 Michel Dänzer 2017-02-23 08:26:38 UTC
Please attach the Xorg log file and the output of dmesg and xrandr, preferably captured after reproducing the problem.
Comment 2 Hadrien Nilsson 2017-02-23 20:52:16 UTC
Created attachment 129885 [details]
xorg log from ~/.local/share/xorg/Xorg.0.log
Comment 3 Hadrien Nilsson 2017-02-23 20:52:35 UTC
Created attachment 129886 [details]
dmesg output
Comment 4 Hadrien Nilsson 2017-02-23 20:52:59 UTC
Created attachment 129887 [details]
xrandr output
Comment 5 Michel Dänzer 2017-02-24 10:15:19 UTC
Created attachment 129893 [details] [review]
Preliminary fix

This patch fixes it for me.
Comment 6 Michel Dänzer 2017-02-27 08:24:48 UTC
*** Bug 99978 has been marked as a duplicate of this bug. ***
Comment 7 Michel Dänzer 2017-03-03 09:09:34 UTC
Thanks for the report, fixed in Git master:

commit 03c2db3c67bf5ad3c0744add9e0bb611b6cd3df7
Author: Michel Dänzer <michel.daenzer@amd.com>
Date:   Thu Mar 2 16:42:04 2017 +0900

    Call drmmode_crtc_scanout_create in drmmode_crtc_shadow_allocate as well
Comment 8 Hadrien Nilsson 2017-03-03 19:22:34 UTC
Nice! Thank you for your responsiveness. I'm looking forward to test the fix.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.