Bug 99978 - rotation causes undefined behavior after updating mesa (radeon, x11, kernel 4.10)
Summary: rotation causes undefined behavior after updating mesa (radeon, x11, kernel 4...
Status: RESOLVED DUPLICATE of bug 99916
Alias: None
Product: Mesa
Classification: Unclassified
Component: Other (show other bugs)
Version: git
Hardware: Other All
: medium major
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-27 05:17 UTC by xaxazak
Modified: 2017-02-27 08:24 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description xaxazak 2017-02-27 05:17:20 UTC
Rotating one of my monitors makes it garbled and/or logs me out (causing endless login loop).

Mesa 17.1 (padoka PPA).
Linux Kernel 4.10.
Xubuntu 16.10. (XFCE).
Radeon RX 480.

2 monitors:
A) Dell U2410 (1920x1080) via HDMI.
B) QNIX QX2710LED (2560x1440) via DVI.

Disabling #B doesn't help.

Not sure if this is a Mesa bug, but it's my best guess.
Note, this doesn't occur when using Unity, so it might be specific to X11?

I wonder if the unusual combo of HDMI + DVI might also be important - I did find one related thread somewhere (lost it, sorry) mentioning they fixed rotation issues by using different ports (Unfortunately, the QNIX only has DVI).

This has been bugging me for a while, but I always rotated the monitor before upgrading kernel/mesa etc so I didn't click that it was rotation until today.

Unfortunately I can't get a screenshot as it's too unstable. If it displays anything before logging out it looks like strips of actual rotated desktop plus strips of unintelligible data.
Comment 1 Michel Dänzer 2017-02-27 08:24:48 UTC

*** This bug has been marked as a duplicate of bug 99916 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.