Bug 9992 - [CH7315] SDVO TV out not supported
[CH7315] SDVO TV out not supported
Status: RESOLVED DUPLICATE of bug 17776
Product: xorg
Classification: Unclassified
Component: Driver/intel
unspecified
x86 (IA32) All
: medium enhancement
Assigned To: Wang Zhenyu
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-15 13:42 UTC by Artur Flinta
Modified: 2009-02-15 19:51 UTC (History)
2 users (show)

See Also:


Attachments
Xorg log file runnig without config (97.02 KB, text/plain)
2007-02-15 13:44 UTC, Artur Flinta
no flags Details
Xorg log file runnig with xorg.conf attached below (93.62 KB, text/plain)
2007-02-15 13:45 UTC, Artur Flinta
no flags Details
xorg.conf file which is working with i810 1.7.4 driver, but not with modesetting (1.77 KB, text/plain)
2007-02-15 13:45 UTC, Artur Flinta
no flags Details
Logfile from terminal switch failure session (119.23 KB, text/plain)
2007-03-27 13:22 UTC, Artur Flinta
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Artur Flinta 2007-02-15 13:42:56 UTC
Hi!
I'm using latest stable release of xorg + git version of i810 driver from modesetting branch (from 13th February 2007). I can't get working video with it, I've tried without xorg.conf file as well as with xorg.file which is working great with i810 v 1.7.4. In all cases when using modesetting branch I end up with not supported video mode form LCD monitor. 
I'm using:
[aflinta@warp ~]$ sudo dmidecode |grep 965
        Version: MQ96510J.86A.1618.2007.0117.1535
        Product Name: DG965WH
my monitor is LCD Samsung 173s

Below attached Xorg logs runnig without and with xorg.conf and xorg.conf file.
Comment 1 Artur Flinta 2007-02-15 13:44:21 UTC
Created attachment 8743 [details]
Xorg log file runnig without config
Comment 2 Artur Flinta 2007-02-15 13:45:03 UTC
Created attachment 8744 [details]
Xorg log file runnig with xorg.conf attached below
Comment 3 Artur Flinta 2007-02-15 13:45:53 UTC
Created attachment 8745 [details]
xorg.conf file which is working with i810 1.7.4 driver, but not with modesetting
Comment 4 Eric Anholt 2007-02-26 12:20:56 UTC
This appears to be due to a failure to DDC.  Need to try fixing the I2C issues I noticed in the X Server a while ago and see if that helps.
Comment 5 Daniel Stone 2007-02-27 01:36:25 UTC
Sorry about the phenomenal bug spam, guys.  Adding xorg-team@ to the QA contact so bugs don't get lost in future.
Comment 6 Eric Anholt 2007-02-28 09:49:04 UTC
On re-review, it's not DDC (or at least, not just DDC).  Could you describe what video output connectors are available on your machine, and which you have monitors connected to?
Comment 7 Artur Flinta 2007-02-28 10:23:47 UTC
Sure, I have Intel DG965WH motherboard with ADD2 card (prolink  PV-CH7315 (N16TDS)-F http://www.prolink-usa.com/item_disp.php?upc=2006886907073 ).
I have only Samsung 173s connected to VGA output on motherboard, I've tried also to connect TV via S-Video cable, but has no impact on logs or display behavior at all. I'm not using HDMI output.
Comment 8 Artur Flinta 2007-03-27 13:21:21 UTC
Using latest intel driver 1.9.93 (RC3) I've made some testing and here are the results:

a) DDC isn't working (no matter if I have ADD2 card or not). Maybe it should be in separate bug? Does it exist or should I create the new one?

b) If ADD2 card is not present in the system I can switch between text terminals and graphics several times without any problems). But if I put ADD2 card into computer (without connecting anything to it), X starts without problems and I have video on VGA output, but switching to text mode causes that monitor goes into suspend mode, switching back to graphics causes X server segfaults (and monitor is still blank). The only thing I can do is switch back to text console and type (as blind men) "reboot" with hope that it will work ;)
Log from this session is in attachment.
Comment 9 Artur Flinta 2007-03-27 13:22:23 UTC
Created attachment 9321 [details]
Logfile from terminal switch failure session
Comment 10 Artur Flinta 2007-04-03 13:07:07 UTC
Tested with 1.9.94 (2.0 RC4) with the same results as in previous versions :(
Comment 11 Eric Anholt 2007-04-03 15:42:40 UTC
TV-out SDVO cards are not supported currently, and will likely cause all sorts of problems.  See the mailing list archives for information on some development being done to support SDVO TV-out, which hasn't been merged in yet.
Comment 12 Jesse Barnes 2007-10-31 13:20:52 UTC
Updating the description.
Comment 13 Michael Fu 2008-01-29 23:54:25 UTC
The DDC issue is a dup of bug# 10694. If I can still get a response from you and this is still a pain for you, please reopen bug# 10694...
Comment 14 Eric Anholt 2008-04-02 16:26:18 UTC
Added some code to master for SDVO TV-out, but it doesn't work on my hardware yet.  The BIOS doesn't light up my card, so I'm working blind trying to figure out how to program it right.  If someone has SDVO TV output working from the console, it would be interesting to see the /var/log/Xorg.0.log, particularly with i830_sdvo_dump_regs() added to the init path.

Comment 15 Wang Zhenyu 2008-07-28 18:05:39 UTC
Artur, have you tried with current git master or 2.4.0 release?
Comment 16 Matteo Croce 2008-10-27 17:59:01 UTC
Eric: I have SDVO TV out, and I can see the console and BIOS splash on the TV.
What do you need to know?
Comment 17 Matteo Croce 2008-10-28 04:12:11 UTC
I've tried with 2.5.0, no luck
Comment 18 Matteo Croce 2008-11-11 17:55:04 UTC
can anyone try with latest GIT?
Comment 19 Wang Zhenyu 2008-12-07 22:25:15 UTC
This needs to be tested against recent drivers and with ModeDebug log.
Comment 20 Wang Zhenyu 2009-02-11 23:35:06 UTC
Can you test my patch on Bug #17776?
Comment 21 Wang Zhenyu 2009-02-15 19:51:16 UTC

*** This bug has been marked as a duplicate of bug 17776 ***