Bug 105682 - [CI] igt@kms_frontbuffer_tracking@* - fail - FBC disabled: no suitable CRTC for FBC
Summary: [CI] igt@kms_frontbuffer_tracking@* - fail - FBC disabled: no suitable CRTC f...
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
: 100020 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-03-22 07:33 UTC by Marta Löfstedt
Modified: 2019-04-11 06:43 UTC (History)
2 users (show)

See Also:
i915 platform: BDW, CFL, ICL, KBL, SKL
i915 features: display/FBC


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marta Löfstedt 2018-03-22 07:33:47 UTC
(kms_frontbuffer_tracking:1891) WARNING: fbc_is_enabled()?
FBC disabled: no suitable CRTC for FBC
(kms_frontbuffer_tracking:1891) CRITICAL: Test assertion failure function do_status_assertions, file ../tests/kms_frontbuffer_tracking.c:1748:
(kms_frontbuffer_tracking:1891) CRITICAL: Failed assertion: fbc_is_enabled(IGT_LOG_WARN)
(kms_frontbuffer_tracking:1891) CRITICAL: FBC disabled
Subtest fbc-1p-primscrn-spr-indfb-draw-render failed.

Some examples:
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_5/fi-bdw-gvtdvm/igt@kms_frontbuffer_tracking@fbc-1p-primscrn-spr-indfb-draw-render.html
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_5/fi-bdw-gvtdvm/igt@kms_frontbuffer_tracking@fbc-1p-primscrn-spr-indfb-draw-pwrite.html
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_5/fi-bdw-gvtdvm/igt@kms_frontbuffer_tracking@fbc-1p-rte.html
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_5/fi-bdw-gvtdvm/igt@kms_frontbuffer_tracking@fbc-1p-primscrn-cur-indfb-draw-blt.html
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_5/fi-bdw-gvtdvm/igt@kms_frontbuffer_tracking@fbc-1p-primscrn-cur-indfb-move.html

please see cibuglog and/or https://intel-gfx-ci.01.org/tree/drm-tip/drmtip.html for full overview of the impact
Comment 1 Martin Peres 2018-07-18 08:24:46 UTC
The vast majority of the failures are on the fi-bdw-gvtdvm machine, so I will consider it a gvt-d issue.
Comment 2 Lakshmi 2018-08-31 12:41:49 UTC
*** Bug 100020 has been marked as a duplicate of this bug. ***
Comment 3 Martin Peres 2019-04-11 06:42:42 UTC
This bug is actually a duplicate of many other bugs:

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5901/shard-skl6/igt@kms_frontbuffer_tracking@fbcpsr-1p-primscrn-spr-indfb-draw-mmap-cpu.html

Starting subtest: fbcpsr-1p-primscrn-spr-indfb-draw-mmap-cpu
(kms_frontbuffer_tracking:2194) WARNING: fbc_is_enabled()?
FBC disabled: no suitable CRTC for FBC
(kms_frontbuffer_tracking:2194) CRITICAL: Test assertion failure function do_status_assertions, file ../tests/kms_frontbuffer_tracking.c:1598:
(kms_frontbuffer_tracking:2194) CRITICAL: Failed assertion: fbc_is_enabled(IGT_LOG_WARN)
(kms_frontbuffer_tracking:2194) CRITICAL: FBC disabled

--> https://bugs.freedesktop.org/show_bug.cgi?id=108040


https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5901/shard-skl6/igt@kms_frontbuffer_tracking@fbc-rgb101010-draw-mmap-cpu.html
	
Starting subtest: fbc-rgb101010-draw-mmap-cpu
(kms_frontbuffer_tracking:2126) igt_debugfs-CRITICAL: Test assertion failure function igt_assert_crc_equal, file ../lib/igt_debugfs.c:419:
(kms_frontbuffer_tracking:2126) igt_debugfs-CRITICAL: Failed assertion: !mismatch

--> https://bugs.freedesktop.org/show_bug.cgi?id=110379


https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5748/shard-skl10/igt@kms_fbcon_fbt@fbc-suspend.html

Starting subtest: fbc-suspend
(kms_fbcon_fbt:1162) CRITICAL: Test assertion failure function subtest, file ../tests/kms_fbcon_fbt.c:258:
(kms_fbcon_fbt:1162) CRITICAL: Failed assertion: feature->wait_until_enabled(drm.debugfs_fd)
Subtest fbc-suspend failed.

--> https://bugs.freedesktop.org/show_bug.cgi?id=103833


https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4935/shard-iclb8/igt@kms_frontbuffer_tracking@fbcpsr-1p-rte.html
	
Starting subtest: fbcpsr-1p-rte
(kms_frontbuffer_tracking:5778) CRITICAL: Test assertion failure function do_status_assertions, file ../tests/kms_frontbuffer_tracking.c:1609:
(kms_frontbuffer_tracking:5778) CRITICAL: Failed assertion: psr_wait_entry(drm.debugfs, PSR_MODE_1)
(kms_frontbuffer_tracking:5778) CRITICAL: PSR still disabled

--> https://bugs.freedesktop.org/show_bug.cgi?id=109247


https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4926/shard-iclb2/igt@kms_frontbuffer_tracking@fbc-1p-rte.html
	
Starting subtest: fbc-1p-rte
(kms_frontbuffer_tracking:4308) igt_debugfs-CRITICAL: Test assertion failure function igt_assert_crc_equal, file ../lib/igt_debugfs.c:419:
(kms_frontbuffer_tracking:4308) igt_debugfs-CRITICAL: Failed assertion: !mismatch

--> https://bugs.freedesktop.org/show_bug.cgi?id=110378


And after that, only one failure was caught, 9 months ago:

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4454/shard-hsw5/igt@kms_frontbuffer_tracking@fbc-2p-primscrn-pri-shrfb-draw-mmap-cpu.html

(kms_frontbuffer_tracking:2306) igt_debugfs-CRITICAL: Test assertion failure function igt_assert_crc_equal, file ../lib/igt_debugfs.c:370:
(kms_frontbuffer_tracking:2306) igt_debugfs-CRITICAL: Failed assertion: !mismatch
Subtest fbc-2p-primscrn-pri-shrfb-draw-mmap-cpu failed.

Thus, we can close this bug altogether! Wasn't painful at all :D
Comment 4 CI Bug Log 2019-04-11 06:43:05 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.