Bug 16225 - [i915 64bit] Illegal instruction when draw prims
[i915 64bit] Illegal instruction when draw prims
Status: RESOLVED DUPLICATE of bug 8724
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915
git
x86-64 (AMD64) Linux (All)
: medium normal
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-03 22:47 UTC by WuNian
Modified: 2009-08-24 12:30 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description WuNian 2008-06-03 22:47:31 UTC
When I run test case of bug #16192 (attachment #16863 [details]) on 64bit 915G, it reports illegal instruction.

The backtrace info is:

Program received signal SIGILL, Illegal instruction.
[Switching to Thread 47859610702768 (LWP 9066)]
_mesa_x86_64_transform_points4_3d () at x86-64/xform4.S:135
135             prefetch 16(%rdx)
Current language:  auto; currently asm
(gdb) bt
#0  _mesa_x86_64_transform_points4_3d () at x86-64/xform4.S:135
#1  0x00002b872f4938a1 in run_texmat_stage (ctx=0x613010, 
    stage=<value optimized out>) at tnl/t_vb_texmat.c:72
#2  0x00002b872f48a33b in _tnl_run_pipeline (ctx=0x613010)
    at tnl/t_pipeline.c:158
#3  0x00002b872f3ea400 in intelRunPipeline (ctx=0x613010) at intel_tris.c:906
#4  0x00002b872f48a864 in _tnl_draw_prims (ctx=0x613010, arrays=0x650de0, 
    prim=0x64f5c4, nr_prims=1, ib=0x0, min_index=<value optimized out>, 
    max_index=3) at tnl/t_draw.c:402
#5  0x00002b872f482a2e in vbo_exec_vtx_flush (exec=0x64f380)
    at vbo/vbo_exec_draw.c:215
#6  0x00002b872f47e54d in vbo_exec_FlushVertices (ctx=<value optimized out>, 
    flags=6552992) at vbo/vbo_exec_api.c:700
#7  0x00002b872f51c25e in _mesa_ReadPixels (x=4, y=4, width=68, height=68, 
    format=6407, type=5126, pixels=0x8fd720) at main/drawpix.c:294
#8  0x0000000000401109 in Test () at api-texcoord_16192.c:121
#9  0x0000000000401343 in test () at api-texcoord_16192.c:154
#10 0x00000000004013c1 in display () at api-texcoord_16192.c:168
#11 0x00002b872cde2bb7 in processWindowWorkList (window=0x6080f0)
    at glut_event.c:1306
#12 0x00002b872cde3826 in glutMainLoop () at glut_event.c:1353
#13 0x000000000040142a in main (argc=1, argv=0x7fff7e180c78)
    at api-texcoord_16192.c:182
Comment 1 haihao 2008-06-03 23:03:15 UTC

*** This bug has been marked as a duplicate of bug 8724 ***
Comment 2 ajax at nwnk dot net 2009-08-24 12:30:19 UTC
Mass version move, cvs -> git