Bug 20820 - [i965 UXA]incorrect rendering when run mesa xdemos/manywin
[i965 UXA]incorrect rendering when run mesa xdemos/manywin
Status: CLOSED DUPLICATE of bug 18262
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
unspecified
Other Linux (All)
: low normal
Assigned To: Eric Anholt
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 01:54 UTC by liuhaien
Modified: 2015-05-14 02:23 UTC (History)
0 users

See Also:


Attachments
xorg.0.log (74.32 KB, text/plain)
2009-03-24 01:54 UTC, liuhaien
Details
xorg conf file (3.91 KB, text/plain)
2009-03-24 01:55 UTC, liuhaien
Details
screenshot1 (916.05 KB, image/png)
2009-03-24 01:56 UTC, liuhaien
Details
screenshot2 using software (916.90 KB, image/png)
2009-03-24 01:56 UTC, liuhaien
Details

Note You need to log in before you can comment on or make changes to this bug.
Description liuhaien 2009-03-24 01:54:53 UTC
Created attachment 24178 [details]
xorg.0.log

System Environment:
--------------------------

Platform:       gm965
Arch:           x86_64
OSD:            Fedora release 10
Libdrm:         (master)2e2e8575b1ed4703653a72ac2b60b75316c388d7
Mesa_stable:            (mesa_7_4_branch)a8528a2e8653b5237c1d1d66fe98c6e031d007f9
Xserver:(server-1.6-branch) 60c161545af80eb78eb790a05bde79409dfdf16e
Xf86_video_intel:                (2.7)238c2c40afd9f8b61479b8640d53f20d52fd7ddf
Kernel:       (for-airlied)dc529a4fe1ae4667c819437a94185e8581e1e680	

Bug detailed description:
--------------------------
With UXA, start X,then run manywin n(n>1), just the first window render correctly. all windows should have the same color and brightness,but the other windows appears different,as is shown in the attached screenshot1, and screenshot2 is the correct rendering with software.

Reproduce steps:
----------------
1. xinit&
2.run mesa/xdemos ./manywin 10
Comment 1 liuhaien 2009-03-24 01:55:09 UTC
Created attachment 24179 [details]
xorg conf file
Comment 2 liuhaien 2009-03-24 01:56:01 UTC
Created attachment 24180 [details]
screenshot1
Comment 3 liuhaien 2009-03-24 01:56:37 UTC
Created attachment 24181 [details]
screenshot2 using software
Comment 4 Gordon Jin 2009-03-24 17:55:46 UTC
Is it different than bug#20052? So it's i965 v.s. i915?
Comment 5 liuhaien 2009-03-24 20:36:51 UTC
(In reply to comment #4)
> Is it different than bug#20052? So it's i965 v.s. i915?
> 

yes, they are differen.20052 for i915 and this bug for i965.
Comment 6 Eric Anholt 2009-08-03 11:11:50 UTC

*** This bug has been marked as a duplicate of bug 18262 ***