Bug 269 - [TRACKER] Pick up un-merged driver fixes from xfree86 bugzilla
Summary: [TRACKER] Pick up un-merged driver fixes from xfree86 bugzilla
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: * Other (show other bugs)
Version: unspecified
Hardware: x86 (IA32) All
: high normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on: 2 96 309 310 311 312 313 314 316 317 318 320 321 322 323 325 326 327 328 329 330 331 332 333 334 798 963 1003 1030 1124 1149 1154 1155 1161 1184 1196 1220 1221 1227 1229 1232
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-04 07:17 UTC by Alex Deucher
Modified: 2011-10-15 15:47 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Deucher 2004-03-04 07:17:40 UTC
There are quite a few small fixes (even a new driver drop) for some of the
drivers (including some I've written) floating around on xfree86 bugzilla.  For
the most part they aren't critical for this upcoming release.  I just putting
this bug here as a place holder.  I'll gather the patches and post them here for
review and integration at some point unless someone has a better plan.
Comment 1 Egbert Eich 2004-03-04 12:07:03 UTC
Alex, could you please add links to the entires in the XFree86 bugzilla?
That would make it easier to do this. If you wnat to you can also do this
yourself. If you are not sure please ask someone to take a quick look.
Comment 2 Alex Deucher 2004-03-04 12:20:30 UTC
that's what I was planning to do.
Comment 3 Alex Deucher 2004-03-04 13:23:47 UTC
possible patches - none of these are critical as far as I know.  I also make no
claim that all these patchs are 100% correct.

HW cursor probs in I810
http://bugs.xfree86.org/show_bug.cgi?id=2

radeon Power management support
http://bugs.xfree86.org/show_bug.cgi?id=96

PCIDATA creates false video cards
http://bugs.xfree86.org/show_bug.cgi?id=604

Fix for LCDs on PPC laptops with radeon M10
http://bugs.xfree86.org/show_bug.cgi?id=798

New Driver: SMI 501
http://bugs.xfree86.org/show_bug.cgi?id=1001

Keyboard LEDs and VT switches
http://bugs.xfree86.org/show_bug.cgi?id=963

Driver for linux joysticks
http://bugs.xfree86.org/show_bug.cgi?id=1003

multimedia keyboard print key needs it's own symbol
http://bugs.xfree86.org/show_bug.cgi?id=1027

xman cannot display SGML man pages on Solaris
http://bugs.xfree86.org/show_bug.cgi?id=1030

Additional features for TWM
http://bugs.xfree86.org/show_bug.cgi?id=1124

Better memory allocation for dualhead radeons
http://bugs.xfree86.org/show_bug.cgi?id=1149

xev should handle WM_DELETE_WINDOW
http://bugs.xfree86.org/show_bug.cgi?id=1154

Keymapping for MS natural USB keyboard
http://bugs.xfree86.org/show_bug.cgi?id=1155

Older neomagic chips also support XV
http://bugs.xfree86.org/show_bug.cgi?id=1161

New feature, single button double-click
http://bugs.xfree86.org/show_bug.cgi?id=1184

Middle button mouse scrolling (Mathias Fröhlich)
http://www.mail-archive.com/devel@xfree86.org/msg03333.html

turn off backlight for nv driver on Dell D800
http://bugs.xfree86.org/show_bug.cgi?id=1196

incorrect memory region in M2B macro
http://bugs.xfree86.org/show_bug.cgi?id=1220

Enhanced symbols file for new keyboard
http://bugs.xfree86.org/show_bug.cgi?id=1227

missing bus to host address translations for PPC/Linux
http://bugs.xfree86.org/show_bug.cgi?id=1229

DRM_CAS in xf86drm.h generates lots of warnings
http://bugs.xfree86.org/show_bug.cgi?id=1232

turn off DAC with dpms for radeons
http://bugs.xfree86.org/show_bug.cgi?id=1221

Gamma correction for radeon Xv (Alex Deucher)
http://www.botchco.com/alex/radeon/Xv/xv_gamma/radeon_video_gamma.diff

Alpha blending support for radeon Xv (Alex Deucher)
http://www.botchco.com/alex/radeon/Xv/xv_alpha/radeon_xvalpha.diff

IBM 526 DAC support for s3 driver (John Hay)
http://marc.theaimsgroup.com/?l=xfree86-devel&m=107843043004076&w=2

Comment 4 Mike A. Harris 2004-03-05 15:27:58 UTC
It might be useful to use this bug report as a master tracker for each of the
issues included above, and file individual reports for each issue, so they
can be closed one at a time once they're reviewed and/or fixed.  That would
also take a bit of time, so I can understand if someone would be too busy
to do so right away however.

Adding myself to CC list, to monitor.  If I investigate any of the issues
myself, I'll file a new report for each and mark it as blocking this one.

Thanks for reporting these Alex!
Comment 5 Alex Deucher 2004-03-08 10:31:18 UTC
new one:

Add interlaced support to S3 driver
http://bugs.xfree86.org/show_bug.cgi?id=1254
Comment 6 Egbert Eich 2004-03-11 10:24:41 UTC
Some of these may be interesting for the RELEASE. 
Comment 7 Alex Deucher 2004-03-11 15:55:32 UTC
FWIW,  there are also quite a few new features in the DRI tree that could be
merged in at some point.  off the top of my head:

- mergedfb support for radeon
- dri-interface changes
- configuration infrastructure
- new 3d features
- fbconfig support
Comment 8 Mike A. Harris 2004-03-11 18:15:08 UTC
The problem with having 40 bug reports all in one bug report, is that you
can't fix "just one issue" and then close the bug "FIXED", because there
are 39 other problems still open.  That makes it difficult to impossible
for anyone reading the report to know which of the 40 bugs reported all in
one report have been fixed and are closed, or are still open.  Even if
one updated the comments one at a time as they were investigated, you
end up with a very very long single bug report and have to manually parse
the whole report to figure out which bugs are fixed/open/etc.  There is no
per-issue tracking.

I think many of the issues look interesting for consideration once the
first release is out the door, but no new features should be added IMHO
unless it is very very small, and very obvious that there is no regression
risk.

I've changed the summary to add the word [Tracker], so that when individual
bug reports get filed later on for the above, they can block this tracker.
Individual reports can be considered to block bug 213 also.

Hope this helps.
Comment 9 Alex Deucher 2004-03-11 22:05:21 UTC
If I have time next week I'll break this into separate bugs.  My only hesitation
was that most of these are already xfree86 bug reports so I feel like it's just
duplicating work, but I guess we are dealing with separate trees...
Comment 10 Bugzilla Maintainer 2004-03-12 09:01:56 UTC
Alex,

Please break these up into separate bugs, so we can can track them and
keep track of which go into the first release branch, and which go into the
current branch.
Comment 11 Egbert Eich 2004-03-16 05:20:55 UTC
OK, I've separated them. Please don't add any more to this bug. Create seperate
ones and let them block this one.
Comment 12 Mike A. Harris 2005-04-27 19:07:34 UTC
Is this tracker still relevant?  IMHO, the bugs blocking this should be removed
and this closed, or alternatively the bugs blocking this should be added to
the official 7.0 release tracker/blocker bug.
Comment 13 Erik Andren 2006-06-28 11:56:26 UTC
Ping on answer to mharris's request
Comment 14 Daniel Stone 2007-02-27 01:23:16 UTC
Sorry about the phenomenal bug spam, guys.  Adding xorg-team@ to the QA contact so bugs don't get lost in future.
Comment 15 Adam Jackson 2008-07-11 13:39:30 UTC
Closing.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.