Bug 28224 - [Arrandale bisected] black screen in dell e6510, e6410
[Arrandale bisected] black screen in dell e6510, e6410
Status: RESOLVED DUPLICATE of bug 28070
Product: DRI
Classification: Unclassified
Component: DRM/Intel
unspecified
x86-64 (AMD64) Linux (All)
: high normal
Assigned To: Wang Zhenyu
:
: 28481 28539 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-24 01:14 UTC by josch
Modified: 2010-06-30 16:00 UTC (History)
3 users (show)

See Also:


Attachments
intel_gpu_dump (80.40 KB, application/octet-stream)
2010-05-24 01:17 UTC, josch
no flags Details
dmesg (58.16 KB, text/plain)
2010-05-24 01:18 UTC, josch
no flags Details
vbios (64.00 KB, application/octet-stream)
2010-05-24 01:19 UTC, josch
no flags Details
intel_gpu_dump.gz 2.6.34 plain (non-working) (80.50 KB, application/octet-stream)
2010-05-26 06:12 UTC, josch
no flags Details
intel_gpu_dump.gz 2.6.34 patched (working) (80.40 KB, application/octet-stream)
2010-05-26 06:14 UTC, josch
no flags Details
patch fixing the issue on 2.6.33-2.6.34 (revert of earlier commit) (1.59 KB, patch)
2010-05-26 06:15 UTC, josch
no flags Details | Splinter Review
intel_reg_dumper output non-working (8.78 KB, text/plain)
2010-05-29 01:51 UTC, josch
no flags Details
intel_reg_dumper output working (8.78 KB, text/plain)
2010-05-29 01:51 UTC, josch
no flags Details
possible edp link clock overflow patch (655 bytes, patch)
2010-06-16 20:24 UTC, Wang Zhenyu
no flags Details | Splinter Review
(resend) edp link clock overflow patch (553 bytes, patch)
2010-06-17 01:51 UTC, Wang Zhenyu
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description josch 2010-05-24 01:14:30 UTC
hi!

on newer kernels, whenever i modprobe i915 my screen goes black. the
backlight is still on and the machine continues working but now as a
headless system.

by bisection i found the commit that introduced this regression:

885a5fb5b120a5c7e0b3baad7b0feb5a89f76c18 is the first bad commit
commit 885a5fb5b120a5c7e0b3baad7b0feb5a89f76c18
Author: Zhenyu Wang <zhenyuw@linux.intel.com>
Date:   Tue Jan 12 05:38:31 2010 +0800

    drm/i915: fix pixel color depth setting on eDP

    Original DP mode_valid check didn't take pixel color depth into account,
    which made one 1600x900 eDP panel's mode check invalid because of
overclock,
    but actually this 6bpc panel does can work with x1 lane at 2.7G.
This one
    trys to take bpp value properly both in mode validation and mode
setting.

    Signed-off-by: Zhenyu Wang <zhenyuw@linux.intel.com>
    Signed-off-by: Eric Anholt <eric@anholt.net>

:040000 040000 3c99ae05b82db5b8e453d2062bcf56743794476b
d7e0aa843fe4f8173f624572c77a7fe93b6fc455 M      drivers


this issue appears on my dell e6510 with intel hd (arrandale) and one
can find many bugreports about the same effect on the e6410 and thinkpad
x200s - all using said platform:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/554569
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/561802

i also can confirm, that when removing the changes from this commit in
the most recent intel_dp.c then my display even works on 2.6.34  :)

as pointed out by zhenyu wang it might be related to bug#28070

cheers
josch
Comment 1 josch 2010-05-24 01:17:22 UTC
Created attachment 35810 [details]
intel_gpu_dump

the normal gpu dump was too big so i gzipped it
Comment 2 josch 2010-05-24 01:18:30 UTC
Created attachment 35811 [details]
dmesg
Comment 3 josch 2010-05-24 01:19:54 UTC
Created attachment 35812 [details]
vbios
Comment 4 josch 2010-05-24 13:58:28 UTC
removed x201s from the title as that bug was solved by another fix and had only the same effect as this one
Comment 5 josch 2010-05-25 05:36:33 UTC
it seems to be unralated to bug#28070 since applying the patch from comment 21 in that bugreport did not change the reported behavior
Comment 6 Wang Zhenyu 2010-05-26 01:32:49 UTC
Could you attach intel_reg_dump output in case of a) original failure; b) with my patch reverted to fix your issue?
Comment 7 josch 2010-05-26 06:12:16 UTC
Created attachment 35867 [details]
intel_gpu_dump.gz 2.6.34 plain (non-working)
Comment 8 josch 2010-05-26 06:14:01 UTC
Created attachment 35868 [details]
intel_gpu_dump.gz 2.6.34 patched (working)
Comment 9 josch 2010-05-26 06:15:25 UTC
Created attachment 35869 [details] [review]
patch fixing the issue on 2.6.33-2.6.34 (revert of earlier commit)
Comment 10 josch 2010-05-26 06:18:35 UTC
i compiled 2.6.34

a) original failure - output found in comment#7

then i applied patch from comment#9 which partly reverts the changes of the breaking commit, rebuilt the kernel and obtained:

b) your patch reverted - output found in comment#8

a) does not work, b) does work
Comment 11 Wang Zhenyu 2010-05-27 00:47:56 UTC
josch, what I'd like to check is 'intel_reg_dumper' output, not 'intel_gpu_dump'.
Comment 12 josch 2010-05-29 01:51:13 UTC
Created attachment 35926 [details]
intel_reg_dumper output non-working
Comment 13 josch 2010-05-29 01:51:59 UTC
Created attachment 35927 [details]
intel_reg_dumper output working
Comment 14 josch 2010-05-29 01:53:55 UTC
whoops, sorry... turned out i had a very old version of the intel_gpu_tools which did not contain the intel_reg_dumper yet - got the git version and attached the output for

a) with stock 2.6.34 in comment#12 (non-working)

b) with patch reverted in comment#13 (working)
Comment 15 josch 2010-06-04 09:20:43 UTC
do you need any more info than the intel_reg_dumper outputs i attached a week ago?
cheers
Comment 16 Gordon Jin 2010-06-10 19:32:31 UTC
*** Bug 28481 has been marked as a duplicate of this bug. ***
Comment 17 Carlos Diego Russo Medeiros 2010-06-13 16:46:35 UTC
(In reply to comment #9)
> Created an attachment (id=35869) [details]
> patch fixing the issue on 2.6.33-2.6.34 (revert of earlier commit)

This regression patch also worked for me, Vanilla Kernel 2.6.34 + Regression Patch + Fedora 13 on e6410 with A03 Bios.

Thanks!
Comment 18 Gordon Jin 2010-06-14 20:36:51 UTC
*** Bug 28539 has been marked as a duplicate of this bug. ***
Comment 19 Wang Zhenyu 2010-06-16 20:24:23 UTC
Created attachment 36324 [details] [review]
possible edp link clock overflow patch

Could you try if this patch has any effect? Please use vanilla kernel without any reverts or workarounds.

thanks.
Comment 20 josch 2010-06-17 01:30:32 UTC
to what kernel version is this patch supposed to apply - i can't find any that this patch matches to :(
Comment 21 Wang Zhenyu 2010-06-17 01:51:49 UTC
Created attachment 36325 [details] [review]
(resend) edp link clock overflow patch

oops, mixed with another not commited patch. Please try this one against linus tree.
Comment 22 josch 2010-06-17 02:39:37 UTC
this patch didnt change anything here - even the intel_reg_dumper output is the same as posted above for the non-working case.
the screen still goes black ones the module is loaded
Comment 23 BenG 2010-06-24 11:05:56 UTC
I have the same problem on my E6410. I have unsuccessfully tried the following kernels on a 64 bit install of ubuntu 10.04:

2.6.32.21    (stock ubuntu 10.04 kernel)
2.6.32.22    (updated ubuntu 10.04 kernel)
2.6.34-rc3    (Unbuntu mainline builds:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.34-rc5-lucid/)
2.6.35-rc1    (Ubuntu mainline builds:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.35-rc1-lucid)
2.6.34-drm-intel-next    (Intel's DRM branch from ubuntu mainline builds: http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-next/2010-06-02-lucid )

All of these exhibited the same black screen failure.

Finally, I've settled on Linus' vanilla mainline 2.6.35 kernel to test the patches attached to this bug. So far, none have worked. I get to the point of the boot where i915 goes into KMS mode, and the machine goes black if booting on the internal flat-panel. I am never able to ssh in, and the boot does not complete.
If I switch the display at the BIOS to an external VGA display, it will boot to X.
Comment 24 Dave Airlie 2010-06-24 23:47:51 UTC
http://lists.freedesktop.org/archives/intel-gfx/2010-June/007216.html

please try this patch.
Comment 25 Tobias 2010-06-25 13:06:00 UTC
(In reply to comment #24)
> http://lists.freedesktop.org/archives/intel-gfx/2010-June/007216.html
> 
> please try this patch.

Works for me :) thanks
Comment 26 josch 2010-06-26 12:31:49 UTC
yes, this fixes the issue i reported, thank you!

although i read that this patch breaks other panels :/
Comment 28 Sérgio M. Basto 2010-06-28 14:15:59 UTC
Hi , check bug #28224
Comment 29 Sérgio M. Basto 2010-06-28 14:25:40 UTC
(In reply to comment #28)
> Hi , check bug #28224

Sorry forget this message I just want CC me . 

bug #28224, #28739, #28746 and #28070 seems very similar, 
and like "Paulo J. S. Silva", my problem is after resuming from suspend to RAM.
Comment 30 Sérgio M. Basto 2010-06-30 16:00:49 UTC
Could I mark this as duplicated of bug #28070 ?

*** This bug has been marked as a duplicate of bug 28070 ***