Bug 4276 - blacks menus whith gtk 2.8.0->2 : pixmap must have a colormap
Summary: blacks menus whith gtk 2.8.0->2 : pixmap must have a colormap
Status: RESOLVED FIXED
Alias: None
Product: GTK-Qt Engine
Classification: Unclassified
Component: GTK-Qt (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: highest critical
Assignee: David Sansome
QA Contact:
URL: http://www.slyunix.org/galerie/displa...
Whiteboard:
Keywords:
: 4571 5405 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-08-28 04:56 UTC by Sebastien ROHAUT
Modified: 2006-02-02 18:53 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Capture screen of gftp on KDE 3.4.2 and gtk-qt-engine 0.6cvs (96.38 KB, image/png)
2005-08-28 04:58 UTC, Sebastien ROHAUT
Details
gtk-qt-engine-0.6-alt-menubg-colormap.patch (475 bytes, patch)
2005-09-30 15:26 UTC, Dmitry Vukolov
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastien ROHAUT 2005-08-28 04:56:39 UTC
Starting with GTK 2.8.0 (tried 2.8.1 and 2.8.2 too) menus appears to be black in
gtk apps (like gftp or amule for example).

Opening a menu results in many messages:

Gdk-WARNING **: gdk_window_set_back_pixmap(): pixmap must have a colormap

I tried to recompile lestest CVS, same problem.
Comment 1 Sebastien ROHAUT 2005-08-28 04:58:57 UTC
Created attachment 3073 [details]
Capture screen of gftp on KDE 3.4.2 and gtk-qt-engine 0.6cvs

You can see full of warning in background
Comment 2 Sebastien ROHAUT 2005-08-28 13:00:08 UTC
Ok, made new tests with:
gtk 2.8.2
glib 2.8.1
pango 1.10.0
cairo : 1.0.0

all compiled from scratch

Now the message I have is :
gftp-gtk:30042): Gdk-WARNING **: Using Cairo rendering requires the drawable
argument to
have a specified colormap. All windows have a colormap,
however, pixmaps only have colormap by default if they
were created with a non-NULL window argument. Otherwise
a colormap must be set on them with gdk_drawable_set_colormap

and of course menus entries are scratched. I put Severity on Critical because
it's not possible to work with gtk-qt-engine. As example, gtk apps make
segfaults when using with cairo 0.9.x ...
Comment 3 Krzysiek Juzaszek 2005-09-08 14:03:03 UTC
gtk 2.8.3
glib 2.8.1
pango 1.10.0
cairo : 1.0.0

I have the same problem.
Comment 4 Joanna Kopeæ 2005-09-11 09:22:42 UTC
Black menus and:

Gdk-WARNING **: gdk_window_set_back_pixmap(): pixmap must have a colormap

with gtk 2.8.x
Comment 5 Dmitry Vukolov 2005-09-30 15:26:00 UTC
Created attachment 3446 [details] [review]
gtk-qt-engine-0.6-alt-menubg-colormap.patch

courtesy of Alexey Morozov (morozov at altlinux dot org)
Comment 6 Robert Huitl 2006-01-25 09:13:51 UTC
Dmitry Vukolov's patch works fine for me. 
Comment 7 Robert Huitl 2006-01-25 09:16:11 UTC
works for me, but someone should apply the patch if it is ok :) 
Comment 8 Robert Huitl 2006-01-25 09:17:04 UTC
*** Bug 5405 has been marked as a duplicate of this bug. ***
Comment 9 Robert Huitl 2006-01-25 09:17:30 UTC
*** Bug 4571 has been marked as a duplicate of this bug. ***
Comment 10 David Sansome 2006-02-03 13:53:58 UTC
Thanks, this should now be fixed in CVS.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.