Bug 83423 - [gen4] GPU HANG: ecode 0:0x9f47f9fd, in chrome [1294], reason: Ring hung
Summary: [gen4] GPU HANG: ecode 0:0x9f47f9fd, in chrome [1294], reason: Ring hung
Status: RESOLVED DUPLICATE of bug 80568
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 83935 84160 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-09-03 07:19 UTC by Hanno Böck
Modified: 2014-11-16 08:09 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg output after GPU hang (72.81 KB, text/plain)
2014-09-03 07:19 UTC, Hanno Böck
Details
drm error from /sys/class/drm/card0/error (596.00 KB, text/plain)
2014-09-03 07:20 UTC, Hanno Böck
Details
output of /sys/class/drm/card0/error from chrome crash on Macbook (851.86 KB, text/plain)
2014-09-21 05:44 UTC, Steven Ellis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hanno Böck 2014-09-03 07:19:54 UTC
Created attachment 105658 [details]
dmesg output after GPU hang

Sometimes on youtube HTML5 videos my screen freezes and then turns black. The system is still active, I can e.g. reboot it blind by switching to console and pressing ctrl-alt-del.

This is what dmesg shows:

[  293.705130] [drm] GPU HANG: ecode 0:0x9f47f9fd, in chrome [1294], reason: Ring hung, action: reset
[  293.705132] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[  293.705134] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[  293.705135] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[  293.705137] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[  293.705139] [drm] GPU crash dump saved to /sys/class/drm/card0/error

I'll attach full dmesg and GPU crash dump.

Further maybe useful info to track down:
System: Thinkpad T61
GPU: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)
Distribution: Gentoo Linux
Kernel: 3.15.6
Mesa: 10.2.6
xf86-video-intel: 2.99.914
xorg-server: 1.16.0
Comment 1 Hanno Böck 2014-09-03 07:20:27 UTC
Created attachment 105659 [details]
drm error from /sys/class/drm/card0/error
Comment 2 Steven Ellis 2014-09-21 05:43:26 UTC
I've got the same issue occurring under Fedora 20 on a Macbook with intel graphics.

Sep 21 17:31:42 macdora kernel: [drm] stuck on render ring
Sep 21 17:31:42 macdora kernel: [drm] GPU HANG: ecode 0:0x9f47f9fd, in chrome [3036], reason: Ring hung, action: reset
Sep 21 17:31:42 macdora kernel: [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
Sep 21 17:31:42 macdora kernel: [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
Sep 21 17:31:42 macdora kernel: [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
Sep 21 17:31:42 macdora kernel: [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
Sep 21 17:31:42 macdora kernel: [drm] GPU crash dump saved to /sys/class/drm/card0/error
Sep 21 17:31:43 macdora kernel: [drm:i915_reset] *ERROR* Failed to reset chip: -110
Sep 21 17:31:47 macdora kernel: Watchdog[3043]: segfault at 0 ip 00007f59e58239de sp 00007f59cd944670 error 6 in chrome[7f59e16cd000+547d000]
Sep 21 17:31:52 macdora kernel: [drm:i915_gem_wait_for_error] *ERROR* Timed out waiting for the gpu reset to complete
Sep 21 17:31:52 macdora kernel: [drm] GMBUS [i915 gmbus vga] timed out, falling back to bit banging on pin 2
Sep 21 17:31:52 macdora kernel: ------------[ cut here ]------------
Sep 21 17:31:52 macdora kernel: WARNING: CPU: 1 PID: 1833 at drivers/gpu/drm/i915/intel_display.c:931 assert_pll+0x68/0x70 [i915]()
Sep 21 17:31:52 macdora kernel: PLL state assertion failure (expected on, current off)
Sep 21 17:31:52 macdora kernel: Modules linked in: tcp_lp fuse ipt_MASQUERADE iptable_nat nf_nat_ipv4 nf_nat xt_CHECKSUM iptable_mangle tun bridge stp llc ebtable_nat ebtables ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter xt_physdev ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack wl(POE) cfg80211 snd_hda_codec_realtek snd_hda_codec_generic snd_hda_intel snd_hda_controller snd_hda_codec snd_hwdep snd_seq snd_seq_device iTCO_wdt iTCO_vendor_support joydev snd_pcm appletouch hid_appleir coretemp applesmc input_polldev snd_timer microcode i2c_i801 rfkill sky2 snd shpchp lpc_ich mfd_core sbs acpi_cpufreq sbshc soundcore apple_bl binfmt_misc nfsd auth_rpcgss nfs_acl lockd sunrpc firewire_ohci i915 firewire_core i2c_algo_bit crc_itu_t drm_kms_helper ata_generic pata_acpi drm i2c_core video
Sep 21 17:31:52 macdora kernel: 
Sep 21 17:31:52 macdora kernel: CPU: 1 PID: 1833 Comm: upowerd Tainted: P        W  OE 3.15.10-201.fc20.x86_64 #1
Sep 21 17:31:52 macdora kernel: Hardware name: Apple Inc. MacBook4,1/Mac-F22788A9, BIOS     MB41.88Z.00C1.B00.0802091535 02/09/08
Sep 21 17:31:52 macdora kernel:  0000000000000000 0000000072dd7e7a ffff8801373ff9a8 ffffffff816ef848
Sep 21 17:31:52 macdora kernel:  ffff8801373ff9f0 ffff8801373ff9e0 ffffffff8108927d 0000000000000001
Sep 21 17:31:52 macdora kernel:  000000000000a800 ffff8800b7ceb000 ffff880037db5000 0000000000000001
Sep 21 17:31:52 macdora kernel: Call Trace:
Sep 21 17:31:52 macdora kernel:  [<ffffffff816ef848>] dump_stack+0x45/0x56
Sep 21 17:31:52 macdora kernel:  [<ffffffff8108927d>] warn_slowpath_common+0x7d/0xa0
Sep 21 17:31:52 macdora kernel:  [<ffffffff810892fc>] warn_slowpath_fmt+0x5c/0x80
Sep 21 17:31:52 macdora kernel:  [<ffffffffa00da55b>] ? gen4_read32+0x4b/0xc0 [i915]
Sep 21 17:31:52 macdora kernel:  [<ffffffffa00e8008>] assert_pll+0x68/0x70 [i915]
Sep 21 17:31:52 macdora kernel:  [<ffffffffa00ed931>] intel_crtc_load_lut+0x1c1/0x1e0 [i915]
Sep 21 17:31:52 macdora kernel:  [<ffffffffa00edb66>] i9xx_crtc_enable+0x216/0x420 [i915]
Sep 21 17:31:52 macdora kernel:  [<ffffffffa00f0947>] __intel_set_mode+0x827/0x1640 [i915]
Sep 21 17:31:52 macdora kernel:  [<ffffffffa00f3e16>] intel_set_mode+0x16/0x30 [i915]
Sep 21 17:31:52 macdora kernel:  [<ffffffffa00f404c>] intel_get_load_detect_pipe+0x21c/0x4c0 [i915]
Sep 21 17:31:52 macdora kernel:  [<ffffffffa011d4fd>] intel_tv_detect+0x10d/0x560 [i915]
Sep 21 17:31:52 macdora kernel:  [<ffffffff811f6666>] ? path_openat+0x176/0x670
Sep 21 17:31:52 macdora kernel:  [<ffffffffa002fd5e>] status_show+0x3e/0x80 [drm]
Sep 21 17:31:52 macdora kernel:  [<ffffffff8145a050>] dev_attr_show+0x20/0x60
Sep 21 17:31:52 macdora kernel:  [<ffffffff816f53c2>] ? mutex_lock+0x12/0x2f
Sep 21 17:31:52 macdora kernel:  [<ffffffff81262fcc>] sysfs_kf_seq_show+0xcc/0x1e0
Sep 21 17:31:52 macdora kernel:  [<ffffffff81261963>] kernfs_seq_show+0x23/0x30
Sep 21 17:31:52 macdora kernel:  [<ffffffff8120a4fa>] seq_read+0x16a/0x3b0
Sep 21 17:31:52 macdora kernel:  [<ffffffff812621b5>] kernfs_fop_read+0xf5/0x160
Sep 21 17:31:52 macdora kernel:  [<ffffffff811e65bb>] vfs_read+0x9b/0x160
Sep 21 17:31:52 macdora kernel:  [<ffffffff811e7225>] SyS_read+0x55/0xd0
Sep 21 17:31:52 macdora kernel:  [<ffffffff816ff969>] system_call_fastpath+0x16/0x1b
Sep 21 17:31:52 macdora kernel: ---[ end trace de7443cb8fe1173c ]---
Sep 21 17:31:52 macdora kernel: ------------[ cut here ]------------
Sep 21 17:31:52 macdora kernel: WARNING: CPU: 1 PID: 1833 at drivers/gpu/drm/i915/intel_display.c:931 assert_pll+0x68/0x70 [i915]()
Sep 21 17:31:52 macdora kernel: PLL state assertion failure (expected on, current off)
Sep 21 17:31:52 macdora kernel: Modules linked in: tcp_lp fuse ipt_MASQUERADE iptable_nat nf_nat_ipv4 nf_nat xt_CHECKSUM iptable_mangle tun bridge stp llc ebtable_nat ebtables ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter xt_physdev ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack wl(POE) cfg80211 snd_hda_codec_realtek snd_hda_codec_generic snd_hda_intel snd_hda_controller snd_hda_codec snd_hwdep snd_seq snd_seq_device iTCO_wdt iTCO_vendor_support joydev snd_pcm appletouch hid_appleir coretemp applesmc input_polldev snd_timer microcode i2c_i801 rfkill sky2 snd shpchp lpc_ich mfd_core sbs acpi_cpufreq sbshc soundcore apple_bl binfmt_misc nfsd auth_rpcgss nfs_acl lockd sunrpc firewire_ohci i915 firewire_core i2c_algo_bit crc_itu_t drm_kms_helper ata_generic pata_acpi drm i2c_core video
Comment 3 Steven Ellis 2014-09-21 05:44:30 UTC
Created attachment 106597 [details]
output of /sys/class/drm/card0/error from chrome crash on Macbook
Comment 4 Rodrigo Vivi 2014-09-23 01:49:12 UTC
*** Bug 84160 has been marked as a duplicate of this bug. ***
Comment 5 Rodrigo Vivi 2014-09-23 01:49:25 UTC
*** Bug 83935 has been marked as a duplicate of this bug. ***
Comment 6 Rodrigo Vivi 2014-09-23 01:54:20 UTC
Can you please reproduce with latest drm-intel-nightly branch?

What happens when you boot your kernel with i915.enable_rc6=0?
Comment 7 Andy Tanner-Smith 2014-10-13 17:40:07 UTC
Hi This affects me also. 

I can reproduce the issue 100% of the time by opening up the Chrome Webstore (https://chrome.google.com/webstore)

I could not get a screen dump as my machine became unresponsive after the hang. I copied down the main line pertaining to the problem after I entered tty (please note -this may not be complete - I did not get the line numbers)

[###.#####] [drm] GPU HANG: ecode 0:0x9f47f9fd, in chrome [1294], reason: Ring hung, action: reset
[###.#####] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[###.#####] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[###.#####] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[###.#####] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[###.#####] [drm] GPU crash dump saved to /sys/class/drm/card0/error

The file: /sys/class/drm/card0/error was empty when I rebooted and looked for it.


Some other information
Subsystem: Lenovo ThinkPad T61/R61
        Flags: bus master, fast devsel, latency 0
        Capabilities: <access denied>
        Kernel driver in use: agpgart-intel

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c) (prog-if 00 [VGA controller])
        Subsystem: Lenovo ThinkPad T61/R61
        Flags: bus master, fast devsel, latency 0, IRQ 32
        Memory at f8100000 (64-bit, non-prefetchable) [size=1M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 1800 [size=8]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: <access denied>
        Kernel driver in use: i915

00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 0c)
        Subsystem: Lenovo ThinkPad T61/R61
        Flags: bus master, fast devsel, latency 0
        Memory at f8200000 (64-bit, non-prefetchable) [size=1M]
        Capabilities: <access denied>

00:03.0 Communication controller: Intel Corporation Mobile PM965/GM965 MEI Controller (rev 0c)
        Subsystem: Lenovo Device 20d1
        Flags: bus master, fast devsel, latency 0, IRQ 31
        Memory at fe226800 (64-bit, non-prefetchable) [size=16]
        Capabilities: <access denied>
        Kernel driver in use: mei_me

00:03.2 IDE interface: Intel Corporation Mobile PM965/GM965 PT IDER Controller (rev 0c) (prog-if 85 [Master SecO PriO])
        Subsystem: Lenovo Device 20d3
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 18
        I/O ports at 1828 [size=8]
        I/O ports at 180c [size=4]
        I/O ports at 1820 [size=8]
        I/O ports at 1808 [size=4]
        I/O ports at 1810 [size=16]
        Capabilities: <access denied>
        Kernel driver in use: ata_generic

00:03.3 Serial controller: Intel Corporation Mobile PM965/GM965 KT Controller (rev 0c) (prog-if 02 [16550])
        Subsystem: Lenovo Device 20d4
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 17
        I/O ports at 1830 [size=8]
        Memory at fe024000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: <access denied>
        Kernel driver in use: serial

OS
Ubuntu 14:04
Linux 3.17 Kernel
Drivers
  *-display:0             
       description: VGA compatible controller
       product: Mobile GM965/GL960 Integrated Graphics Controller (primary)
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 0c
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:32 memory:f8100000-f81fffff memory:e0000000-efffffff ioport:1800(size=8)
  *-display:1 UNCLAIMED
       description: Display controller
       product: Mobile GM965/GL960 Integrated Graphics Controller (secondary)
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 0c
       width: 64 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=0
       resources: memory:f8200000-f82fffff
Comment 8 Matt Turner 2014-11-16 08:09:45 UTC

*** This bug has been marked as a duplicate of bug 80568 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.