Bug 88700 - Portal 2 FPS goes below 5 in several places
Summary: Portal 2 FPS goes below 5 in several places
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 104457 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-01-22 11:10 UTC by Md Imam Hossain
Modified: 2018-05-02 15:28 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
/sys/class/drm/card0/error (2.23 MB, text/plain)
2015-03-05 11:07 UTC, Samuel Iglesias Gonsálvez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Md Imam Hossain 2015-01-22 11:10:09 UTC
While playing Portal 2 the FPS range is 40~12 depending on the scene and graphics details in the settings but the game mostly playable. However, in several areas throughout different levels the FPS goes below 5 and even becomes 1~2 making it really hard to keep moving forward with the game. These problematic places do not look very different from the rest of the non problematic places. My guess is, there must be some sort of software fallback in these areas. I have found similar problem with the game Trine released by Humble Bundle but it may be different issue.

System:

Kubuntu 14.10
Linux kernel 3.16.0-29-generic
Mesa 10.5.0-devel (git-7a182d2) using oibaf ppa

https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers

X.Org X Server 1.16.0

Intel Bay Trail, device id: 0f31
Comment 1 Md Imam Hossain 2015-01-25 20:40:40 UTC
I have found similar problem in the games Trine and Legend of Grimrock from Humble Bundle where games slow down increadably to the point of completely unplayable decreasing FPS below 5 FPS. If I restart the games then the games becomes normal again. It happens after 5-15 minutes of gameplay. Please, fix this bug I guess many games are affected by this bug on Intel Bay Trail.
Comment 2 Md Imam Hossain 2015-01-26 13:33:05 UTC
Okay, I have tested Portal 2 with other desktop environment such as LXDE, the problem seems like related to bloated KDE desktop and it's composited desktop environment. Under LXDE desktop I have not encountered any FPS issues. I will test with other games and see if the problem occurs with LXDE desktop.
Comment 3 Kenneth Graunke 2015-01-26 18:30:48 UTC
Interesting.  I doubt that the problem is the compositor being "bloated", but we're probably doing something wrong with compositing.
Comment 4 Md Imam Hossain 2015-02-06 00:03:49 UTC
Same problem with Bit.Trip Presents Runner2: Future Legend of Rhythm Alien, this time I went further with the problematic situation, so what I have found is like this, I used LXDE desktop to run Bit.Trip Presents Runner2 and the game runs normally but after a while around 10-15~ minutes of gameplay the game slows down increadibly lowering fps >5 then if I keep playing for 1-2~ the game come back to normal. Similar situation with Civilization: Beyond Earth.

System configuration:

Intel(R) Celeron(R) CPU  N2840  @ 2.16GHz
Intel Bay Trail, device id: 0f31

Kubuntu 14.10
Linux kernel 3.16.0-30-generic and 3.18.5-031805-lowlatency
Mesa 10.5.0-devel (git-6094619 2015-01-31 utopic-oibaf-ppa)

https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers

X.Org X Server 1.16.0
Comment 5 Samuel Iglesias Gonsálvez 2015-03-04 14:15:45 UTC
I wonder if the FPS decrement could be because of GPU hangs. I had one GPU hang while trying to reproduce this problem on my SNB laptop, but I don't know if it's related to this bug or to bug 89279 (my Chromium instance froze because it lost its GL context due to the GPU hang).

Can you attach 'dmesg' command output after this problem has occurred?
Comment 6 Md Imam Hossain 2015-03-04 23:52:22 UTC
Yes, I got gpu hang several times on Intel Bay Trail when playing for a while as well as doing desktop recording where I had to force shutdown computer by pressing power button because once I get gpu hang everything becomes non responsive.
Comment 7 Samuel Iglesias Gonsálvez 2015-03-05 11:07:49 UTC
Created attachment 114024 [details]
/sys/class/drm/card0/error

OK, then I reproduced it successfully on my SNB laptop. In my case, GPU hang happens after five minutes of "Portal 2" gameplay (executed through Steam).

I attach /sys/class/drm/card0/error file.

System info:

glxinfo:

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile 
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.6.0-devel (git-073a5d2)
OpenGL core profile shading language version string: 3.30

$ uname -a
Linux fourier 3.14-2-amd64 #1 SMP Debian 3.14.15-2 (2014-08-09) x86_64 GNU/Linux

/var/log/messages output. Google Chrome was also running. Because of the GPU hang, Chrome lost its GL context and its CPU consumption went to 100%. I would say that this is duplicate of bug 89279 but I am not sure as bug 89279 report doesn't explain what Steam was doing.

[...]
Mar  4 13:59:58 fourier kernel: [22628.700115] [drm] stuck on render ring
Mar  4 13:59:58 fourier kernel: [22628.700119] [drm] stuck on blitter ring
Mar  4 13:59:58 fourier kernel: [22628.700120] [drm] GPU crash dump saved to /sys/class/drm/card0/error
Mar  4 13:59:58 fourier kernel: [22628.700121] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
Mar  4 13:59:58 fourier kernel: [22628.700122] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
Mar  4 13:59:58 fourier kernel: [22628.700122] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
Mar  4 13:59:58 fourier kernel: [22628.700123] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
Mar  4 13:59:58 fourier google-chrome.desktop[7447]: [7524:7524:0304/125958:ERROR:gles2_cmd_decoder.cc(10030)] Onscreen context lost via ARB/EXT_robustness. Reset status = GL_INNOCENT_CONTEXT_RESET_KHR
Mar  4 13:59:58 fourier google-chrome.desktop[7447]: [7524:7524:0304/125958:ERROR:gles2_cmd_decoder.cc(3200)]   GLES2DecoderImpl: Context lost during MakeCurrent.
Mar  4 13:59:58 fourier google-chrome.desktop[7447]: [7524:7524:0304/125958:ERROR:gles2_cmd_decoder.cc(3200)]   GLES2DecoderImpl: Context lost during MakeCurrent.
Mar  4 13:59:58 fourier google-chrome.desktop[7447]: [7524:7524:0304/125958:ERROR:gles2_cmd_decoder.cc(3200)]   GLES2DecoderImpl: Context lost during MakeCurrent.
Mar  4 13:59:58 fourier google-chrome.desktop[7447]: [7524:7524:0304/125958:ERROR:gles2_cmd_decoder.cc(3200)]   GLES2DecoderImpl: Context lost during MakeCurrent.
Mar  4 13:59:58 fourier google-chrome.desktop[7447]: [7524:7524:0304/125958:ERROR:gles2_cmd_decoder.cc(10030)] Onscreen context lost via ARB/EXT_robustness. Reset status = GL_INNOCENT_CONTEXT_RESET_KHR
Mar  4 13:59:58 fourier google-chrome.desktop[7447]: [7524:7524:0304/125958:ERROR:gles2_cmd_decoder.cc(3200)]   GLES2DecoderImpl: Context lost during MakeCurrent.
[...]
Comment 8 oleksandr.nikitin 2018-04-26 12:48:44 UTC
The new bug was found. After launching a game click "Robot Enrichment" button. Gpu hang would happen. 
Information on the configuration of a computer: 
- Ubuntu Linux Version 16.04 64-bit
- 4.13.0-38-generic
- Intel® HD Graphics 620 (Kaby Lake GT2)
- Intel® Core™ i7-7500U CPU @ 2.70GHz × 4 
Bugs exist with mesa 17.2.8

With mesa 17.3.9 and 18.1.0 this and original bugs are unable to reproduce.
Comment 9 Mark Janes 2018-05-02 15:27:46 UTC
*** Bug 104457 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.